Trying to refigure out subtitles settings I had

For help and support with Linux-specific issues
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
crimson30
Posts: 8
Joined: Sun Oct 29, 2017 12:29 pm

Re: Trying to refigure out subtitles settings I had

Post by crimson30 » Thu Nov 09, 2017 11:33 am

Sami32 wrote:
Sun Nov 05, 2017 11:25 am
@crimson30 Part of your issue come from that you didn't read our Wiki. Click on the green link into my signature and read it carefully.
You are using the default settings that disable subtitles for english, and that is your case.
I did read it. I read it again and I still can't get it to work.

If you're referring to the language priority settings, I've tried various settings, to include eng for the Subtitles language priority and *,eng;*,und for the Audio/subtitle language priority and that doesn't work.

Note that if *,* and leaving it blank are not correct for the Subtitles language priority (to always display subtitles), this FAQ should be changed: http://www.universalmediaserver.com/faq/#Video3

User avatar
Sami32
Posts: 822
Joined: Mon Apr 11, 2016 5:09 am

Re: Trying to refigure out subtitles settings I had

Post by Sami32 » Fri Nov 10, 2017 2:09 am

@crimson30
I did read it. I read it again and I still can't get it to work.
Good, so you will need to post a new log with the correct parameters that you have set now, as it was not the case in your precedent log, that we can look at your issue.

crimson30
Posts: 8
Joined: Sun Oct 29, 2017 12:29 pm

Re: Trying to refigure out subtitles settings I had

Post by crimson30 » Fri Nov 10, 2017 6:26 am

I've attached the results leaving Subtitles language priority blank and setting Audio/subtitle language priority to *,eng;*,und
Attachments
UMS.conf
(54.3 KiB) Downloaded 29 times
debug.zip
(854.18 KiB) Downloaded 26 times

User avatar
Sami32
Posts: 822
Joined: Mon Apr 11, 2016 5:09 am

Re: Trying to refigure out subtitles settings I had

Post by Sami32 » Fri Nov 10, 2017 6:57 am

LOL
TRACE 2017-11-09 11:21:48.723 [HTTPv2 Request Worker 4] Searching for a match for: en with eng and off
TRACE 2017-11-09 11:21:48.723 [HTTPv2 Request Worker 4] Disabled the subtitles: id: 0, type: UNKNOWN, lang: off
You have edited your UMS.conf, but leaved the line commented so...no effect.

Code: Select all

# audio_subtitles_languages = *,eng;*,und
Why don't you simply do it from the GUI's Transcoding Settings subtitles sub tab ?
Last edited by Sami32 on Fri Nov 10, 2017 7:09 am, edited 2 times in total.

Nadahar
Posts: 1245
Joined: Tue Jun 09, 2015 5:57 pm

Re: Trying to refigure out subtitles settings I had

Post by Nadahar » Fri Nov 10, 2017 6:58 am

@Sami Because he's running UMS headless.


crimson30
Posts: 8
Joined: Sun Oct 29, 2017 12:29 pm

Re: Trying to refigure out subtitles settings I had

Post by crimson30 » Fri Nov 10, 2017 8:45 am

Sami32 wrote:
Fri Nov 10, 2017 6:57 am
You have edited your UMS.conf, but leaved the line commented so...no effect.
Doh. That was it. :oops:

Those sneaky octothorpes.

crimson30
Posts: 8
Joined: Sun Oct 29, 2017 12:29 pm

Re: Trying to refigure out subtitles settings I had

Post by crimson30 » Sat Nov 11, 2017 10:39 am

Also, for anyone reading this in the future, please note that I ran into a problem using *,eng;*,und (subtitles wouldn't play) and had better luck using *,*

Post Reply