Solved problem with Wired Connection (activation of network connection failed)

For help and support with Linux-specific issues
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
Posts: 3
Joined: Sat Jul 21, 2018 4:35 am

Solved problem with Wired Connection (activation of network connection failed)

Post by Snake19 » Sat Jul 21, 2018 5:14 am

Just want to share my solution with Wired Connection between my PS3 & UMS on Linux.
I installed Ubuntu on my laptop and connected it with my PS3 via cable. But it didn't work. UMS can't see renderer and Ubuntu show me pop-up message at the top of the screen: activation of network connection failed.Then i connected via Wi-Fi and it worked great. Looking whole Internet for answer, but didn't find it.
So, after hours of solving i find a decision: go to Ubuntu Settings - Network - Wired (click on it) - IPv4 - IPv4 method - Link-Local only.
Then start UMS - General configuration - Network settings - Force networking on interface - and choose your ps3 ip-adress. Restart UMS (not restart server, but quit UMS and launch it again).
That's all.
Screenshot from 2018-07-20 20-10-04.png
Screenshot from 2018-07-20 20-10-04.png (41.85 KiB) Viewed 14176 times
Screenshot from 2018-07-20 20-09-38.png
Screenshot from 2018-07-20 20-09-38.png (77.42 KiB) Viewed 14176 times

Posts: 1476
Joined: Tue Jun 09, 2015 5:57 pm

Re: Solved problem with Wired Connection (activation of network connection failed)

Post by Nadahar » Sat Jul 21, 2018 7:36 am

This seems to have been a problem with your network configuration, not UMS as such. If you have plugged a cable between the PC and the PS3 directly, you'd need to configure their IP addresses manually. That's not the "normal" way to do it, normally there's a router on the network running DHCP, which assigns IP addresses automatically.

I don't know exactly what this "Link Local" option does, but it probably use some kind of auto-negotiated IP. When you have multiple network interfaces with valid IPv4 addresses, you might have to "force" the interface since UMS will simply pick the first one it finds with a valid IP.

Post Reply