DVD not playing at all

For help and support with Linux-specific issues
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
SZoPer
Posts: 3
Joined: Thu Dec 05, 2013 7:43 am

DVD not playing at all

Post by SZoPer » Thu Dec 05, 2013 8:12 am

Hello.
First of all congratulations on a fine piece of software :-) Now, to the point.
I have only 2 DVDs at home and none of them work like it should. This thread is about a disc that plays flawlessly on a PC, but doesn't through wireless DLNA. I mount the disc on the PC, so VIDEO_TS directory is accessible at path: /run/media/szoper/PULP_FICTION/VIDEO_TS. It is also shared with TV and I can traverse to the directory, but when I select "Title 1" I only get "Please wait" for a minute and it all returns to the previous screen.
All the information are in the attached log files - my TV is Panasonic TX-P50ST60 and UMS 3.2.0 is running on ArchLinux x86_64. The problem is nothing new and at first I've spotted it at version 3.0.0beta-something.

What am I doing wrong? Is this my environment issue or a UMS bug?
Attachments
ums_dbg - dvd not playing.zip
(17.41 KiB) Downloaded 85 times

Mandrake
Posts: 4
Joined: Fri Jun 15, 2012 12:42 pm

Re: DVD not playing at all

Post by Mandrake » Wed Dec 11, 2013 7:26 am

I'm no expert here, but I believe you'll probably want to encode the video from the DVD first (turning it into an MP4, an MKV, or the like). If you're sharing the folder with your television, it's just seeing the data directories, and has no clue what to do with the VOB files, etc..

My suggestion would be to use Handbrake to encode the DVD first, then place the resulting MP4 in a directory that UMS can see. From there, your television should be able to view/play it.

ExSport
Posts: 596
Joined: Wed Oct 10, 2012 1:57 am

Re: DVD not playing at all

Post by ExSport » Thu Dec 12, 2013 1:45 am

Not true. UMS/PMS is smart enough to deal with it. If you will share separate VOB files, UMS will shares them as is but if there is full DVD structure in "VIDEO_TS" folder shared, including the folder name, UMS will detect it as DVD and will offer you separate titles present on DVD to be played. There is no need to convert it outside UMS.

SZoPer
Posts: 3
Joined: Thu Dec 05, 2013 7:43 am

Re: DVD not playing at all

Post by SZoPer » Thu Dec 12, 2013 11:12 pm

Exactly. UMS does support DVDs and when it discovers VIDEO_TS directory it should play it just fine. I've mentioned my other DVD disc - despite a terrible audio/video desynch it is rendered decently. Well, at least I see some scenes...
The problem still persists in UMS 3.3.0 - log files attached. I don't know what's so specific about this PULP FICTION disc.
Attachments
ums_dbg_3.3.0 - dvd not playing.zip
(17.69 KiB) Downloaded 112 times

ranaenovak
Posts: 1
Joined: Wed Sep 21, 2016 7:30 pm
Location: http://javtop.me/
Contact:

Re: DVD not playing at all

Post by ranaenovak » Wed Sep 21, 2016 7:32 pm


Post Reply