[Tutorial] Installing UMS 4.4.0 on Ubuntu Server 14.04.1

For help and support with Linux-specific issues
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
99altezza
Posts: 10
Joined: Sun Jul 26, 2015 10:12 pm

Re: [Tutorial] Installing UMS 4.4.0 on Ubuntu Server 14.04.1

Post by 99altezza » Sat Aug 01, 2015 4:12 pm

I'm running ubuntu 14.04 desktop and I also installed Gnome.

I don't have a run option when I right click on the UMS.sh file either, and when I input the text into Terminal - it'll didn't run properly, do I only need to run part of the text file?

Tonne M
Posts: 29
Joined: Sat Jul 18, 2015 6:29 am

Re: [Tutorial] Installing UMS 4.4.0 on Ubuntu Server 14.04.1

Post by Tonne M » Sat Aug 01, 2015 6:22 pm

Seems like I'm stuck here.
I ran Ubuntu five years ago, 10.04, and things were way different. All I can do for you is put Ubuntu 14.04 on a USB stick, run it from there and figure out how things are in Ubuntu.

Personally, I run Linux Mint 17 (Petra) with Cinnamon. Mate would also be a good choice though. Linux Mint 17 is based on Ubuntu 14.04 but seems (to me) way more user-friendly.
Maybe, since your setup on the laptop is relatively new, it would be an idea to give Linux Mint a try.

There is however one more thing you could try in Ubuntu. Rightclick on UMS.sh, click "properties" then "permissions" and check something like "make this file executable".

If that won't work I'm sorry but then my experience is lacking.

Should you decide to give Mint a try, make sure you download and install the version with codecs. Read here: http://www.linuxmint.com/download.php
So, one of the "Multimedia support" versions.

kleverbear
Posts: 1
Joined: Mon Aug 17, 2015 9:57 pm

Re: [Tutorial] Installing UMS 4.4.0 on Ubuntu Server 14.04.1

Post by kleverbear » Mon Aug 17, 2015 10:06 pm

Hi all, so i see some of you have saved your UMS to a different directory other than what the tutorial called for and are having problems getting the UMS.sh script to work correctly. If you create a symlink from the suggested location /usr/ums to your working directory:

Code: Select all

ln -s /MY/WORKING/DIR/ums /usr/ums
This will make the UMS.sh file work correctly with the command:

Code: Select all

service ums start/stop
Any questions msg me.

therevenger
Posts: 2
Joined: Tue Sep 01, 2015 8:51 am

Re: [Tutorial] Installing UMS 4.4.0 on Ubuntu Server 14.04.1

Post by therevenger » Wed Sep 02, 2015 6:04 am

Hi,
Ubuntu headless server 12.04
Java Oracle 7
UMS 5.2.2

Nice topic thank a lot.
I used to run old PMS but I need to "upgrade" to UMS because transcoding MKV files is better for PS3.
I have make the install, that all OK, but i need some help because UMS is not PMS !
init.d script works fine, nice !

My questions :
Where is the log file ? I have nothing into /usr/ums.

Why my UMS.conf is not read by ums at startup ? ums boot with the server, but "out of the stock", nothing change.
I edit UMS.conf with "sudo nano", I don't understand what's the matter (without logs, not easy to solve by myself...)

It's deprecated to run one time the UMS.sh script ?

Sorry for my bad english.
Thanks a lot.

manan
Posts: 5
Joined: Fri Jul 24, 2015 3:53 am

Re: [Tutorial] Installing UMS 4.4.0 on Ubuntu Server 14.04.1

Post by manan » Mon Sep 07, 2015 7:15 pm

Wow, thank you for the post!
Regart!

likeaboogie
Posts: 2
Joined: Wed May 27, 2015 3:34 am

Re: [Tutorial] Installing UMS 4.4.0 on Ubuntu Server 14.04.1

Post by likeaboogie » Sat Oct 10, 2015 11:55 pm

Thank you !
but i don't have access to subfolders.
How to fix it ?

anndrox
Posts: 3
Joined: Thu Dec 24, 2015 12:38 am

Re: [Tutorial] Installing UMS 4.4.0 on Ubuntu Server 14.04.1

Post by anndrox » Thu Dec 24, 2015 12:42 am

therevenger wrote:Hi,
Ubuntu headless server 12.04
Java Oracle 7
UMS 5.2.2

Nice topic thank a lot.
I used to run old PMS but I need to "upgrade" to UMS because transcoding MKV files is better for PS3.
I have make the install, that all OK, but i need some help because UMS is not PMS !
init.d script works fine, nice !

My questions :
Where is the log file ? I have nothing into /usr/ums.

Why my UMS.conf is not read by ums at startup ? ums boot with the server, but "out of the stock", nothing change.
I edit UMS.conf with "sudo nano", I don't understand what's the matter (without logs, not easy to solve by myself...)

It's deprecated to run one time the UMS.sh script ?

Sorry for my bad english.
Thanks a lot.
you have to modify the script in /etc/init.d/ums
"UMS_PROFILE=[current ums.conf]"
the terminal command to access it is " sudo nano /etc/init.d/ums
after making changes ctrl+o and then ctrl+w save and exit
I'm new to linux and I think that is the correct way to do it. The problem I am having now is that when ums service starts it does not mount my external hard drive right away :(

anndrox
Posts: 3
Joined: Thu Dec 24, 2015 12:38 am

Re: [Tutorial] Installing UMS 4.4.0 on Ubuntu Server 14.04.1

Post by anndrox » Thu Dec 24, 2015 12:43 am

likeaboogie wrote:Thank you !
but i don't have access to subfolders.
How to fix it ?
try changing the permissions of the folder using chmod

Post Reply