Ubuntu Gnome - Can't see UMS?

For help and support with Linux-specific issues
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
AngryMan
Posts: 1
Joined: Fri Apr 03, 2015 8:31 pm

Ubuntu Gnome - Can't see UMS?

Post by AngryMan » Fri Apr 03, 2015 8:39 pm

Im using Ubuntu Gnome 14.04.2 64bit, just installed latest UMS..

I run it from a terminal or even tell it to run the UMS.sh on start-up, i have the Java 7 thingy installed..

It works on regular Ubuntu and xubuntu, I can see the tray icon at the top right of the screen, when i click on it, it opens, but that doesnt show on Ubuntu Gnome, had to use gnome tweak tool with an old system icon extension just to see the UMS icon, but it still doesn’t show or load or open when i click it. :(

Can someone help me get the tray icon to show or load or is there another command i can do to make it open?

Thanks in advance, otherwise I love UMS, used it on xubuntu and even in Windows, convinced many people to switch to it from PS3 media server and even the stupid windows media player/DLNA crap.

Before posting any replies, I think someone should install Ubuntu GNOME 14.04.2 64bit, then install the java 7 from the software enter, then download and extract the latest UMS 5.1.1, then run it, the initial prompts come up to configure it and the network speed etc. but then... nothing, running it again from a terminal makes it load, but I really like to see that graphical interface for configuring it :)

As you can tell by my username, i normally post in a bit of an angry manor, with swear words and everything, but i actually like UMS, so far this and some random glitches on the previous version with my samsung TV not playing some files when it used to is it's only downfall (that and enabling the cache option tends to make all files not play on my TV, so disabling it makes it work...not sure why, this too doesn’t happen in Windows but does affect linux versions of ubuntu (kubuntu, xubuntu gnome etc.)

JP Rockagetty III
Posts: 1
Joined: Sun Apr 05, 2015 5:46 pm

Re: Ubuntu Gnome - Can't see UMS?

Post by JP Rockagetty III » Sun Apr 05, 2015 6:43 pm

AngryMan, I feel your pain. I really do. I'd like to help, but I'm not sure I can. It took me half a dozen Ubuntu 14.04 installs before Ubuntu would work (only certain memory modules work in certain slots, my motherboard must have timing issues or something).

I put my UMS installation in /home/mike/UMS-5.1.1. If there is a better place to put it, I hope someone will tell me. Anyway, I installed UMS before I installed the Java, and that was a mistake. I had to uninstall UMS 5.1.1 (and I forgot about the "sudo rm", because I come from a Mandriva background, with "root" and "regular" users).

I rebooted, got a uxterm, and typed "tar -xvf" and expanded the tarfile again. Navigated to the correct directory, typed "./UMS.sh", and I was asked 4 questions. Interesting, when I removed and reinstalled UMS 5.1.1 a couple more times, to be sure I could do this reliably, I was never asked those four questions again. On a later reinstall, I even got the panel THE FIRST TIME like I always wanted/expected (maybe the blu-ray was turned on this time and it was not before). I always got the UMS icon in the upper right, and that means I could bring up the main panel and change the "start minimized" to "no". Interesting, I never had to change ownership/group of any files/directories, or change any "rwxrwxrwx" bits during this time.

(The answers to the four questions might be stored in some .rc file somewhere, like the old Windows 3.1/95/98 *.ini file. Maybe that info never got deleted, and later installs read the answers to those four questions.)

Please note that if you type <CTRL> <ALT> <F2> and install from a character mode screen, you will never see any GUI. You have to launch the commands from an xterm inside Gnome, apparently the install script knows that you're inside the GUI. (I added the uxterm to my launcher, on the left side of the screen, in case I need to do more of these kinds of operations.)

(I still have not learned enough to start the UMS server automatically on bootup, whether or not anyone is logged in. So I have much learning to do.)

(Also I don't know how to use the config files - perhaps I don't need to specify one. Perhaps UMS will detect my device when it announces itself on the network, like when you turn on a device or wake up a smartphone. If any device can show up at any time, adding a new config file and restarting UMS would be inconvenient.)

(I also don't know how well UMS finds the different video/audio content. Do I need to use the "virtual_folders" described in one of the config files? I might need that when I start adding gigs of content and more hard drives.)

If this does not help, or if there is more detail you can give to describe the problem, please let us know. I'll check back, although not as soon as I'd like -- everybody is so busy these days....

Post Reply