ubuntu UMS.conf problem

For help and support with Linux-specific issues
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
anndrox
Posts: 3
Joined: Thu Dec 24, 2015 12:38 am

ubuntu UMS.conf problem

Post by anndrox » Thu Dec 24, 2015 12:46 pm

I followed the instructions here viewtopic.php?f=10&t=2761
and when I edit my UMS.conf to include my shared folders they do not show up. However I can load the jar file through terminal and everything works... Is it the ums script in init.d ?

djmonki
Posts: 1
Joined: Wed Jan 27, 2016 3:13 pm

Re: ubuntu UMS.conf problem

Post by djmonki » Wed Jan 27, 2016 3:17 pm

I am having exactly the same issue, by following the same thread in the link.
With the script 'service ums start' - the server starts up and can be seen on my ps3 and other devices.
However, it does not take any of the settings from the UMS.conf file, and just has a limited option of all my drives on the ubuntu 14.04.1 LTS server.

If, I locally manually runit with a GUI, it has all the correct settings !!??!?
Can someone help please.

Nadahar
Posts: 1441
Joined: Tue Jun 09, 2015 5:57 pm

Re: ubuntu UMS.conf problem

Post by Nadahar » Wed Jan 27, 2016 3:37 pm

UMS is clearly looking in the wrong place for the config file when using the script. By default that is ~/.config/UMS (that is, if no profile path argument is given). I really don't know bash and init.d, but the profile path must point to the folder where UMS.conf is located. It seems like this line is setting it:

Code: Select all

UMS_PROFILE=/etc/ums
So the question is if the UMS.conf you edit is in that folder or not.

tmk
Posts: 21
Joined: Wed Jun 06, 2012 2:34 pm

Re: ubuntu UMS.conf problem

Post by tmk » Mon Feb 01, 2016 3:37 am

...also, ensure path is 775. Share your UMS.conf and debug if still not working...
Server Platform: Linux Xubuntu 14.04 (LTS)
Renderer: Sony Bravia KDL-40W5100

newbietux
Posts: 16
Joined: Sun Apr 17, 2016 4:57 am

Re: ubuntu UMS.conf problem

Post by newbietux » Sun Apr 17, 2016 6:06 am

I think you must additionally add this line:
export UMS_PROFILE

And then it must be working.

I hope that was the right way.

Post Reply