Encrypted dvd playback problem.

For help and support with Linux-specific issues
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
asmol
Posts: 24
Joined: Sun May 28, 2017 3:54 am

Re: Encrypted dvd playback problem.

Post by asmol » Wed May 31, 2017 2:46 pm

Sami32, I managed! ;)) I installed MPlayer version 1.3, which included MEncoder and the picture went! Everything works and even very good! ;) Only here there is no possibility of searching the clip track. It depends on the media server, or already from my client, who sends information to the media player? But still I'm very pleased with what happened! ;)

User avatar
Sami32
Posts: 822
Joined: Mon Apr 11, 2016 5:09 am

Re: Encrypted dvd playback problem.

Post by Sami32 » Wed May 31, 2017 11:55 pm

@Andrey I'm glad to know that you finally get it to work :)

I was suspecting your MPlayer/MEncoder issue, as we use an old own version, and the fact that it's known to be not too reliable but FFmpeg do not handle DVD :(
And all the Linux system are well known to be so different that it just no thinkable to make something work without issue on all of them :(

Thank you for your feedback 8-)

asmol
Posts: 24
Joined: Sun May 28, 2017 3:54 am

Re: Encrypted dvd playback problem.

Post by asmol » Thu Jun 01, 2017 10:01 am

Yes, I'm glad for that, too. The only question that remains is how to change the aspect ratio in MEncoder. It seems to me that this encoder shows the original ratio, but I need it to be 16:9, is this possible?

User avatar
Sami32
Posts: 822
Joined: Mon Apr 11, 2016 5:09 am

Re: Encrypted dvd playback problem.

Post by Sami32 » Thu Jun 01, 2017 11:09 am

Yes, normally it should have been done automatically. I never read any DVD with it, but @Nadahar recently reported like you, so it's possible that it has been broken.

You can manually add it into your renderer configuration file:

Code: Select all

KeepAspectRatio = true
KeepAspectRatioTranscoding = true
If that doesn't fill your need, delete these lines and add that one:

Code: Select all

CustomMencoderOptions = -vf softskip,expand=::::1:16/9:2,scale=1283:720 -lavcopts aspect=16/9
If it's still not as you expect, you'll need to adapt it to your need.
Please, take time to return feedback. Thank you 8-)

Hoping that helped.

asmol
Posts: 24
Joined: Sun May 28, 2017 3:54 am

Re: Encrypted dvd playback problem.

Post by asmol » Thu Jun 01, 2017 11:41 am

Yes, the first two lines worked perfectly. Only the picture after the change of sides began to show small jerks. Can this be fixed somehow, or should we wait for the next versions of the mediaserver?

User avatar
Sami32
Posts: 822
Joined: Mon Apr 11, 2016 5:09 am

Re: Encrypted dvd playback problem.

Post by Sami32 » Thu Jun 01, 2017 11:51 am

Sorry, i don't understand what you mean, so i cannot help you on that. I'm not an english native so that doesn't really help.
Except if you can rephrase it or post a photo.

asmol
Posts: 24
Joined: Sun May 28, 2017 3:54 am

Re: Encrypted dvd playback problem.

Post by asmol » Thu Jun 01, 2017 11:55 am

Ok, nothing terrible. I'm from Russia and I also use Google translator to communicate with you. I'll try to wait for new versions of the program, but for now I will use the old aspect ratio. Anyway, thank you very much - you helped me a lot! ;)

User avatar
Sami32
Posts: 822
Joined: Mon Apr 11, 2016 5:09 am

Re: Encrypted dvd playback problem.

Post by Sami32 » Thu Jun 01, 2017 12:09 pm

You're welcome :)
Congratulation for your english anyway ;) Yes, Google Translate can be "weaky" in the translation, but it far better than nothing :D

I prefer tell you that nothing will change in the next version concerning that point. I don't think @Nadahar will modify it, as like me, he never use the DVD or ISO.

Did you tried the second option that i given you, perhaps it should give you a better result ?

asmol
Posts: 24
Joined: Sun May 28, 2017 3:54 am

Re: Encrypted dvd playback problem.

Post by asmol » Thu Jun 01, 2017 1:39 pm

Yes, I tried both functions. When the aspect ratio included - picture video is as if braking. As soon as I turn off the keep aspect ratio everything is displayed perfectly. Do you think there is any way to solve this problem?

User avatar
Sami32
Posts: 822
Joined: Mon Apr 11, 2016 5:09 am

Re: Encrypted dvd playback problem.

Post by Sami32 » Thu Jun 01, 2017 1:51 pm

Sorry, i don't really understand what is your issue, only that your display is not as you like.
You can ask to @SubJunk, as he is an english native, the only one by now, and the only video developper here.

To answer your question: Yes, there is a way to solve that.
But it need people that understand your issue, to give you a fix.

EDIT: What you can do, is open an issue there and explain your issue:
https://github.com/UniversalMediaServer ... ver/issues

Post Reply