Globally disable transcoding

For help and support with Mac OS X-specific issues
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
Atalantia
Posts: 12
Joined: Sun Feb 18, 2018 2:09 pm

Globally disable transcoding

Post by Atalantia » Sat Jun 08, 2019 2:06 pm

Hello,
how do I globally disable transcoding? I made a conf file for every device that contains:

Code: Select all

Device = 192.168.0.12
disable_transcode_for_extensions = mp4,m4v,mkv,avi,mpg,mpeg
But do I need that for each device? Can I do?:

Code: Select all

Device = 192.168.0.12 192.168.0.13 192.168.0.14 
or:

Code: Select all

Device = 192.168.0.12,192.168.0.13,192.168.0.14 

Nadahar
Posts: 1435
Joined: Tue Jun 09, 2015 5:57 pm

Re: Globally disable transcoding

Post by Nadahar » Sat Jun 08, 2019 3:04 pm

There's a setting in the global configuration to do this: https://github.com/UniversalMediaServer ... #L649-L656

That said, this should only be used for troubleshooting or similar, the whole idea of "disabling transcoding" is a logical fallacy. Transcoding is only used when the renderer cannot otherwise play the media. That means that disabling transcoding is the same as "disabling playback" of said media. I doubt that's what you're after.

What is normally the real problem is that the renderer is configured wrong, so that UMS think it has to transcode when it doesn't. The fix is to correct the configuration, not disable transcoding.

Atalantia
Posts: 12
Joined: Sun Feb 18, 2018 2:09 pm

Re: Globally disable transcoding

Post by Atalantia » Sun Jun 09, 2019 3:09 pm

Thanks for answering. I'll look at little bit closer. Maybe I can disable all the conf file I made.

Post Reply