Maximum supported version of UMS

For help and support with Mac OS X-specific issues
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
tomaz
Posts: 1
Joined: Mon Feb 27, 2017 10:05 am

Maximum supported version of UMS

Post by tomaz » Mon Feb 27, 2017 10:07 am

Is information available anywhere as to what the maximum supported version is on each respective version of Mac OS X (or alternatively what the minimum required Mac OS X version is for each UMS version)? E.g. what's the last version that will run on Mac OS X 10.3, 10.4, 10.5, 10.6, 10.7, etc.?

User avatar
Nadahar
Developer
Posts: 1199
Joined: Tue Jun 09, 2015 5:57 pm

Re: Maximum supported version of UMS

Post by Nadahar » Mon Feb 27, 2017 10:32 am

No, UMS is a Java application so it doesn't need compatibility with the OS version in that sense. What matters is which Java version you're running. Current versions of UMS work on Java 7 and Java 8. The last version of UMS that supported Java 6 was 5.2.3.

The question is which Java version you can manage to get working on the different OS iterations, Apple hasn't made it easy since they used to bundle "their own"Java version with OS X, but then found out that they didn't bother to anymore so they abandoned their Java 6 implementation. As a result it can be hard to get working because it doesn't work with newer updates etc. Oracle Java 7 will only work from a certain OS X version, so there might be some versions that you need to be creative to get Java working properly. In any case, UMS doesn't care as long as Java 7 or 8 is working.

Post Reply