Issues with 4.0.0a1

Download and discuss official beta builds here
User avatar
SubJunk
Lead Developer
Posts: 2838
Joined: Sun May 27, 2012 4:12 pm

Re: Issues with 4.0.0a1

Post by SubJunk » Fri Aug 01, 2014 5:07 pm

Madoka wrote:I like how FFmpeg sends a 5.1 audio stream for most of my video files.
As of 4.0.1 we fixed the bug that caused FFmpeg to upconvert 2 channel audio to 6 channel audio, so maybe you won't like that :p
Madoka wrote:This may be fixed already as I see commits relating to subtitles (looking forward to trying 4.0.1), but FFmpeg will ignore the shadow codes for the Default subtitles. I get no shadows at all with FFmpeg when MEncoder will give me a proper shadow.
It seems like FFmpeg ignores a lot of ASS/SSA settings despite us setting them correctly. I guess we will need to start issue reports on their bug tracker.

Madoka
Posts: 316
Joined: Fri Jun 01, 2012 12:51 pm

Re: Issues with 4.0.0a1

Post by Madoka » Sat Aug 02, 2014 4:22 am

So, it was an audio bug!? LOL! Well, if it's saving bandwidth this way, I'm all for that.

4.0.1 seems to respect the Default style settings properly now, without changing the color, and with proper shadows. Thanks!

Still, no control over .srt subtitles position and size, although you may be still working on that.

I did find a new FFmpeg bug. It does not like Japanese (perhaps Asian in general) names for subtitle files. So, I have this 156 episode series where the name of the files is entirely in Japanese so the subtitles' names are also in Japanese. FFmpeg will not work and return an error of 1 in the Log Tab. However, you can go into the Transcode folder and manually select FFmepg without the subtitles and it will transcode the file. I then changed both names to English, and it worked. You can then change a file/subtitle set that works in English (I tried a completely different show) to say, スペシャル, and FFmpeg will not work and give the error again. So, it's not the files themselves, but the name, I think. MEncoder works fine.

You can try this yourself. Change a file/subtitle set to スペシャル as the name and try it. I can post debug logs if you like, but I thought I might be easier for you to try it yourself.

BTW, is Java 8 recommended over Java 7 now for UMS?

Thanks!

Post Reply