4.1.0, FFmpeg, MEncoder, and Subtitles

Download and discuss official beta builds here
Post Reply
Madoka
Posts: 316
Joined: Fri Jun 01, 2012 12:51 pm

4.1.0, FFmpeg, MEncoder, and Subtitles

Post by Madoka » Sun Aug 31, 2014 6:51 pm

I built 4.1.0 using UMSBuilder 1.8 as I was curious about the new "Defer to Mencoder" option.

With the default settings, everything works as expected.

With "Use Fontconfig" checked in the FFmpeg settings, FFmpeg will still generate it's temp subs from .srt subs in the Subs folder even though it will then default to MEncoder. This will then have funny results if the same file is replayed with MEncoder.

So, say there are 2 videos, both with .srt subs. Play File 1 first, get correct subs with Mencoder (as intended from the settings in the Subtitles tab), stop before the end. Play File 2, get correct subs, stop before the end. Resume File 1, and the subs MEncoder displays are smaller than before with a much thicker border. The subs are displayed, just with the wrong settings, almost as if FFmepg using Fontconfig first messed Fontconfig up for MEncoder. I had noticed this behavior before but hadn't mentioned it as I had to manually transcode the subtitles from the Transcode folder to make it happen. But now that FFmpeg hands off to MEncoder, it's much easier to reproduce. I'm sending to a PS3.

Not a huge deal as unchecking Fontconfig will not have this behavior. I don't have debug logs right now as I'm on another computer.

Post Reply