Version 7.0.0 released

Announcements about Universal Media Server
User avatar
SubJunk
Lead Developer
Posts: 2842
Joined: Sun May 27, 2012 4:12 pm

Version 7.0.0 released

Post by SubJunk » Tue Mar 27, 2018 5:07 pm

General:

You can download it from the front page.

This release adds new features to dynamically sort and add your media, most notably there are new "TV Shows" and "Movies" folders that are populated automatically with content from your shared folders.


Changes since 6.8.0:
  • General:
    • Added "TV Shows", "Movies", "3D Movies", and "Unsorted" folders to the "Media Library" folder
    • Added right-click menu to navigation pane
    • Renamed "Cache" folder to "Media Library" folder and enabled it by default
    • Changed "Hide" options to "Show", e.g. "Hide Media Library folder" becomes "Show Media Library folder"
    • When a file is added/changed/removed in a shared folder, UMS detects it
    • Fully played tracking is stored in the SQL database
    • Shared folders are scanned for changes on startup (configurable)
    • Made folder scanning up to 10x faster
    • Made Media Library browsing faster
    • Gave folder scanning a lower priority than other UMS functions to make them work more smoothly
    • Fixed some bugs related to sending media metadata (org_pn) to renderers
    • Fixed bug where removing a directory in UMS does not remove its contents from the Media Library.
    • Fixed sorting in dynamic folders
    • Reduced lookups and bandwidth to OpenSubtitles
    • Fixed MusicBrainz bugs
    • Fixed many other bugs
  • Languages:
    • Synchronized translations with Crowdin
  • Renderers:
    • Added Samsung 8 Series config
    • Updated FetchTV config
    • Improved support for Samsung Galaxy S7

Changes since 7.0.0-rc2:
  • General:
    • Made folder scanning up to 10x faster
    • Made Media Library browsing faster
    • Gave folder scanning a lower priority than other UMS functions to make it work more smoothly
    • Added configuration option to toggle shared folder scanning on startup
    • Fixed "By Date" virtual folders on joined folders
    • Fixed a database initialization bug
    • Fixed order of "By date" folders, now they go from newest to oldest
    • Fixed some bugs related to sending media metadata (org_pn) to renderers
  • Languages:
    • Synchronized translations with Crowdin
  • Renderers:
    • Added Samsung 8 Series config
    • Updated FetchTV config
    • Improved support for Samsung Galaxy S7

Compatibility notes:

These releases work on all versions of Java 7 onwards.
The Windows releases work on Windows Vista onwards. We are working on supporting older versions.

erick diangilis
Posts: 141
Joined: Sun May 22, 2016 8:25 am

Re: Version 7.0.0 released

Post by erick diangilis » Wed Mar 28, 2018 1:50 am

thanks for the release i will test on the ps4 media player to see how its going to behave if i found a bug or something i ll let you know.
keep up with the good work and have a good day. :D ;)

Rhialto
Posts: 14
Joined: Mon Jan 13, 2014 1:47 am

Re: Version 7.0.0 released

Post by Rhialto » Wed Mar 28, 2018 1:45 pm

SubJunk wrote:
Tue Mar 27, 2018 5:07 pm
The Windows releases work on Windows Vista onwards. We are working on supporting older versions.
Why put energy and time on that? Stick on 7+ for now, XP is not secure and should go.

Meanwhile I will try to find someone to package it for a QNAP NAS.

User avatar
pipin
Posts: 65
Joined: Fri Dec 28, 2012 12:17 am

Re: Version 7.0.0 released

Post by pipin » Thu Mar 29, 2018 6:38 pm

Thanks for the new version, great work.

Strange thing for me , it worked in the beginning and now it stopped working at all, ums won't event start. Clean install and going back to 6.8.0 doesnt work either.
The only thing I changed was flashing a new bios for the mainboard. On a clean install it asks after the language and stops with the logo screen. :shock:

Edit:
Ok works now. There one folder which isnt deleted by the uninstall routine, after deleting it manually its working again.
Regards,
Jens
-----------
Devices used with UMS : - Windows 10 PC, Samsung UE32 F4580SS, Samsung UE48H6600

AuthenticM
Posts: 24
Joined: Mon Sep 30, 2013 12:49 pm

Re: Version 7.0.0 released

Post by AuthenticM » Fri Mar 30, 2018 5:52 am

Thanks!
SubJunk wrote:
Tue Mar 27, 2018 5:07 pm
We are working on supporting older versions.
What's the reason for wanting to support pre-Windows7 OSes?

erick diangilis
Posts: 141
Joined: Sun May 22, 2016 8:25 am

Re: Version 7.0.0 released

Post by erick diangilis » Fri Mar 30, 2018 9:48 am

i've tested out on the ps4 media player before it updated from version 3.50 to version 4.00 wich is have two new features one is to shuffle and the other one is to repeat vídeos. on the previous version 3.50 was working fine but after the update to 4.00 i started to have some playback issues like disconnections or vídeos stopping to work when the memory usage is too high i also noticed a playback quality on the vídeos is degraded a little bit i believe due to imcompatibilty issues since the 7.00 was released before the media player updated. the sound quality is ok but the áudio sync got a little worse after the update wich i also believe due to incompatibilty from the ums with this new media player version.
i also took a liberty to try the new java 11+5 early acess to see how is going to behave on the 7.00 version and until 10 the ums Works fine but in the 11 some of codec options like avisynth ffmpeg, mencoder and vlc can't be turned on they're completely locked.


i hope this report can help somehow have a good day. ;)

Paradox
Posts: 127
Joined: Tue Dec 17, 2013 5:50 am

Re: Version 7.0.0 released

Post by Paradox » Mon Apr 02, 2018 12:16 pm

Rhialto wrote:
Wed Mar 28, 2018 1:45 pm
SubJunk wrote:
Tue Mar 27, 2018 5:07 pm
The Windows releases work on Windows Vista onwards. We are working on supporting older versions.
Why put energy and time on that? Stick on 7+ for now, XP is not secure and should go.

Meanwhile I will try to find someone to package it for a QNAP NAS.
XP is NOT the only OS prior to Vista, there was Windows 2000 and 2003. 2003 particularly being a server OS is probably still used quite a bit in small server environments. Your ISP may even still run that on some backend hardware, like switching or DNS lookup. Oh and just because Microsoft no longer supports a OS with updates does not necessarily make it more or less secure, in fact being a server OS depending on what you are running on it and what it is connected to (firewall/brick routers) can make it far more secure that cheapo home OS'es like Windows 10 which come complete with numerous back doors and spyware built in for you.

Running third party security software on any windows OS makes it far more secure than any out of the box solution, newer is not automatically more secure.
This as just one of many examples shows that...
Windows vulnerabilities
https://www.cvedetails.com/product-list ... stems.html
take note of the 6th and 7th down entries, those being...
https://www.cvedetails.com/product/3223 ... ndor_id=26
and
https://www.cvedetails.com/product/107/ ... ndor_id=26

Windows 10 has had in TOTAL more vulnerabilities discovered inside of 5 years than 2000 had in over a decade of its entire life.
Couple that with the fact many still have a old windows box churning away just for internal network stuff and this being a media serving program and im not shocked they would like to see it still work if possible.

PS......... If you get this to work on a QNAP device that will be impressive, there was once an old version that ran on SOME Synology hardware but that was more than a few years ago AFAIK. Its became far more java centric over time.
AuthenticM wrote:
Fri Mar 30, 2018 5:52 am
Thanks!
SubJunk wrote:
Tue Mar 27, 2018 5:07 pm
We are working on supporting older versions.
What's the reason for wanting to support pre-Windows7 OSes?
I suspect its pretty much as i explained above, newer is not always better, not to mention there are still a fair slab of people running older versions of Windows. Windows XP in particular has a lot of media related stuff with regards to gaming emulation and video capture which does not work on newer versions. Particularly things like old school composite video capturing and older media center type software. Older windows server based OS'es probably still exist as basic Network shares and similar in many homes.

JDN165
Posts: 6
Joined: Wed Apr 04, 2018 6:47 pm

Re: Version 7.0.0 released

Post by JDN165 » Wed Apr 04, 2018 10:56 pm

I experienced the same issue as pipin (above): UMS 7.0.0 suddenly won't start anymore, it keeps hanging in the splash screen.
Ths problem can only be solved by uninstalling the software, remove all folders and reinstall again (just a reinstall won't solve it).
I've had this problem twice. For now I reinstalled version 6.8.0 until this issue is solved (I hope soon).

Dosageko
Posts: 12
Joined: Fri May 10, 2013 7:24 am

Re: Version 7.0.0 released

Post by Dosageko » Fri Apr 06, 2018 1:04 pm

just wondering why noone noticed it already or is it just for me?

there is a major bug in 7.0 GUI Windows Edition about setting true/false variables.

for example:
the enabled "hide transcode Folder" Checkbox should set:
show_transcode_folder = false
but it will set:
show_transcode_folder = true
on the config file.

same for some other variables at least on the navigation tab (i was not investigated the other tabs)

i was using a blank config file to start from scratch just to be sure my older config file is not broken.
i did a quick test with enabling and disabling checkboxes on the navigation tab and the variables always went wrong (true/false reversed).

User avatar
pipin
Posts: 65
Joined: Fri Dec 28, 2012 12:17 am

Re: Version 7.0.0 released

Post by pipin » Sat Apr 07, 2018 6:10 am

Dosageko wrote:
Fri Apr 06, 2018 1:04 pm
just wondering why noone noticed it already or is it just for me?

there is a major bug in 7.0 GUI Windows Edition about setting true/false variables.

for example:
the enabled "hide transcode Folder" Checkbox should set:
show_transcode_folder = false
but it will set:
show_transcode_folder = true
on the config file.

same for some other variables at least on the navigation tab (i was not investigated the other tabs)

i was using a blank config file to start from scratch just to be sure my older config file is not broken.
i did a quick test with enabling and disabling checkboxes on the navigation tab and the variables always went wrong (true/false reversed).
Yes, noticed it, too.

Same for Live_subtitles and the other folder options.

In addition there are many media files, that could not be parsed and therefore are hidden.

Last but not least many "java.lang.OutOfMemoryError: Java heap space" errors.
Regards,
Jens
-----------
Devices used with UMS : - Windows 10 PC, Samsung UE32 F4580SS, Samsung UE48H6600

Post Reply