Page 1 of 1

Version 5.1.4 is released

Posted: Sun Jun 14, 2015 9:42 pm
by SubJunk
General:

You can download it from the front page.

This release improves file support, detection, browsing and transcoding speed, stability and more!


Changes since 5.1.3:

  • General:
    • Limits clickable areas of settings more precisely
    • Uses a default renderer image when none exist
    • Made H.264 transcoding faster
    • Improved stability and speed with large amounts of images
    • Expanded code testing coverage (thanks, Jensaarai!)
    • Improved detection of languages
    • Improved filename prettifying
    • Code optimizations
  • Renderers:
    • Improved support for DTS audio on Panasonic VT60 TVs
  • Languages:
    • Updated French translation (thanks, Kirvx!)
  • External Components:
    • Updated FFmpeg to builds from 20150521, which:
      • Improved support for many containers and codecs
      • Fixed bugs
    • Updated InterFrame to 2.8.2, which improved speed
    • Updated Maven Assembly Plugin to 2.5.4
    • Updated Maven Compiler Plugin to 3.3
    • Updated Maven Git Commit ID Plugin to 2.1.15
    • Updated Maven Javadoc Plugin to 2.10.3
    • Updated Maven Surefire Plugin to 2.18.1
    • Updated MediaInfo to 0.7.74, which improved detection of file information
    • Updated Netty to 4.0.28, which improved network operations (thanks, mfulgo!)

Re: Version 5.1.4 is released

Posted: Mon Jun 15, 2015 2:32 am
by Wolfgan
Thanks for the update... going to my media server to upgrade! Thanks again, Wolf.

Re: Version 5.1.4 is released

Posted: Mon Jun 15, 2015 3:04 am
by Phonism
Thank you for another update! I sent a summer donation, so have a nice cold beer :D

Re: Version 5.1.4 is released

Posted: Tue Jun 16, 2015 7:06 am
by Pandora-Box
I would like to report some "strange" UMS behavior since version 5.1.2, and still occurring in both 5.1.3 and 5.1.4 versions, but last version it was NOT observed it was 5.0.0 ( I have not tested version 5.1.1):
very high CPU usage, near 100% on both processors when streaming videos.
It has something to do with transcoding: MEncoder and FFmpeg, according to Task Manager CPU usage.
My UMS is set up not to transcode m2ts and vob files. Also, it is set to use LPCM, AC3 and DTS audio (AV system supports them).
In version 5.0.0 it does not occur.
Also, in ver 5.0.0 my AV system: Yamaha RX-V773WA is showing correct Yamaha icon, however in later mentioned versions, this icon changes to Streamium icon, unless Streamium renderer is unchecked.
I have both 5.0.0 and 5.1.4 trace logs but somehow I am not able to attach them to this post.
I think I will have to post this message under General Topics.

Re: Version 5.1.4 is released

Posted: Wed Jun 17, 2015 4:29 am
by jps92
Pandora, you can try the conf yamaha-RN500 (in the renderer subjet) maybe it's working.

Re: Version 5.1.4 is released

Posted: Fri Jun 19, 2015 6:42 am
by paulgala89
Please add the support for Ps4!! Now the console can recognize dlna server :D

Re: Version 5.1.4 is released

Posted: Fri Jun 19, 2015 8:06 am
by Wolfgan
paulgala89 wrote:Please add the support for Ps4!! Now the console can recognize dlna server :D


Just make sure you follow http://www.universalmediaserver.com/forum/viewtopic.php?f=4&t=3521&p=16739&sid=5ec3443b92d97ba54271f38c13349104#p16739 thread

Re: Version 5.1.4 is released

Posted: Fri Jul 03, 2015 3:50 am
by awschmidt
Problems with Sopcast-Streaming in this version:

TRACE 17:59:06.134 [nioEventLoopGroup-3-5] Opened request handler on socket /192.168.178.38:3774
TRACE 17:59:06.135 [nioEventLoopGroup-3-5] Request: HTTP/1.0 : HEAD : get/507/SopCast
DEBUG 17:59:06.135 [nioEventLoopGroup-3-5] Matched media renderer "TV" based on address /192.168.178.38
TRACE 17:59:06.135 [nioEventLoopGroup-3-5] Received on socket: getCaptionInfo.sec: 1
TRACE 17:59:06.135 [nioEventLoopGroup-3-5] Received on socket: Content-Length: 0
TRACE 17:59:06.135 [nioEventLoopGroup-3-5] Recognized media renderer: TV
TRACE 17:59:06.135 [nioEventLoopGroup-3-5] HTTP: get/507/SopCast / 0-0
TRACE 17:59:06.135 [nioEventLoopGroup-3-5] Asked stream chunk : TimeRange [start=null, end=null] of SopCast and player VLC Web Video
DEBUG 17:59:06.135 [nioEventLoopGroup-3-5] Starting transcode/remux of SopCast with media info: container: null, bitrate: 0, size: 0, video codec: null, duration: null, width: 0, height: 0, frame rate: null, mime type: null, attached fonts: false
TRACE 17:59:06.135 [nioEventLoopGroup-3-5] Searching for a match for: null with eng and off
TRACE 17:59:06.135 [nioEventLoopGroup-3-5] Searching for a match for: null with * and eng
TRACE 17:59:06.136 [nioEventLoopGroup-3-5] Searching for a match for: null with * and und
TRACE 17:59:06.136 [nioEventLoopGroup-3-5] Looking for a subtitle track with lang: ger
TRACE 17:59:06.136 [nioEventLoopGroup-3-5] Looking for a subtitle track with lang: jpn
TRACE 17:59:06.136 [nioEventLoopGroup-3-5] Looking for a subtitle track with lang: eng
TRACE 17:59:06.136 [nioEventLoopGroup-3-5] Looking for a subtitle track with lang: und
TRACE 17:59:06.136 [nioEventLoopGroup-3-5] Using mp2v, a52, ps
DEBUG 17:59:06.136 [nioEventLoopGroup-3-5] Creating pipe \\.\pipe\VLC1435852746136.ps
DEBUG 17:59:06.137 [Thread-78] Waiting for pipe connection \\.\pipe\VLC1435852746136.ps
DEBUG 17:59:06.137 [nioEventLoopGroup-3-5] Caught exception: java.lang.NullPointerException

Thanks for any help!

Re: Version 5.1.4 is released

Posted: Fri Jul 03, 2015 8:32 am
by valib
Again for you and others. Please send the full log. The info you provided is useless. You wrote that there is a java.lang.NullPointerException but in which part of the code? And what was the reason that it happened? Without log nobody can help you.