Page 1 of 2

Version 2.4.0 is released

Posted: Sun Feb 10, 2013 7:51 pm
by SubJunk
General:

You can download it from the front page.

This release adds external subtitle support to FFmpeg, the Linux build now includes all engine binaries, improved file compatibility, improved file sorting, and more!


Changes since 2.3.0:
  • General:
    • FFmpeg supports external subtitles
    • Linux build includes MPlayer, MEncoder and FFmpeg binaries like the other versions always have
    • Fixed user setting to automatically load external subtitles
    • Audio/subtitle language priority is now blank by default
    • Improved RealVideo file support
    • Added log level selector to the Logs tab
    • Improved MP4 compatibility on PS3
    • The word "the" at the start of filenames is ignored while sorting by default
    • Program runs on Windows startup by default, can be changed on the General Configuration tab
    • Fixed support for the Channels plugin
  • Languages:
    • Updated Czech translation
    • Updated Russian translation (thanks, Tianuchka!)
    • Made more things translatable
  • External Components:
    • Added MPlayer/MEncoder SB49 for Linux
    • Added FFmpeg SB6 for Linux
    • Updated Java Runtime Environment automatic downloader for Windows to 7u13, which:
      • Fixes serious security holes
    • Updated FFmpeg for Windows to SB6, which:
      • Enables external subtitles

Upgrade Notes:

For versions prior to 1.5.0:
It is recommended to delete your UMS.conf file prior to installing this version. For Windows users you can choose the "clean install" option while installing instead.

For all versions:
It is recommended (but usually not necessary) to uninstall the older version before installing the new one.


Thanks:

Cameron Spiers for building the OS X version

Re: Version 2.4.0 is released

Posted: Sun Feb 10, 2013 8:03 pm
by kuroukage
Awesome news. I'm about to test it out now. :)

Re: Version 2.4.0 is released

Posted: Sun Feb 10, 2013 9:02 pm
by kuroukage
Well, I'm having an issue with your new build of FFmpeg. It's not showing subtitles in Jumpy. I'm having to use Infidel's workaround still (the update.jar). Is this due to him needing to update Jumpy or do you need to add his new code to UMS in a future build?

Re: Version 2.4.0 is released

Posted: Sun Feb 10, 2013 11:21 pm
by uening
SubJunk wrote:
  • General:
    • Linux build includes MPlayer, MEncoder and FFmpeg binaries like the other versions always have
  • External Components:
    • Added MPlayer/MEncoder SB49 for Linux
    • Added FFmpeg SB6 for Linux

Code: Select all

02-10 12:10:49  Please wait while we check the MPlayer font cache, this can take a minute or so.
02-10 12:10:49  [2] Cannot launch MPlayer. Check the presence of ./mplayer
02-10 12:10:49  Finished checking the MPlayer font cache.

Code: Select all

[email protected]:~/ums$ ./mplayer 
bash: ./mplayer: Kann die Datei nicht ausführen.
[email protected]:~/ums$ ./mencoder 
bash: ./mencoder: Kann die Datei nicht ausführen.
[email protected]:~/ums$ ./tsMuxeR 
SmartLabs tsMuxeR.  Version 1.10.6  http://www.smlabs.net
Usage: 
For start muxing: tsMuxeR <meta file name> <out file/dir name>
For detect stream params: tsMuxeR <media file name>
For more information about meta file see readme.txt

[email protected]:~/ums$ ./ffmpeg 
bash: ./ffmpeg: Kann die Datei nicht ausführen.
Ubuntu 12.10 Quantal 32bit

Code: Select all

[email protected]:~/ums$ file mencoder 
mencoder: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), statically linked, for GNU/Linux 2.6.24, BuildID[sha1]=0x87fc096f62015346f445ca44dec2ab03594f0fbf, stripped

Re: Version 2.4.0 is released

Posted: Mon Feb 11, 2013 6:37 am
by Wolfgan
Working well for me on Win7x86. Thanks for the new release! Wolf

Re: Version 2.4.0 is released

Posted: Mon Feb 11, 2013 8:12 am
by Tyestor
So was this version compiled with/for JRE7 or still JRE6?

Re: Version 2.4.0 is released

Posted: Mon Feb 11, 2013 8:19 am
by SubJunk
JRE6. After researching and speaking with a Java representative, I concluded that there is no advantage to be had in compiling for Java 7 since they are both as secure as eachother. It is still recommended to use JRE 7 though since that does (in theory) offer better security than JRE 6.

Re: Version 2.4.0 is released

Posted: Mon Feb 11, 2013 9:45 am
by SubJunk
@Tyestor: I should note though that as soon as there is any difference between them (when there is a release of JDK 7 that is not synchronised with JDK 6) we will switch to 7 :)

@uening: Thanks for the report, I hadn't realised it had compiled for 64-bit. I am in the process of compiling 32-bit binaries for Linux now.

@wolfgan: Thanks! :D

Re: Version 2.4.0 is released

Posted: Tue Feb 12, 2013 3:51 am
by Tyestor
Thanks for the response. By the way, one of my most hated things about UMS is probably the UI (and the fact that I have to open and close UMS/restart my PS3 to get it to work sometimes. Oh and when closing UMS it sometimes leaves the javaw.exe process open so if you reopen UMS it won't detect any renderers until you close the old javaw.exe), is there any plans for a revamp?

Re: Version 2.4.0 is released

Posted: Tue Feb 12, 2013 8:44 am
by SubJunk
Feel free to make a thread with suggestions on how to improve the UI :)