srt subtitles stopped working a while back

General discussion about Universal Media Server (no support or requests)
User avatar
SubJunk
Lead Developer
Posts: 2923
Joined: Sun May 27, 2012 4:12 pm

Re: srt subtitles stopped working a while back

Post by SubJunk » Fri Jul 19, 2019 9:59 am

Thanks for all the info here guys, we are looking into this

User avatar
pipin
Posts: 80
Joined: Fri Dec 28, 2012 12:17 am

Re: srt subtitles stopped working a while back

Post by pipin » Fri Jul 19, 2019 7:47 pm

SubJunk wrote:
Fri Jul 19, 2019 9:59 am
Thanks for all the info here guys, we are looking into this
Thanks, the strange thing is, my Samsung UE32 F4580SS is still working with external subtitles.

Would logs with different versions and using both tvs helpful?
Regards,
Jens
-----------
Devices used with UMS : - Windows 10 PC, Samsung UE32 F4580SS, Samsung UE48H6600

User avatar
SubJunk
Lead Developer
Posts: 2923
Joined: Sun May 27, 2012 4:12 pm

Re: srt subtitles stopped working a while back

Post by SubJunk » Thu Aug 22, 2019 2:19 pm

Yes that would be ideal, then we can see exactly what the difference is between what is being sent to the TV

User avatar
pipin
Posts: 80
Joined: Fri Dec 28, 2012 12:17 am

Re: srt subtitles stopped working a while back

Post by pipin » Mon Sep 09, 2019 2:37 am

SubJunk wrote:
Thu Aug 22, 2019 2:19 pm
Yes that would be ideal, then we can see exactly what the difference is between what is being sent to the TV

I will try to grab some logs in the next days.
Regards,
Jens
-----------
Devices used with UMS : - Windows 10 PC, Samsung UE32 F4580SS, Samsung UE48H6600

User avatar
pipin
Posts: 80
Joined: Fri Dec 28, 2012 12:17 am

Re: srt subtitles stopped working a while back

Post by pipin » Mon Sep 09, 2019 4:29 am

Ok here are my logs.


I just started the same file with 7.6.2:

Both working: Samsung UE32 F4580SS (schlaf) and Samsung UE48H6600 (Samsung LED48..)


With 9.0.0

Working: Samsung UE32 F4580SS
Not working: Samsung UE48H6600
Attachments
ums_dbg_9_0_0.zip
Version 9.0.0
(94.01 KiB) Downloaded 2 times
ums_dbg_7_6_2.zip
Version 7.6.2
(71.72 KiB) Downloaded 3 times
Regards,
Jens
-----------
Devices used with UMS : - Windows 10 PC, Samsung UE32 F4580SS, Samsung UE48H6600

User avatar
SubJunk
Lead Developer
Posts: 2923
Joined: Sun May 27, 2012 4:12 pm

Re: srt subtitles stopped working a while back

Post by SubJunk » Sun Sep 15, 2019 12:48 am

I'm looking through your logs, thanks for attaching them. I can't see what could be causing the difference yet but I'll leave my progress notes:

7.6.2:

Code: Select all

<DIDL-Lite xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:pv="http://www.pv.com/pvns/" xmlns:sec="http://www.sec.co.kr/" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/">
  <item id="44" parentID="23" restricted="1">
    <dc:title>video {Untertitel:SubRip:English}</dc:title>
    <sec:dcmInfo>CREATIONDATE=0,FOLDER=video {Untertitel:SubRip:English},BM=99</sec:dcmInfo>
    <res xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" bitrate="110579" colorDepth="8" duration="0:43:06.623" nrAudioChannels="2" protocolInfo="http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_PS_PAL;DLNA.ORG_OP=01" pv:subtitleFileType="SRT" pv:subtitleFileUri="http://192.168.0.5:5001/get/44/subtitle0000video.srt" resolution="720x404" sampleFrequency="48000" size="286027920">http://192.168.0.5:5001/get/44/video.mp4</res>
    <res protocolInfo="http-get:*:text/srt:*">http://192.168.0.5:5001/get/44/subtitle0000video.srt</res>
    <res xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" protocolInfo="http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_SM;DLNA.ORG_FLAGS=00900000000000000000000000000000" resolution="320x180" size="10782">http://192.168.0.5:5001/get/44/thumbnail0000JPEG_SM_video.mp4.jpg</res>
    <res xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" protocolInfo="http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_TN;DLNA.ORG_CI=1;DLNA.ORG_FLAGS=00900000000000000000000000000000" resolution="160x90">http://192.168.0.5:5001/get/44/thumbnail0000JPEG_TN_video.mp4.jpg</res>
    <res xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" protocolInfo="http-get:*:image/png:DLNA.ORG_PN=PNG_LRG;DLNA.ORG_CI=1;DLNA.ORG_FLAGS=00900000000000000000000000000000" resolution="320x180">http://192.168.0.5:5001/get/44/thumbnail0000PNG_LRG_video.mp4.png</res>
    <res xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" protocolInfo="http-get:*:image/png:DLNA.ORG_PN=PNG_TN;DLNA.ORG_CI=1;DLNA.ORG_FLAGS=00900000000000000000000000000000" resolution="160x90">http://192.168.0.5:5001/get/44/thumbnail0000PNG_TN_video.mp4.png</res>
    <upnp:albumArtURI xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" dlna:profileID="JPEG_SM">http://192.168.0.5:5001/get/44/thumbnail0000JPEG_SM_video.mp4.jpg</upnp:albumArtURI>
    <upnp:albumArtURI xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" dlna:profileID="JPEG_TN">http://192.168.0.5:5001/get/44/thumbnail0000JPEG_TN_video.mp4.jpg</upnp:albumArtURI>
    <upnp:albumArtURI xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" dlna:profileID="PNG_LRG">http://192.168.0.5:5001/get/44/thumbnail0000PNG_LRG_video.mp4.png</upnp:albumArtURI>
    <upnp:albumArtURI xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" dlna:profileID="PNG_TN">http://192.168.0.5:5001/get/44/thumbnail0000PNG_TN_video.mp4.png</upnp:albumArtURI>
    <dc:date>2013-04-16T07:04:45</dc:date>
    <upnp:class>object.item.videoItem</upnp:class>
  </item>
</DIDL-Lite>
9.0.0:

Code: Select all

<DIDL-Lite xmlns="urn:schemas-upnp-org:metadata-1-0/DIDL-Lite/" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:pv="http://www.pv.com/pvns/" xmlns:sec="http://www.sec.co.kr/" xmlns:upnp="urn:schemas-upnp-org:metadata-1-0/upnp/">
  <item id="44" parentID="23" restricted="1">
    <dc:title>video {English Untertitel}</dc:title>
    <sec:dcmInfo>CREATIONDATE=0,FOLDER=video {English Untertitel},BM=121</sec:dcmInfo>
    <res xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" bitrate="110579" colorDepth="8" duration="0:43:06.623" nrAudioChannels="2" protocolInfo="http-get:*:video/mpeg:DLNA.ORG_PN=MPEG_PS_PAL;DLNA.ORG_OP=01" pv:subtitleFileType="SRT" pv:subtitleFileUri="http://192.168.0.5:5001/get/44/subtitle0000video.srt" resolution="720x404" sampleFrequency="48000" size="286027920">http://192.168.0.5:5001/get/44/video.mp4</res>
    <res protocolInfo="http-get:*:text/srt:*">http://192.168.0.5:5001/get/44/subtitle0000video.srt</res>
    <res xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" protocolInfo="http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_SM;DLNA.ORG_FLAGS=00900000000000000000000000000000" resolution="320x180" size="10782">http://192.168.0.5:5001/get/44/thumbnail0000JPEG_SM_video.mp4.jpg</res>
    <res xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" protocolInfo="http-get:*:image/jpeg:DLNA.ORG_PN=JPEG_TN;DLNA.ORG_CI=1;DLNA.ORG_FLAGS=00900000000000000000000000000000" resolution="160x90">http://192.168.0.5:5001/get/44/thumbnail0000JPEG_TN_video.mp4.jpg</res>
    <res xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" protocolInfo="http-get:*:image/png:DLNA.ORG_PN=PNG_LRG;DLNA.ORG_CI=1;DLNA.ORG_FLAGS=00900000000000000000000000000000" resolution="320x180">http://192.168.0.5:5001/get/44/thumbnail0000PNG_LRG_video.mp4.png</res>
    <res xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" protocolInfo="http-get:*:image/png:DLNA.ORG_PN=PNG_TN;DLNA.ORG_CI=1;DLNA.ORG_FLAGS=00900000000000000000000000000000" resolution="160x90">http://192.168.0.5:5001/get/44/thumbnail0000PNG_TN_video.mp4.png</res>
    <upnp:albumArtURI xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" dlna:profileID="JPEG_SM">http://192.168.0.5:5001/get/44/thumbnail0000JPEG_SM_video.mp4.jpg</upnp:albumArtURI>
    <upnp:albumArtURI xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" dlna:profileID="JPEG_TN">http://192.168.0.5:5001/get/44/thumbnail0000JPEG_TN_video.mp4.jpg</upnp:albumArtURI>
    <upnp:albumArtURI xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" dlna:profileID="PNG_LRG">http://192.168.0.5:5001/get/44/thumbnail0000PNG_LRG_video.mp4.png</upnp:albumArtURI>
    <upnp:albumArtURI xmlns:dlna="urn:schemas-dlna-org:metadata-1-0/" dlna:profileID="PNG_TN">http://192.168.0.5:5001/get/44/thumbnail0000PNG_TN_video.mp4.png</upnp:albumArtURI>
    <dc:date>2013-04-16T07:04:45</dc:date>
    <upnp:class>object.item.videoItem</upnp:class>
  </item>
</DIDL-Lite>

User avatar
SubJunk
Lead Developer
Posts: 2923
Joined: Sun May 27, 2012 4:12 pm

Re: srt subtitles stopped working a while back

Post by SubJunk » Sun Sep 15, 2019 1:05 am

pipin can you try newer releases of version 7? There are 7.7.0, 7.7.1, 7.8.0, and 7.9.0. I recommend starting with 7.9.0 and if that still works the same as 7.6.2 you don't need to test the others.
It would help narrow down the problem if we can find exactly when the problem started, though I suspect we will find that 7.9.0 is the same as 7.6.2 and the problem started with v8, it would be good to confirm

Post Reply