Embedded subtitles doesn't show on Samsung TV

General discussion about Universal Media Server (no support or requests)
Post Reply
Rbdk1
Posts: 2
Joined: Sun Apr 03, 2016 11:04 pm

Embedded subtitles doesn't show on Samsung TV

Post by Rbdk1 » Sun Apr 03, 2016 11:06 pm

Hey there!

I am having a lot of troubles getting embedded subtitles in MKV files to show on my Samsung Smart TV. External .srt files works just fine.

I have read somewhere that Samsung doesn't support this natively (doesn't work when inserting a USB either), so the subtitles need to be streamed externally or something? I Think FFMpeg was mentioned, but I'm not sure. Can someone please give me a nod in the right direction? Thanks!

Settings:

Disable subtitles: not checked
Subtitles priority: eng,fre,jpn,ger,und
Forced language: en
audio//subtitles language priority: *,*

Wolfgan
Posts: 371
Joined: Fri Feb 08, 2013 12:33 am

Re: Embedded subtitles doesn't show on Samsung TV

Post by Wolfgan » Mon Apr 04, 2016 1:10 am

Embedded soft subtiltes work in my Samsung H6400 TV, but not all models support same features. Which one is your TV?
Besides, it would be better if you add log files (as per viewtopic.php?f=9&t=556)
-- UMS serving PS3, WDTV, Samsung H6400 + J5500 and Kalemsoft renderers! (no video transcoding but remuxing accepted :D )

Rbdk1
Posts: 2
Joined: Sun Apr 03, 2016 11:04 pm

Re: Embedded subtitles doesn't show on Samsung TV

Post by Rbdk1 » Mon Apr 04, 2016 1:18 am

Thanks! My tv is a UE46D6500. I'll get back with a log :-)

User avatar
SubJunk
Lead Developer
Posts: 2783
Joined: Sun May 27, 2012 4:12 pm

Re: Embedded subtitles doesn't show on Samsung TV

Post by SubJunk » Mon Apr 04, 2016 7:38 am

When you come back with logs we can make a new config for your TV so it works better

Post Reply