PS4 Pro (PlayStation 4 Pro) renderer's configuration file

Discuss media renderers like Xbox 360, TVs, smartphones, etc.
User avatar
Sami32
Posts: 794
Joined: Mon Apr 11, 2016 5:09 am

Re: PS4 Pro (PlayStation 4 Pro) renderer's configuration file

Post by Sami32 » Sun Aug 13, 2017 7:41 am

Yes, sadly i saw an other issue, a dirty code trick IMO, so i did make an other build for you to test:
https://we.tl/z7ndLW01zk

I'll check at your log later. Thanks for having reported back ;)

predator848
Posts: 17
Joined: Thu Aug 10, 2017 10:29 pm

Re: PS4 Pro (PlayStation 4 Pro) renderer's configuration file

Post by predator848 » Sun Aug 13, 2017 8:39 am

unfortunately it doesn't work aswell.
I've got only tsmuxer with this build. I can hear the sound but no picture...
Kind the same problem
Attachments
ums_dbg.zip
(64.9 KiB) Downloaded 18 times

erick diangilis
Posts: 105
Joined: Sun May 22, 2016 8:25 am

Re: PS4 Pro (PlayStation 4 Pro) renderer's configuration file

Post by erick diangilis » Sun Aug 13, 2017 9:55 am

thanks sami for the explanation on the subject was very nice of you since the topic on my question is diffrent from the one is here on the post i Always wonder how the system Works. i hope you can fix the problem on ps4 pro which for me is wierd to happen because it Works fine on the base console and the ps4 pro is just a ps4 with a hardware enchancement but still a ps4 on its core with a minor new software options. i was on a intention to buy one but i think i will wait a little longer to ums work as good as its on the regular ps4.


i wish you good luck and thanks again for your time. ;)

User avatar
Sami32
Posts: 794
Joined: Mon Apr 11, 2016 5:09 am

Re: PS4 Pro (PlayStation 4 Pro) renderer's configuration file

Post by Sami32 » Sun Aug 13, 2017 1:35 pm

Hi predator,

Your log are very useful. I only checked the first for now, and saw that your FFmpeg version, the UMS old one, don't support well HEVC 10-bit in MP4 container. Sorry, i don't touch, or at least try to, anything related to MEncoder.

So, i'll check at your second log later, and make a new build for you.
Last edited by Sami32 on Mon Aug 14, 2017 5:39 am, edited 2 times in total.

predator848
Posts: 17
Joined: Thu Aug 10, 2017 10:29 pm

Re: PS4 Pro (PlayStation 4 Pro) renderer's configuration file

Post by predator848 » Sun Aug 13, 2017 7:30 pm

Hi Sami32,

Thanks for your work and replies.
I've tried with h264 videos and the results are the same (aswell with Mencoder).
Thanks again for your work. Really appreciate that.

User avatar
Sami32
Posts: 794
Joined: Mon Apr 11, 2016 5:09 am

Re: PS4 Pro (PlayStation 4 Pro) renderer's configuration file

Post by Sami32 » Tue Aug 15, 2017 6:08 am

Hi,

your 2 first logs make fixes 1 issues each, and the third one, well, i just disabled tsMuxeR for now, because you was triggered on tsMuxeR and you should't have and that make things go totally wrong.
I'm still not sure why because i couldn't reproduce it, so for now i just disabled it for testing purpose.

Could you try this version with a clean install and report back ? Thanks.

EDIT: if it still doesn't work try to set "PlayStation 4 Pro" renderer as default, force it, and restart UMS.
As for me its the only way i can try to simulate your situation, and that's work for me, it's worst a try ;)
Last edited by Sami32 on Tue Aug 15, 2017 1:33 pm, edited 1 time in total.

User avatar
Sami32
Posts: 794
Joined: Mon Apr 11, 2016 5:09 am

Re: PS4 Pro (PlayStation 4 Pro) renderer's configuration file

Post by Sami32 » Tue Aug 15, 2017 11:47 am

In fact, it seem that your renderer is not correctly handled, more exactly the custom parameters are not all taken in consideration, so you should disable all the others renderers, from "Select renderers" in the "General Configuration" tab.

Or add this IP filter under "Network settings (advanced)" in the "General Configuration" tab:

Code: Select all

192.168.0.5,192.168.0.7
and / or add this line into your renderer's configuration file:

Code: Select all

chromecast_extension = false
If it work, i suspect the last one to be the culprit, then you can re-enable the tsMuxeR engines (select them in the transcoding tab and then click on the wheel below).

predator848
Posts: 17
Joined: Thu Aug 10, 2017 10:29 pm

Re: PS4 Pro (PlayStation 4 Pro) renderer's configuration file

Post by predator848 » Wed Aug 16, 2017 12:44 am

Hi,

Thank you for your work.

I've done a clean install. Put ps4 pro as default and forced. Tsmuxer was enabled so i've disabled it.
When i put"192.168.0.5,192.168.0.7" and or "chromecast_extension = false", I don't know why but it doesn't work. UMS doesn't detect anything.
I've tried many times with all the parameters that you have told me to do but it doesn't work. I've tried aswell with only the clean install, it doesn't work aswell.
I've tried with ffmpeg, mencoder and no transcoding it doesn't work aswell. Even with h264.
You'll find attached the log (it's with all the parameters that you've told me to do/enabled)

Thanks again.
Attachments
ums_dbg.zip
(137.73 KiB) Downloaded 14 times

User avatar
Sami32
Posts: 794
Joined: Mon Apr 11, 2016 5:09 am

Re: PS4 Pro (PlayStation 4 Pro) renderer's configuration file

Post by Sami32 » Wed Aug 16, 2017 7:41 am

YES, now that work as expected...but as i asked for the maximum video quality, your powerful CPU was on its kneel, not suffisantly powerfull to transcoding fast enought to be able to stream in real time ;)

So, lets try these renderers that should lower the CPU use: (i will need log to see which one is the less CPU intensive)
You will need to replace the original one by one of these.

1)
Sony-PlayStation4Pro.conf
(2.14 KiB) Downloaded 16 times
2)
Sony-PlayStation4Pro.conf
(2.15 KiB) Downloaded 16 times
3)
Sony-PlayStation4Pro.conf
(2.19 KiB) Downloaded 12 times
Note: as video is not my zone of confort, and transcoding 4k UHD for streaming is out of my CPU possibilities :mrgreen: , i'll appreciate some patience and tolerance from your side.
I'm only trying to fix FFmpeg settings for the UHD, so you don't need to try the others video engines.
Last edited by Sami32 on Wed Aug 16, 2017 8:03 am, edited 4 times in total.

User avatar
Sami32
Posts: 794
Joined: Mon Apr 11, 2016 5:09 am

Re: PS4 Pro (PlayStation 4 Pro) renderer's configuration file

Post by Sami32 » Wed Aug 16, 2017 7:42 am

4)
Sony-PlayStation4Pro.conf
(2.17 KiB) Downloaded 14 times

Could you try to play these 2 files directly from your PS4, without using UMS ? Thanks.
https://we.tl/AUL0cJdm1i
Just to make sure that PS4 Pro can read it natively this kind of videos.

EDIT: @Nadahar point out that above to 125 MB/s you will not be able to stream it on the network, and still you need an HDD that support this speed.
So use only jellyfish samples that are between your HDD "max-less" speed and 120 MB/s if you are sure that your network is perfect (you can test its speed using "Use automatic maximum bandwidth" in the "General Configuration" tab, and post your log).
That mean that we was trying stupidly to stream 140 to 180 MB/s videos without any hope :oops:

Post Reply