LG BP550

Discuss media renderers like Xbox 360, TVs, smartphones, etc.
boss
Posts: 156
Joined: Thu Jun 30, 2016 1:07 pm

LG BP550

Post by boss » Mon Nov 27, 2017 1:37 pm

I had my LG BP550 Bluray players working very well.
I then noticed they were not seeing any MP4 files with UMS. I remember there was a firmware upgrade a while ago and maybe the issue was caused by that.
My LG WebOSTV sees the MP4 files so I know it was a BP550 issue.

In the LG-BP550.conf file there was:
Supported = f:mp4 v:h264|mp4|mpeg1|mpeg2|vc1 a:aac-lc|ac3|dts|he-aac|mpa|mp3|wma m:video/mp4
if I remove the a: from a:aac-lc so it becomes:
Supported = f:mp4 v:h264|mp4|mpeg1|mpeg2|vc1 aac-lc|ac3|dts|he-aac|mpa|mp3|wma m:video/mp4
(it use to be like this some versions before from memory)
It sees and plays the MP4 files.

Is that what I should do? Just change a:aac-lc to aac-lc or are there other implications.

Thanks in advance.

boss
Posts: 156
Joined: Thu Jun 30, 2016 1:07 pm

Re: LG BP550

Post by boss » Fri Dec 01, 2017 3:32 am

Can anyone help with an answer?

boss
Posts: 156
Joined: Thu Jun 30, 2016 1:07 pm

Re: LG BP550

Post by boss » Sun Dec 03, 2017 6:11 pm

I realised that removing the a: from a:aac-lc was not the correct thing to do.
Now I have got it to work by changing:
TranscodeVideo = MPEGTS-H264-AC3
To:
TranscodeVideo = MPEGTS-MPEG2-H264-AC3

Any advice if this is OK to do?

Thanks

User avatar
valib
Developer
Posts: 594
Joined: Fri Feb 08, 2013 3:11 am

Re: LG BP550

Post by valib » Mon Dec 04, 2017 11:52 pm

The

Code: Select all

TranscodeVideo = MPEGTS-MPEG2-H264-AC3
is wrong. There is in the "DefaultRenderer.conf" written

Code: Select all

# Profile to use for transcoding video files.
# Options:
#
#    Profile            Video           Audio   Container   Notes
#    ------------------------------------------------------------
#    MPEGPS-MPEG2-AC3   MPEG-2          AC-3    MPEG-PS     VLC only outputs 2-channel AC-3 audio
#    MPEGTS-MPEG2-AC3   MPEG-2          AC-3    MPEG-TS     VLC only outputs 2-channel AC-3 audio
#    MPEGTS-H264-AC3    H.264 (AVC)     AC-3    MPEG-TS     VLC only outputs 2-channel AC-3 audio
#    MPEGTS-H264-AAC    H.264 (AVC)     AAC     MPEG-TS
#    MPEGTS-H265-AC3    H.265 (HEVC)    AC-3    MPEG-TS     Only FFmpeg outputs H.265, others will output H.264
#    MPEGTS-H265-AAC    H.265 (HEVC)    AAC     MPEG-TS     Only FFmpeg outputs H.265, others will output H.264
#    WMV:               WMV 2 (WMV 8)   WMA 2   ASF
#
# These profiles are supported by the MEncoder, FFmpeg and VLC engines.
# Default: MPEGPS-MPEG2-AC3
TranscodeVideo = 
which means if any of that profiles are not written correctly than UMS does not understand it and chooses the default transcoding profile

Code: Select all

MPEGPS-MPEG2-AC3
Anyway will be better you follow the instruction written here viewtopic.php?f=9&t=556 and send the log.

boss
Posts: 156
Joined: Thu Jun 30, 2016 1:07 pm

Re: LG BP550

Post by boss » Tue Dec 05, 2017 12:12 pm

Thank you for the reply.
I changed the LG-BP550.conf back to default (for LG-BP550). TranscodeVideo = MPEGTS-H264-AC3
I have attached the log in "TRACE" mode.
I checked 2 folders for:
COMBAT! - Season 1
COMBAT! - Season 2

These are 2 of the folders where the mp4 videos do not show.
My LG-BP550 players worked fine with mp4 files previously. I think the problem may have been due to a firmware upgrade if I remember correctly.

Thanks again.
Attachments
debug.zip
(68.52 KiB) Downloaded 26 times

User avatar
Sami32
Posts: 819
Joined: Mon Apr 11, 2016 5:09 am

Re: LG BP550

Post by Sami32 » Thu Dec 07, 2017 6:11 am

Downgrade to MediaInfo 0.7.98 will fix your issue. The actual default version used by UMS is 0.7.97, but you've upgraded it to later version.

boss
Posts: 156
Joined: Thu Jun 30, 2016 1:07 pm

Re: LG BP550

Post by boss » Thu Dec 07, 2017 11:25 pm

@Sami32

Thank you for the reply.
I downgraded mediainfo to version 0.7.98 but unfortunately the result was the same.
That is the mp4 files were not showing up.
My LG WebOS 3.5 smart TV does see the mp4 files though.

Any more suggestions appreciated.

Thank you.

User avatar
Sami32
Posts: 819
Joined: Mon Apr 11, 2016 5:09 am

Re: LG BP550

Post by Sami32 » Fri Dec 08, 2017 12:52 am

Post a new trace log while using MediaInfo 0.7.97/98 and playing MP4 video.

boss
Posts: 156
Joined: Thu Jun 30, 2016 1:07 pm

Re: LG BP550

Post by boss » Fri Dec 08, 2017 4:05 am

I installed Mediainfo 0.7.97 and tested.
It is working now and the MP4 files are showing.

Thank you for your help.

User avatar
valib
Developer
Posts: 594
Joined: Fri Feb 08, 2013 3:11 am

Re: LG BP550

Post by valib » Fri Dec 08, 2017 11:00 am

Can you try to install back the MediaInfo version 0.7.99, add to the renderers folder the LG-BP550_updated.conf I provided, choose it in the UMS instead of the LG-BP550.conf and test it?
Attachments
LG-BP550_updated.conf
(2.08 KiB) Downloaded 31 times

Post Reply