Page 1 of 1

PS4 Pro playback issues

Posted: Sun Nov 25, 2018 12:12 pm
by turboguard
I'm having issues streaming from my PC to my new PS4 Pro. When I select a file to play, it will sit and think for a few seconds then come back with an "unable to play media" error. However, if I click on it several more times it eventually starts playing.
Also sometimes during playback I'm getting weird horizontal split second video glitches that I never had on my PS3.

So far I've completely uninstalled UMS and any codecs from my system and did a clean install with default settings. The only setting I changed was enabling GPU acceleration.
My specs are Intel 5820k, 16GB DDR4, GeForce 1070Ti, on a gigabit LAN.

Any suggestions??

Re: PS4 Pro playback issues

Posted: Mon Nov 26, 2018 8:38 am
by Sami32
Only TRACE log are useful so...

Do disabling the GPU accelaration do fix you issue?
I cannot remember when they pushed that code but i think it was between 7.3.0 and 7.5.0, so you could also use an older version to verify, if you still get issue after disabling the GPU acceleration:
https://sourceforge.net/projects/unimed ... 0Releases/

Re: PS4 Pro playback issues

Posted: Mon Nov 26, 2018 1:56 pm
by SubJunk
Yes we might need to remove the new GPU acceleration code since several users have reported problems with it

Re: PS4 Pro playback issues

Posted: Mon Nov 26, 2018 11:46 pm
by valib
@Subjunk we can either remove it or add checkbox to the FFMpeg configuration page to enable/disable GPU acceleration.

Re: PS4 Pro playback issues

Posted: Tue Nov 27, 2018 2:08 pm
by turboguard
My apologies, here is the log with tracing enabled. I also disabled GPU acceleration, and the results were still the same.
So I've determined it takes 2 attempts and then the file finally plays when I select it a third time. If I watch my ethernet ports, the first and second times the lights show little activity, but on the third attempt they start blinking to show that there is data being streamed...very weird. Still getting those weird video glitches as well.
ums_dbg.zip
(217.3 KiB) Downloaded 54 times