Roku support

Discuss media renderers like Xbox 360, TVs, smartphones, etc.

recursion69
Posts: 1
Joined: Sun Nov 16, 2014 3:28 pm

Re: Roku support

Post by recursion69 » Sun Nov 16, 2014 3:31 pm

I have the same issue as previous people. The above file did not allow me to playback any media.

Thanks for the efforts though!

Note: Roku 3 is the device in question I am using.

User avatar
SubJunk
Lead Developer
Posts: 2570
Joined: Sun May 27, 2012 4:12 pm

Re: Roku support

Post by SubJunk » Tue Nov 25, 2014 12:38 pm

Thanks for testing :) How about this one? http://www.spirton.com/uploads/UMS/UMS-76cc66d.exe

Apesbrain
Posts: 2
Joined: Thu Nov 27, 2014 7:25 am

Re: Roku support

Post by Apesbrain » Thu Nov 27, 2014 7:29 am

I just tried build just above with no luck. I know Roku Media Player will play these specs:

Image

Can I force all video to transcode to this? If so, how? Thanks.

User avatar
SubJunk
Lead Developer
Posts: 2570
Joined: Sun May 27, 2012 4:12 pm

Re: Roku support

Post by SubJunk » Thu Nov 27, 2014 10:59 am

That would be great if we could but at the moment we don't have the ability to stream to MP4. We might add it in the future but it's tricky, we'll post back here if we do

Apesbrain
Posts: 2
Joined: Thu Nov 27, 2014 7:25 am

Re: Roku support

Post by Apesbrain » Fri Nov 28, 2014 3:23 am

Using VLC I converted my small video library to H.264 MP4 and still they won't play when being served by UMS; Roku starts to load the file then gets stuck. Note that these files do play on the Roku when Windows Media Player selected as server.

Vallimar
Posts: 36
Joined: Fri Oct 04, 2013 1:15 pm

Re: Roku support

Post by Vallimar » Tue Dec 02, 2014 1:38 pm

I did some playing around this evening on my Linux box with my Roku HD Streaming stick which is similar to the Roku3. I tried a few different DLNA servers with the official Roku Media Player app and here is a short summary:
  • Plex DLNA Media Server ==> plays some things; jerky starts, transcode w/ subs works for some things.
    miniDLNA ==> plays some things, no transcoding support
    Rygel (Gnome) ==> can list contents, but nothing actually plays/streams.
    UMS ==> can list contents, but nothing actually plays/streams.
For comparison, the Plex App will play/not play pretty much the same items as the DLNA server but it is a smoother experience and has a better interface letting you choose to display subs that the DLNA server misses and allowing you to fine tune transcode settings.

I haven't figured out why UMS isn't able to stream while those other 2 can.

User avatar
SubJunk
Lead Developer
Posts: 2570
Joined: Sun May 27, 2012 4:12 pm

Re: Roku support

Post by SubJunk » Tue Dec 02, 2014 4:40 pm

Thanks for the testing :) Can you please try this version and let me know how it goes? http://www.spirton.com/uploads/UMS/UMS-939446f.exe

Vallimar
Posts: 36
Joined: Fri Oct 04, 2013 1:15 pm

Re: Roku support

Post by Vallimar » Fri Dec 05, 2014 3:42 am

I did a bit more playing with a fresh git pull this morning and the latest Roku renderer files. It looks like it has a lot
of bits added that I had experimented with previously. For my situation with the steaming stick, it seems the problem
is outside any tweaking in this file. By that I mean it doesn't appear to be buffering/receiving any data at all from UMS.
The buffer bar makes no progress at all. I made a trace debug log with 1 example file. I also ran minidlna in debug
mode and attached that so you can compare. minidlna will play fully supported files fine. Videos with unsupported
audio will also still play, just no audio. Matroska files with embedded subs will also play sans subs. It isn't obvious
to me by looking at the logs why minidlna has no trouble streaming data whereas UMS doesn't appear to be sending
any data at all. I'm guessing some headers that the Roku is expecting to see aren't being sent so it isn't able to request
the data?
Attachments
minidlna.zip
miniDLNA debug log
(5.32 KiB) Downloaded 67 times
ums_dbg.zip
UMS debug w/ trace enabled
(13.55 KiB) Downloaded 66 times

pins
Posts: 1
Joined: Thu Dec 25, 2014 1:15 pm

Re: Roku support

Post by pins » Thu Dec 25, 2014 1:17 pm

SubJunk wrote:Thanks for the testing :) Can you please try this version and let me know how it goes? http://www.spirton.com/uploads/UMS/UMS-939446f.exe
Tested and still not working. Video wont even buffer

Post Reply