Help us improve support for your devices

Discuss media renderers like Xbox 360, TVs, smartphones, etc.
User avatar
Sami32
Posts: 814
Joined: Mon Apr 11, 2016 5:09 am

Re: Help us improve support for your devices

Post by Sami32 » Thu Oct 19, 2017 9:00 am

@zappie Thanks for confirming it, only DVD ISO (mounted DVDs).
Real DVDs, physical discs, play fine.

That is definitively a UMS bug, that as never been reported before, AFAIK.
But the fact that you used PMS 1.90.1 make me think that it has been broken very long time ago, or you'll have used a more recent version, isn't it ?

EDIT: No problem for MPlayer, i just tell you that in case you get issue related to encrypted DVDs, that MPlayer 1.3 should solve it.

zappie
Posts: 6
Joined: Fri Oct 13, 2017 10:54 am

Re: Help us improve support for your devices

Post by zappie » Thu Oct 19, 2017 9:41 am

@Sami32
Real DVDs, physical discs sadly DO NOT work (with mounted DVDs I ment a real/mounted physical disc at some mount-point in the filesystem without encryption). Same is for copied data from non-encrypted physical DVD to a file-system folder and playing that - that's also not working properly.

What works are only other video types which are non DVD.

I can not say how long this is broken. Some longer time ago I already tried the UMS versions (6.? and also the existing 7) and with those I already had this problem with DVD playback. But i do not remember when it was.
Other formats i did not try at this time because non working DVD was a no-go for me.
My assumption then was that this seems to be some more general bug and as it was relating to DVD (a very common type) i assumed that someone will detect that problem and hopefully fix it soon.
But this was not the case until now. At this time i just tried the UMS software and did not dive deeper into the software as pms was fine and i did not want to spend that much time about finding out what causes this as i did not know much about the UMS structure and it just did not work out of the box.
For pms I have never used an other pms version than 1.90.1 since this is not maintained for years now and this is the latest one - but in general somehow still working. But I guess in some time it will start to be problematic to use it since interfaces changes time by time and no new features will be implemented.

Thanks for the info about mplayer 1.3, then I will for now not dive deeper in building this new version for my ubuntu version.

User avatar
Sami32
Posts: 814
Joined: Mon Apr 11, 2016 5:09 am

Re: Help us improve support for your devices

Post by Sami32 » Thu Oct 19, 2017 12:28 pm

@zappie By real DVD, i was meaning when your put your buyed or burned DVD disk into your DVD reader, that should be added to your shared folder in UMS, that you can browse and play directly from you TV.
No ISO files, no virtual disk. As i'm not an english native, i could have not choosed the correct words :roll:

The fact that few users report issues, with a usable TRACE log, and that this kind of DVD ISO use is not that popular should explain why it hasn't been reported before, IMHO.

Thank you for having taked the time to report it +1

eyeonus
Posts: 1
Joined: Tue Jan 09, 2018 12:49 pm

Re: Help us improve support for your devices

Post by eyeonus » Tue Jan 09, 2018 12:59 pm

Insignia 39in. Roku TV, model number NS-39DR5100NA17

The .conf I made works fairly well, but fast forward and rewind aren't working whether I set that option to false or true. Haven't tried exclusive yet.

(Also the RendererIcon I put in the .conf isn't working because I have no idea how to get it to work and the website referenced in the DefaultRenderer.conf file doesn't exist:

Code: Select all

# Determines the icon that is displayed in the UMS user interface when this
# renderer connects. By default, these icons are bundled with UMS in ums.jar,
# but they can easily be customised:
# http://www.ps3mediaserver.org/forum/viewtopic.php?f=6&t=3507&p=49536#p49536
Attachments
ums_dbg.zip
(523.1 KiB) Downloaded 9 times

User avatar
valib
Developer
Posts: 499
Joined: Fri Feb 08, 2013 3:11 am

Re: Help us improve support for your devices

Post by valib » Wed Jan 10, 2018 5:42 am

eyeonus wrote:
Tue Jan 09, 2018 12:59 pm

(Also the RendererIcon I put in the .conf isn't working because I have no idea how to get it to work and the website referenced in the DefaultRenderer.conf file doesn't exist:

Code: Select all

# Determines the icon that is displayed in the UMS user interface when this
# renderer connects. By default, these icons are bundled with UMS in ums.jar,
# but they can easily be customised:
# http://www.ps3mediaserver.org/forum/viewtopic.php?f=6&t=3507&p=49536#p49536
Thanks for the comment about not existing URL. You can use info from Wiki https://github.com/UniversalMediaServer ... figuration

Post Reply