Help us improve support for your devices

Discuss media renderers like Xbox 360, TVs, smartphones, etc.
Uppie
Posts: 16
Joined: Thu Jul 19, 2012 5:42 am

Re: Help us improve support for your devices

Post by Uppie » Wed Mar 18, 2015 5:11 am

Hi SubJunk,

thanx for the reply:
Unfortunately that TV doesn't identify itself with anything unique (same as the PFL one) so we have no way to detect which Philips TV is connected. Frustrating.
.

I know, but the good thing is you guys fixed the detection error in viewtopic.php?f=5&t=2989, so i have a working set now!

Been trying to build a config from scratch and the preliminary results as well as the logs are attached. Maybe this can help. I've also logged my comments on the Philips-forum (Infidel found me there as well :D ), so i hope for some information from that side as well.

Thanx,

Uppie
ums_dbg_5.1.0.zip
(23.49 KiB) Downloaded 137 times

Enrice
Posts: 6
Joined: Thu Nov 06, 2014 8:24 am

Re: Help us improve support for your devices

Post by Enrice » Mon Mar 23, 2015 3:33 am

SubJunk wrote:
Enrice wrote:Hi.

Regarding the ir320: sorry to say, still no files listed at all. :cry: I never have seen any file listed with any version and any renderer config when using UMS.
Something deeply more general must be the problem, since I am able to see (and play) them from win8 media player as well as Plex media server.
Hi Enrice, do you know which profile Plex is using for the IR320? It doesn't seem to have a specific one for that device.
Hi again,

finally I got a replacement unit for my broken one (the IR320)

I added a Plex DLNA log for reference. As you can see, it plays most MP3, WMA and AAC (no lossless, no ogg, no wma pro, no wav however).
Attachments
Plex DLNA Server.zip
(25.67 KiB) Downloaded 127 times

nickhere
Posts: 138
Joined: Sat Jan 03, 2015 3:28 am

Panny as650

Post by nickhere » Wed Mar 25, 2015 5:22 am

ffmpeg didnt work for ted until i added the line MimeTypesChanges = video/mpeg=video/mp4
you may want to add this to testbuild

The onion still doesn't work
Attachments
ums_dbg.zip
(77.97 KiB) Downloaded 117 times

Hwo
Posts: 2
Joined: Mon Apr 06, 2015 1:40 am

Re: Help us improve support for your devices

Post by Hwo » Mon Apr 06, 2015 2:53 am

Using 5.1.1 + clean install + no changes in order of transcoder / video file engines.

Now, 90% of files that this tv recognizes, don't have time search or permit back / forward in time, appears 519 mil minutes (possible because transcoding in real time).

But, if change primary VFE on Transcoding FFMPEG to another, this problem don't occur, but some files don't play or recognizes (in tv, so much files is "not supported now, or not supported by this device), on olders versions this happens whit some MKV's (WMV9). All audio (mp3 / mp4 / flac) works fine.

This tv is similar and share the same settings in manual (and supported files) of PS490 / PL 491 séries (Global), and PS 550 séries (EU), maybe possible good to another users that have any of this TV's, reply too ;

And have any way possible to have a config especific that forces AVC-HL'5 10/8bits [email protected] to play / transcoding (not supported) in this TV? Much, much of my files with this don't play :(

Thanks for all (and sorry for my english / not main language).
Attachments
File Support
File Support
Samy.jpg (96.41 KiB) Viewed 5065 times
ums_dbg.zip
PL51E490
(1.05 MiB) Downloaded 118 times

IdivideBy0
Posts: 4
Joined: Wed May 28, 2014 7:48 am

Re: Help us improve support for your devices

Post by IdivideBy0 » Thu Apr 09, 2015 4:44 am

I have created a .conf file for the Samsung BD-FM57C blu ray players sold at Costco. Comparing specs, it is essentially a Samsung F5100 that has WIFI only instead of an ethernet port. Hope this helps. Thank you for creating this awesome program!!
Attachments
Samsung-BD-FM57C.zip
(722 Bytes) Downloaded 129 times

nickname
Posts: 7
Joined: Mon Jun 17, 2013 2:28 am

Re: Help us improve support for your devices

Post by nickname » Thu Apr 09, 2015 10:36 pm

Hi
Regarding to an older post about not sending the subtitles when streaming without tsanscoding it.
(link for logs etc download/file.php?id=1970 page 7 of this thread my original post)

I found on trace level this line

TRACE 10:35:41.075 [New I/O worker #2] Subtitles for "Modern.Family.S06E14.720p.HDTV.X264-DIMENSION.mkv" will not be transcoded because media_subtitle is not null


whats the option media_subtitle?

Is it a variable to be set on .conf
or on the preference window?
This could be the reason for not streaming the subtitles.

Also what is the
CharMap = / :
line on .conf file. There is no description on default.conf

Thanks a lot!

ExSport
Posts: 596
Joined: Wed Oct 10, 2012 1:57 am

Re: Help us improve support for your devices

Post by ExSport » Fri Apr 10, 2015 1:39 am

It means file will is not required to be transcoded to enable subtiltes as this value is not null what means there is "some" support of external soft subtitles as also your log shows:

Code: Select all

SupportedExternalSubtitlesFormats = SUBRIP,MICRODVD,SAMI,TEXT
This means these types can be streamed to renderer without transcoding. If it doesn't work and subs can't be enabled on your TV, probably TV doesn't support them.

Code: Select all

# A comma-separated list of supported text-based external subtitles formats
# for streaming together with streaming (not transcoded) video.
#
#    Supported formats:   File extension:
#    ------------------------------------
#    ASS                  .ass or .ssa
#    MICRODVD             .sub
#    SAMI                 .smi
#    SUBRIP               .srt
#    TEXT                 .txt
#    WEBTT                .wtt
#
# Example: SupportedExternalSubtitlesFormats = SUBRIP,ASS,MICRODVD
# Default: ""
SupportedExternalSubtitlesFormats = 

# A comma-separated list of supported embedded subtitles formats.
#
#    Supported formats:
#    ------------------
#    ASS
#    BMP
#    DIVX
#    MICRODVD
#    PGS
#    SAMI
#    SUBRIP
#    TEXT
#    TX3G
#    USF
#    VOBSUB
#    WEBTT
#
# Example: SupportedInternalSubtitlesFormats = SUBRIP,ASS,PSG,DIVX
# Default: ""
SupportedInternalSubtitlesFormats =

nickname
Posts: 7
Joined: Mon Jun 17, 2013 2:28 am

Re: Help us improve support for your devices

Post by nickname » Fri Apr 10, 2015 2:00 am

thanks a lot for your quick response.

External .srt are definitely supported. Meaning they are displayed properly when are played form usb stick.

Internal subtitled are being displayed properly when streaming.

Currently the only way to display the external subtitles is to force trasccode using mencoder.

Will keep trying any way....thanks!

ExSport
Posts: 596
Joined: Wed Oct 10, 2012 1:57 am

Re: Help us improve support for your devices

Post by ExSport » Fri Apr 10, 2015 7:44 am

UMS sends srt files to your renderer so if they are not shown, external srt subs are not supported via DLNA/UPnP or UMS technique how subs are sent to your renderer are not compatible.
You can try other DLNA servers if anyone supports streaming subs. If yes, network trace can help to implement it also to UMS if it is not already there 8-)

Code: Select all

TRACE 10:35:33.739 [New I/O worker #8] Network debugger: Girls.S04E04.720p.HDTV.x264-KILLERS {Stream Sub: SubRip} http-get:*:video/x-matroska:DLNA.ORG_OP=01 pv:subtitleFileType=SRT pv:subtitleFileUri=http://192.168.1.13:50103/get/45/subtitle0000Girls.S04E04.720p.HDTV.x264-KILLERS.srt size=554975200 duration=00:28:35.00 http://192.168.1.13:50103/get/45/Girls.S04E04.720p.HDTV.x264-KILLERS.mkv
TRACE 10:35:33.739 [New I/O worker #8] Network debugger: http-get:*:text/srt:*http://192.168.1.13:50103/get/45/subtitle0000Girls.S04E04.720p.HDTV.x264-KILLERS.srt
Also there other two tips:
- always use the latest version as debug.log shows you are using old one
- play with other subtitle params in renderer.conf like enabling ClosedCaption:

Code: Select all

# Whether to use the "sec:CaptionInfoEx" parameter to stream external subtitles.
# Supported subtitles are defined in SupportedSubtitlesFormat.
# Default: false
UseClosedCaption = 

darkerthanblack
Posts: 12
Joined: Tue Mar 25, 2014 2:03 am

Re: Help us improve support for your devices

Post by darkerthanblack » Sat Apr 11, 2015 1:09 pm

Xperia Z2 can't play any video file.
Attachments
ums_dbg.zip
(178.77 KiB) Downloaded 103 times

Post Reply