PlayStation Vita 'Network Media Player' App Support

Discuss media renderers like Xbox 360, TVs, smartphones, etc.
Verequies
Posts: 11
Joined: Thu Oct 30, 2014 9:11 pm

PlayStation Vita 'Network Media Player' App Support

Post by Verequies » Thu Oct 30, 2014 11:16 pm

Hey Guys

For the past few hours I have been debugging Sony's Network Media Player for PlayStation Vita with Universal Media Server. I have created a custom configuration profile for the PS Vita along with an appropriate image for the renderer. Here are the issues I have found.

# ============================================================================
# Notes for PlayStation Vita Network Media Player:
# - With audio streaming, if TranscodeAudio = LPCM then the file won't be copyable to the Vita,
# if TranscodeAudio = MP3, it takes forever to initiate a stream, if TranscodeAudio = WAV, the file is
# copyable however the song duration is wrong, instead of 4(Minutes):27(Seconds), it is shown as
# 06(Hours):12:49.
Image
# - When trying to stream a video, whatever folder you browse it will say
# "There are no compatible files in this folder."
Image
#=============================================================================

The audio format tested was a lossless flac format.

I have also uploaded debug information, and the custom configuration file that you can just drop into the UMS directory.
If anyone could help fix/debug these issues, that would be greatly appreciated.

Thanks in Advance
Hamish

Custom Configuration Profile:
Custom Configuration Profile V2.zip
(78.99 KiB) Downloaded 566 times
UMS 5.0.0-a1 Debug Information:
ums_dbg.zip
(89.93 KiB) Downloaded 276 times
Last edited by Verequies on Sat Nov 01, 2014 8:46 pm, edited 2 times in total.

Balmung
Posts: 12
Joined: Thu Oct 09, 2014 8:14 am

Re: PlayStation Vita 'Network Media Player' App Support

Post by Balmung » Fri Oct 31, 2014 3:39 am

Yeah, thx, but I have already started a Topic about that only one Topic under yours... :roll:

Verequies
Posts: 11
Joined: Thu Oct 30, 2014 9:11 pm

Re: PlayStation Vita 'Network Media Player' App Support

Post by Verequies » Fri Oct 31, 2014 10:20 am

Balmung wrote:Yeah, thx, but I have already started a Topic about that only one Topic under yours... :roll:
I started a new thread as yours was rather vague and you clearly didn't read the thread 'How to ask for support' by SubJunk, which is also conveniently located at the top of the forum page.

Balmung
Posts: 12
Joined: Thu Oct 09, 2014 8:14 am

Re: PlayStation Vita 'Network Media Player' App Support

Post by Balmung » Sat Nov 01, 2014 9:42 am

Args, you are right, I have overseen it, my fault, have deleted my Topic.

But ok, it is the similar Problem that you have here. Didn't get with my Profile any Videos in the Vita App.

xubz
Posts: 1
Joined: Sat Nov 01, 2014 6:34 pm

Re: PlayStation Vita 'Network Media Player' App Support

Post by xubz » Sat Nov 01, 2014 6:40 pm

Code: Select all

#----------------------------------------------------------------------------
# Profile for Sony PlayStation Vita.
# See DefaultRenderer.conf for descriptions of all the available options.
#----------------------------------------------------------------------------
RendererName = PlayStation Vita
RendererIcon = ps3.png

UserAgentSearch = PS Vita

SeekByTime = exclusive
DLNALocalizationRequired = true
TranscodeVideo = MPEGTS-H264-AAC
TranscodeAudio = MP3
H264Level41Limited = true
MaxVideoBitrateMbps = 10
MaxVideoWidth = 960
MaxVideoHeight = 540
MimeTypesChanges = video/mpeg=video/mp4
MuxNonMod4Resolution = true
ForceJPGThumbnails = true
ThumbnailAsResource = true
AccurateDLNAOrgPN = true
MediaInfo = true
CustomMencoderOptions = -channels 2 

# Supported video formats:
Supported = f:mp4     v:mp4|h264     a:aac	m:video/mp4
Supported = f:h264    v:mp4|h264     a:aac	m:video/h264

# Supported audio formats:
Supported = f:mp3                    n:2             m:audio/mpeg
Supported = f:mp4     a:aac          n:2             m:audio/x-m4a
Supported = f:wav     a:lpcm         n:6   s:48000   m:audio/L16
Supported = f:wav                    n:2   s:48000   m:audio/wav

# Supported image formats:
Supported = f:jpg     m:image/jpeg
Using UMS 5.0.0-a1

Modified Verequies profile a bit, Now I'm able to browse the Videos (with thumbnails!), but video doesn't start streaming... mencoder starts transcoding I suppose (can see CPU usage), but I keep getting the Loading animation on Vita.

Here is a DEBUG log of trying to get .avi file to work:

Code: Select all

DEBUG 12:02:30.838 [mencoder.exe-24] Starting C:\Program Files (x86)\Universal Media Server\win32\mencoder.exe -ss 0 E:\Anime\FLCL\01 - Fooly Cooly.avi -msglevel statusline=2 -oac lavc -of lavf -lavfopts format=mpegts -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=4 -lavcopts autoaspect=1:vcodec=libx264:acodec=libfaac:abitrate=448:threads=4:o=preset=superfast,crf=19,g=250,i_qfactor=0.71,qcomp=0.6,level=4.1,weightp=0,8x8dct=0,aq-strength=0,me_range=16:vrc_maxrate=4000:vrc_buf_size=5000 -nosub -noautosub -ofps 24000/1001 -lavdopts fast -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoder1414823550789
DEBUG 12:02:30.840 [mencoder.exe-24] Reading pipe: \\.\pipe\mencoder1414823550789
DEBUG 12:02:30.840 [mencoder.exe-24] Attaching thread: mencoder.exe-24
DEBUG 12:02:30.855 [Thread-104] MEncoder SB59-UMS (C) 2000-2014 MPlayer Team
DEBUG 12:02:30.855 [Thread-104] Custom build by SubJunk, http://www.spirton.com
DEBUG 12:02:30.855 [Thread-104] 
DEBUG 12:02:30.857 [Thread-104] success: format: 0  data: 0x0 - 0xeaa1000
DEBUG 12:02:30.857 [Thread-104] libavformat version 56.3.100 (internal)
DEBUG 12:02:30.859 [Thread-104] AVI file format detected.
DEBUG 12:02:30.859 [Thread-104] [aviheader] Video stream found, -vid 0
DEBUG 12:02:30.859 [Thread-104] [aviheader] Audio stream found, -aid 1
DEBUG 12:02:30.863 [Thread-104] VIDEO:  [XVID]  640x480  16bpp  23.976 fps  1189.3 kbps (145.2 kbyte/s)
DEBUG 12:02:30.863 [Thread-104] [V] filefmt:3  fourcc:0x44495658  size:640x480  fps:23.976  ftime:=0.0417
DEBUG 12:02:30.863 [Thread-104] ==========================================================================
DEBUG 12:02:30.863 [Thread-104] Opening audio decoder: [mpg123] MPEG 1.0/2.0/2.5 layers I, II, III
DEBUG 12:02:30.864 [Thread-104] AUDIO: 48000 Hz, 2 ch, s16le, 32.0 kbit/2.08% (ratio: 4000->192000)
DEBUG 12:02:30.864 [Thread-104] Selected audio codec: [mpg123] afm: mpg123 (MPEG 1.0/2.0/2.5 layers I, II, III)
DEBUG 12:02:30.864 [Thread-104] ==========================================================================
DEBUG 12:02:30.865 [Thread-100] Result of \\.\pipe\mencoder1414823550789 : true
DEBUG 12:02:30.865 [mencoder.exe-24-2] ** MUXER_LAVF *****************************************************************
DEBUG 12:02:30.865 [mencoder.exe-24-2] REMEMBER: MEncoder's libavformat muxing is presently broken and can generate
DEBUG 12:02:30.865 [mencoder.exe-24-2] INCORRECT files in the presence of B-frames. Moreover, due to bugs MPlayer
DEBUG 12:02:30.865 [mencoder.exe-24-2] will play these INCORRECT files as if nothing were wrong!
DEBUG 12:02:30.865 [mencoder.exe-24-2] *******************************************************************************
DEBUG 12:02:30.865 [Thread-104] OK, exit.
DEBUG 12:02:30.865 [Thread-104] libavcodec version 56.1.100 (internal)
DEBUG 12:02:30.865 [Thread-104] Opening video filter: [expand osd=1]
DEBUG 12:02:30.865 [Thread-104] Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
DEBUG 12:02:30.865 [Thread-104] ==========================================================================
DEBUG 12:02:30.865 [Thread-104] Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
DEBUG 12:02:30.867 [Thread-104] Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
DEBUG 12:02:30.867 [Thread-104] ==========================================================================
DEBUG 12:02:30.867 [mencoder.exe-24-2] [libfaac @ 01158200]Channel layout not specified
DEBUG 12:02:30.884 [Thread-104] Movie-Aspect is undefined - no prescaling applied.
DEBUG 12:02:30.884 [Thread-104] videocodec: libavcodec (640x480 fourcc=34363268 [h264])
DEBUG 12:02:30.884 [Thread-104] [libx264 @ 01158200]using SAR=1/1
DEBUG 12:02:30.889 [Thread-104] [libx264 @ 01158200]using cpu capabilities: MMX2 SSE2Fast LZCNT
DEBUG 12:02:30.892 [Thread-104] [libx264 @ 01158200]profile Constrained Baseline, level 4.1
DEBUG 12:02:30.912 [mencoder.exe-24-2] [VD_FFMPEG] DRI failure.
DEBUG 12:02:30.913 [Thread-104] Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
DEBUG 12:02:30.915 [mencoder.exe-24-2] [VD_FFMPEG] DRI failure.
DEBUG 12:02:30.934 [Thread-104] VIDEO CODEC ID: 28
DEBUG 12:02:30.934 [Thread-104] AUDIO CODEC ID: 15002, TAG: 0
DEBUG 12:02:30.934 [Thread-104] Writing header...
DEBUG 12:02:30.934 [mencoder.exe-24-2] [mpegts @ 01123c80]Using AVStream.codec.time_base as a timebase hint to the muxer is deprecated. Set AVStream.time_base instead.
DEBUG 12:02:30.974 [ffmpeg.exe-20-Cleanup] Stopping process: ffmpeg.exe-20
DEBUG 12:02:31.104 [ffmpeg.exe-21-Cleanup] Stopping process: ffmpeg.exe-21
DEBUG 12:02:31.383 [ffmpeg.exe-22-Cleanup] Stopping process: ffmpeg.exe-22
DEBUG 12:02:31.566 [ffmpeg.exe-23-Cleanup] Stopping process: ffmpeg.exe-23
DEBUG 12:02:34.631 [New I/O worker #2] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
INFO  12:02:36.940 [StartPlaying Event] Started playing 01 - Fooly Cooly.avi on your PlayStation Vita
DEBUG 12:02:36.941 [StartPlaying Event] The full filename of which is: E:\Anime\FLCL\01 - Fooly Cooly.avi and the address of the renderer is: 192.168.1.15
DEBUG 12:02:37.166 [New I/O worker #1] HTTP User-Agent: libhttp/3.35 (PS Vita)
DEBUG 12:02:38.103 [New I/O worker #3] HTTP User-Agent: libhttp/3.35 (PS Vita)
DEBUG 12:02:40.927 [New I/O worker #4] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
DEBUG 12:02:46.010 [New I/O worker #5] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
DEBUG 12:02:48.032 [New I/O worker #6] HTTP User-Agent: libhttp/3.35 (PS Vita)
DEBUG 12:02:51.054 [New I/O worker #7] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
DEBUG 12:02:52.309 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 5146, -13055 bits)
DEBUG 12:02:52.318 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 5147, -105703 bits)
DEBUG 12:02:52.339 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 5148, -108839 bits)
DEBUG 12:02:52.346 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 5149, -147775 bits)
DEBUG 12:02:52.355 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 5150, -63743 bits)
DEBUG 12:02:52.368 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 5151, -149919 bits)
DEBUG 12:02:52.379 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 5152, -111367 bits)
DEBUG 12:02:52.389 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 5153, -116903 bits)
DEBUG 12:02:52.399 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 5154, -156415 bits)
DEBUG 12:02:52.406 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 5155, -59343 bits)
DEBUG 12:02:52.423 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 5156, -130287 bits)
DEBUG 12:02:52.431 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 5157, -91359 bits)
DEBUG 12:02:52.440 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 5158, -103551 bits)
DEBUG 12:02:56.154 [New I/O worker #8] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
DEBUG 12:02:58.043 [New I/O worker #1] HTTP User-Agent: libhttp/3.35 (PS Vita)
DEBUG 12:03:01.262 [New I/O worker #2] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
DEBUG 12:03:06.381 [New I/O worker #3] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
DEBUG 12:03:08.118 [New I/O worker #4] HTTP User-Agent: libhttp/3.35 (PS Vita)
DEBUG 12:03:11.553 [New I/O worker #5] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
DEBUG 12:03:16.729 [New I/O worker #6] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
DEBUG 12:03:18.121 [New I/O worker #7] HTTP User-Agent: libhttp/3.35 (PS Vita)
DEBUG 12:03:21.881 [New I/O worker #8] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
DEBUG 12:03:27.041 [New I/O worker #1] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
DEBUG 12:03:28.123 [New I/O worker #2] HTTP User-Agent: libhttp/3.35 (PS Vita)
DEBUG 12:03:31.762 [New I/O worker #1] Setting margin to 2Mb
DEBUG 12:03:32.204 [New I/O worker #3] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
DEBUG 12:03:36.301 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15895, -8116 bits)
DEBUG 12:03:36.306 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15896, -133551 bits)
DEBUG 12:03:36.323 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15897, -61255 bits)
DEBUG 12:03:36.329 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15898, -135975 bits)
DEBUG 12:03:36.333 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15899, -32135 bits)
DEBUG 12:03:36.347 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15900, -167311 bits)
DEBUG 12:03:36.351 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15901, -116855 bits)
DEBUG 12:03:36.363 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15902, -134111 bits)
DEBUG 12:03:36.367 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15903, -58847 bits)
DEBUG 12:03:36.379 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15904, -128191 bits)
DEBUG 12:03:36.392 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15905, -248095 bits)
DEBUG 12:03:36.397 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15906, -130791 bits)
DEBUG 12:03:36.406 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15907, -176247 bits)
DEBUG 12:03:36.411 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15908, -100991 bits)
DEBUG 12:03:36.424 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15909, -128431 bits)
DEBUG 12:03:36.437 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15910, -190079 bits)
DEBUG 12:03:36.441 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15911, -90359 bits)
DEBUG 12:03:36.447 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15912, -112679 bits)
DEBUG 12:03:36.452 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15913, -119487 bits)
DEBUG 12:03:36.484 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15914, -200655 bits)
DEBUG 12:03:36.488 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15915, -189799 bits)
DEBUG 12:03:36.493 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15916, -105719 bits)
DEBUG 12:03:36.500 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15917, -88591 bits)
DEBUG 12:03:36.511 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15918, -80759 bits)
DEBUG 12:03:36.526 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15919, -149367 bits)
DEBUG 12:03:36.531 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15920, -74423 bits)
DEBUG 12:03:36.539 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15921, -90663 bits)
DEBUG 12:03:36.544 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15922, -147887 bits)
DEBUG 12:03:36.567 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15923, -167487 bits)
DEBUG 12:03:36.577 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15924, -196871 bits)
DEBUG 12:03:36.583 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15925, -130927 bits)
DEBUG 12:03:36.589 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15926, -184119 bits)
DEBUG 12:03:36.604 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15927, -169359 bits)
DEBUG 12:03:36.611 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15928, -153647 bits)
DEBUG 12:03:36.631 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15929, -257103 bits)
DEBUG 12:03:36.637 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15930, -189151 bits)
DEBUG 12:03:36.649 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15931, -167463 bits)
DEBUG 12:03:36.662 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 15932, -65519 bits)
DEBUG 12:03:37.383 [New I/O worker #4] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
DEBUG 12:03:38.133 [New I/O worker #5] HTTP User-Agent: libhttp/3.35 (PS Vita)
DEBUG 12:03:38.494 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16273, -43369 bits)
DEBUG 12:03:38.497 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16274, -25503 bits)
DEBUG 12:03:38.510 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16275, -83071 bits)
DEBUG 12:03:38.524 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16276, -56823 bits)
DEBUG 12:03:40.482 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16656, -11147 bits)
DEBUG 12:03:40.490 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16657, -177679 bits)
DEBUG 12:03:40.496 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16658, -153351 bits)
DEBUG 12:03:40.511 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16659, -120655 bits)
DEBUG 12:03:40.516 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16660, -83103 bits)
DEBUG 12:03:40.528 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16661, -93495 bits)
DEBUG 12:03:40.543 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16662, -211391 bits)
DEBUG 12:03:40.553 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16663, -137663 bits)
DEBUG 12:03:40.559 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16664, -129831 bits)
DEBUG 12:03:40.571 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16665, -164495 bits)
DEBUG 12:03:40.577 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16666, -34607 bits)
DEBUG 12:03:40.585 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16667, -103935 bits)
DEBUG 12:03:40.595 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16668, -91775 bits)
DEBUG 12:03:40.615 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16669, -183799 bits)
DEBUG 12:03:40.623 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16670, -145599 bits)
DEBUG 12:03:40.631 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16671, -9399 bits)
DEBUG 12:03:40.647 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16672, -162775 bits)
DEBUG 12:03:40.658 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16673, -167575 bits)
DEBUG 12:03:40.665 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16674, -152735 bits)
DEBUG 12:03:40.676 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16675, -186895 bits)
DEBUG 12:03:40.682 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16676, -89735 bits)
DEBUG 12:03:40.693 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16677, -29055 bits)
DEBUG 12:03:40.697 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16678, -49935 bits)
DEBUG 12:03:40.706 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16679, -60655 bits)
DEBUG 12:03:40.721 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16680, -196535 bits)
DEBUG 12:03:40.727 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16681, -7703 bits)
DEBUG 12:03:40.741 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16683, -62333 bits)
DEBUG 12:03:40.760 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16686, -12188 bits)
DEBUG 12:03:40.777 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16689, -32980 bits)
DEBUG 12:03:40.791 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16691, -73093 bits)
DEBUG 12:03:40.826 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16693, -313093 bits)
DEBUG 12:03:40.834 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16694, -297311 bits)
DEBUG 12:03:40.841 [mencoder.exe-24-2] [libx264 @ 01158200]VBV underflow (frame 16695, -194919 bits)
...
Here is a DEBUG log of trying to get a .mkv with 6 channel FLAC audio to work (no Loading animation on Vita, just shows the "broken" icon).

Code: Select all

DEBUG 12:01:35.390 [mencoder.exe-9] Starting C:\Program Files (x86)\Universal Media Server\win32\mencoder.exe -ss 0 [removed filename].mkv -msglevel statusline=2 -oac lavc -of lavf -lavfopts format=mpegts -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=4 -lavcopts autoaspect=1:vcodec=libx264:acodec=libfaac:abitrate=640:threads=4:o=preset=superfast,crf=22,g=250,i_qfactor=0.71,qcomp=0.6,level=4.1,weightp=0,8x8dct=0,aq-strength=0,me_range=16:vrc_maxrate=4000:vrc_buf_size=5000 -ass -fontconfig -noautosub -sid 0 -ofps 24000/1001 -vf scale=960:540 -lavdopts fast -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoder1414823495355
DEBUG 12:01:35.403 [mencoder.exe-9] Reading pipe: \\.\pipe\mencoder1414823495355
DEBUG 12:01:35.403 [mencoder.exe-9] Attaching thread: mencoder.exe-9
DEBUG 12:01:35.421 [Thread-45] MEncoder SB59-UMS (C) 2000-2014 MPlayer Team
DEBUG 12:01:35.422 [Thread-45] Custom build by SubJunk, http://www.spirton.com
DEBUG 12:01:35.422 [Thread-45] 
DEBUG 12:01:35.424 [Thread-45] success: format: 0  data: 0x0 - 0x5b043593
DEBUG 12:01:35.437 [Thread-45] libavformat version 56.3.100 (internal)
DEBUG 12:01:35.437 [Thread-45] libavformat file format detected.
DEBUG 12:01:35.461 [Thread-45] [lavf] stream 0: video (h264), -vid 0, H.264
DEBUG 12:01:35.461 [Thread-45] [lavf] stream 1: audio (flac), -aid 0, -alang jpn, FLAC 5.1
DEBUG 12:01:35.461 [Thread-45] [lavf] stream 2: subtitle (ass), -sid 0, -slang eng, Styled Subs [removed]
DEBUG 12:01:35.461 [Thread-45] [lavf] stream 3: subtitle (ass), -sid 1, -slang eng, Styled Subs [removed]
DEBUG 12:01:35.464 [Thread-45] VIDEO:  [H264]  1280x720  0bpp  23.974 fps    0.0 kbps ( 0.0 kbyte/s)
DEBUG 12:01:35.464 [Thread-45] [V] filefmt:44  fourcc:0x34363248  size:1280x720  fps:23.974  ftime:=0.0417
DEBUG 12:01:35.464 [Thread-45] ==========================================================================
DEBUG 12:01:35.464 [Thread-45] Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
DEBUG 12:01:35.465 [Thread-45] libavcodec version 56.1.100 (internal)
DEBUG 12:01:35.488 [Thread-45] AUDIO: 48000 Hz, 6 ch, s32le, 0.0 kbit/0.00% (ratio: 0->1152000)
DEBUG 12:01:35.489 [Thread-45] Selected audio codec: [ffflac] afm: ffmpeg (FFmpeg FLAC audio)
DEBUG 12:01:35.489 [Thread-45] ==========================================================================
DEBUG 12:01:35.489 [Thread-41] Result of \\.\pipe\mencoder1414823495355 : true
DEBUG 12:01:35.489 [mencoder.exe-9-2] ** MUXER_LAVF *****************************************************************
DEBUG 12:01:35.489 [Thread-45] OK, exit.
DEBUG 12:01:35.489 [mencoder.exe-9-2] REMEMBER: MEncoder's libavformat muxing is presently broken and can generate
DEBUG 12:01:35.489 [mencoder.exe-9-2] INCORRECT files in the presence of B-frames. Moreover, due to bugs MPlayer
DEBUG 12:01:35.489 [mencoder.exe-9-2] will play these INCORRECT files as if nothing were wrong!
DEBUG 12:01:35.489 [mencoder.exe-9-2] *******************************************************************************
DEBUG 12:01:35.489 [Thread-45] Opening video filter: [ass auto=1]
DEBUG 12:01:35.489 [Thread-45] [ass] auto-open
DEBUG 12:01:35.490 [Thread-45] Opening video filter: [scale w=960 h=540]
DEBUG 12:01:35.529 [Thread-45] ==========================================================================
DEBUG 12:01:35.529 [Thread-45] Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
DEBUG 12:01:35.531 [Thread-45] Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
DEBUG 12:01:35.531 [Thread-45] ==========================================================================
DEBUG 12:01:35.543 [mencoder.exe-9-2] [libfaac @ 01158200]Channel layout not specified
DEBUG 12:01:35.553 [mencoder.exe-9-2] [libfaac @ 01158200]libfaac doesn't support the specified bitrate, using 576kbit/s instead
INFO  12:01:35.560 [mencoder.exe-9] Process C:\Program Files (x86)\Universal Media Server\win32\mencoder.exe has a return code of -1073741819! Maybe an error occurred... check the log file
DEBUG 12:01:35.742 [ffmpeg.exe-4-Cleanup] Stopping process: ffmpeg.exe-4
DEBUG 12:01:35.966 [ffmpeg.exe-5-Cleanup] Stopping process: ffmpeg.exe-5
DEBUG 12:01:36.347 [ffmpeg.exe-6-Cleanup] Stopping process: ffmpeg.exe-6
DEBUG 12:01:36.677 [ffmpeg.exe-7-Cleanup] Stopping process: ffmpeg.exe-7
DEBUG 12:01:36.708 [New I/O worker #4] HTTP User-Agent: libhttp/3.35 (PS Vita)
DEBUG 12:01:37.143 [ffmpeg.exe-8-Cleanup] Stopping process: ffmpeg.exe-8
DEBUG 12:01:38.943 [New I/O worker #5] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
INFO  12:01:41.485 [StartPlaying Event] Started playing 01 - Film 1 - Overlooking View.mkv on your PlayStation Vita
DEBUG 12:01:41.486 [StartPlaying Event] The full filename of which is: [removed].mkv and the address of the renderer is: 192.168.1.15
DEBUG 12:01:41.552 [New I/O worker #3] HTTP User-Agent: libhttp/3.35 (PS Vita)
DEBUG 12:01:44.022 [mencoder.exe-9-Cleanup] Stopping process: mencoder.exe-9
DEBUG 12:01:44.092 [New I/O worker #6] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
INFO  12:01:45.555 [StopPlaying Event] Stopped playing 01 - Film 1 - Overlooking View.mkv on your PlayStation Vita
DEBUG 12:01:45.556 [StopPlaying Event] The full filename of which is: [removed].mkv and the address of the renderer is: 192.168.1.15
DEBUG 12:01:45.556 [StopPlaying Event] Reading resume: false (default: true)
DEBUG 12:01:46.729 [New I/O worker #7] HTTP User-Agent: libhttp/3.35 (PS Vita)
DEBUG 12:01:49.142 [New I/O worker #8] HTTP User-Agent: Network Media Player UPnP/1.0 DLNADOC/1.50 libhttp/3.35 (PS Vita)
Hope someone gets it to work because I've pretty much given up. Tried everything I could. :|

Verequies
Posts: 11
Joined: Thu Oct 30, 2014 9:11 pm

Re: PlayStation Vita 'Network Media Player' App Support

Post by Verequies » Sat Nov 01, 2014 7:10 pm

xubz, the Network Media Player supports 1080p video at 30 FPS, no need to change the resolution to the Vita's native display.

I've updated the Custom Configuration Profile to V2, Changelog:
- Fixed UMS PS Vita Device Icon
- Videos are now being detected, and thumbnails are viewable thanks to xubz.

Now that we can detect the video files and get them to start streaming/transcoding, we might be able to get them to work by playing around with custom transcoding options. However I'm not quite sure what command line options there are.

Balmung
Posts: 12
Joined: Thu Oct 09, 2014 8:14 am

Re: PlayStation Vita 'Network Media Player' App Support

Post by Balmung » Sun Nov 02, 2014 3:01 pm

@xubz: thx.
Verequies wrote:xubz, the Network Media Player supports 1080p video at 30 FPS, no need to change the resolution to the Vita's native display.
Smaller Resolution > faster encoding

Verequies
Posts: 11
Joined: Thu Oct 30, 2014 9:11 pm

Re: PlayStation Vita 'Network Media Player' App Support

Post by Verequies » Sun Nov 02, 2014 9:53 pm

Balmung wrote:@xubz: thx.
Verequies wrote:xubz, the Network Media Player supports 1080p video at 30 FPS, no need to change the resolution to the Vita's native display.
Smaller Resolution > faster encoding
Not necessarily, and why limit other people who enjoy 1080p. I personally have been using UMS to stream 1080p movies for a long time now, and they all start within 10 seconds, transcoding from a pretty low end NAS/Server.

Balmung
Posts: 12
Joined: Thu Oct 09, 2014 8:14 am

Re: PlayStation Vita 'Network Media Player' App Support

Post by Balmung » Mon Nov 03, 2014 1:48 am

Why 1080p for a 960x544 Display? More Data that must send over WiFi and that the Vita must decode.

Btw. "CreateDLNATreeFaster" didn't work well with the Vita, I got only the first 2 Entries from the Trees. You have enabled this Setting in your Profile.

SpitFire92
Posts: 5
Joined: Thu Oct 30, 2014 5:55 am

Re: PlayStation Vita 'Network Media Player' App Support

Post by SpitFire92 » Mon Nov 03, 2014 6:06 am

Hey,
is it so hard to add a new renderer? I have no idea, so there is no offense in my question! I hope that someone will add a functioning Vita profile as soon as poossible. Nvm, thanks for the work of those guys who allready tried to make it work.

Post Reply