PS4 disconnecting every 20 minutes

Discuss media renderers like Xbox 360, TVs, smartphones, etc.
zaz3n
Posts: 1
Joined: Tue Nov 03, 2015 7:41 pm

PS4 disconnecting every 20 minutes

Post by zaz3n » Tue Nov 03, 2015 7:46 pm

Hello all,

I recently started using UMS with PS4 (previuosly I owned a PS3), and I noticed that during streaming PS4 abruptly stops playing and goes back to DLNA server selection, where UMS has disappeared. I have latest SW versions of both UMS and PS4 firmware installed.
Browsing through logs nothing comes out apart from a "ALIVE..." message every 3 minutes. Then, exactly 20 minutes after streaming start, a "Stop" event is logged.
No packet loss or errors are logged. The only way to come back live is to close "Media Player" on PS4 and fire it up again.

Please note I have both my PS4 and my PC where UMS with DHCP IP addresses, as I previously read in the forum that setting static IP could solve this issue. Anyway, I would not be keen to set a static IP address... and furthermore I would like to know why it happens... :-)

Any idea?

Thank you,
z.

thulsa18
Posts: 1
Joined: Tue Nov 03, 2015 8:19 pm

Re: PS4 disconnecting every 20 minutes

Post by thulsa18 » Tue Nov 03, 2015 8:21 pm

Hello There,

Just thought I let you know that you are not the only one with this problem.
If I find a solution I'll let you know but so far I'm suffering the same problem.
Watched a movie yesterday and had to restart it about 5 times and fast forward back to where I was before

AuthenticM
Posts: 25
Joined: Mon Sep 30, 2013 12:49 pm

Re: PS4 disconnecting every 20 minutes

Post by AuthenticM » Thu Nov 19, 2015 8:36 am

This also happens to me, but only when I am streaming from my Windows PC. When I do so from my Macbook, everything is fine. I made a thread about this months ago, but no solution was offered.

Lord Phobos
Posts: 1
Joined: Fri Nov 27, 2015 7:20 am

Re: PS4 disconnecting every 20 minutes

Post by Lord Phobos » Fri Nov 27, 2015 7:22 am

Exactly the very same problem here.
Streaming from pc, disconnection every 15-20 minutes (not a precise time, tried misuring).

If anybody has a solution, you're welcome!


AND:

Does anybody knows how to use the .srt files for the subtitles? The Ps4 simply ignores them.

mp3cm
Posts: 2
Joined: Sun Dec 13, 2015 11:09 am

Re: PS4 disconnecting every 20 minutes

Post by mp3cm » Mon Dec 14, 2015 11:59 am

I recently have been plagued by this issue serving from OSX to the telstra t-box and the ps4. The currently playing video would stop and the UMS server would disappear from the media player. This would happen just before 20 minutes. It didn't matter if the file was streamed or served directly to the media player. It also didn't matter if only 5 minutes were played in one video, the issue would present itself just under 15 minutes in to the next video.

I tried modifying settings under general configuration, checking 'only run a single instance of UMS', forcing the network interface, forcing the ip of the server, forcing the port of the server. All of these didn't have any effect.

I've installed and re-installed Java 1.8.0_66 to no effect.

I've had success by removing the line

Code: Select all

<string>-Djava.net.preferIPv4Stack=true</string>
from the Info.plist file. I have no idea why removing this works. I thought that because there is a broken pipe error in the logs that it might be network related, that it could be anything from issues with certificates to internal ips to some application conflict on my machine. I also have no idea of what it breaks by removing it, but at least the disconnects don't occur anymore. Anyway I've attached my logs of before and after, so hope they help.

Also after reading https://github.com/ps3mediaserver/ps3me ... /issues/61 here's a screenshot of my general configuration in UMS.
Screen Shot 2015-12-14 at 10.21.04 AM.png
Screen Shot 2015-12-14 at 10.21.04 AM.png (112.05 KiB) Viewed 30625 times
Attachments
debug-logs.zip
(62.64 KiB) Downloaded 189 times

mdsa
Posts: 1
Joined: Mon Dec 21, 2015 2:11 am

Re: PS4 disconnecting every 20 minutes

Post by mdsa » Mon Dec 21, 2015 2:14 am

Hi there,

I'm having the exact same problem whilst connecting through mac. I don't quite understand how to implement the solution recommended above, could you please elaborate?

I thought originally it had something to do with the settings on my mac and it going to sleep but I changed them to prevent it from sleeping but I still get the same problem.

Would really appreciate some help, thanks.

silveradock
Posts: 1
Joined: Tue Dec 22, 2015 3:52 am

Re: PS4 disconnecting every 20 minutes

Post by silveradock » Tue Dec 22, 2015 4:04 am

Hey,

I have the same issue, but for me it take ~30min to stop. No error or explanation from UMS logs.

Im using Windows 10 Pro x64, UMS 5.3.1, Java8 and PS4 all up to date (PS4 firmware and Media Player). I was using a PS3 before, without any issue.

Ive done some test but nothing worked, tried Java7, UMS 6.0.0 a1. Launch UMS with the .bat file (Also tried removing the line -Djava.net.preferIPv4Stack=true and change true to false). Tinkered with UMS settings (force network, disable HTTP engive v2, etc.) My only guest is the issue must come from the PS4.

Ive search for the "Info.plist" to remove " -Djava.net.preferIPv4Stack=true " like mp3cm suggested, but couldn't find this file or anything that contain this line in the Windows build. (Except for the .bat file)

Thanks for anyone help,

EDIT: I tested with another Media Server and its doing the same thing. The issue is likely coming from the PS4.

mp3cm
Posts: 2
Joined: Sun Dec 13, 2015 11:09 am

Re: PS4 disconnecting every 20 minutes

Post by mp3cm » Sun Feb 28, 2016 6:12 pm

mdsa wrote:Hi there,

I'm having the exact same problem whilst connecting through mac. I don't quite understand how to implement the solution recommended above, could you please elaborate?
Hi mdsa,

First I'd recommend updating UMS to see if that works.

I accessed the info.plist file by doing the following:

Right click on the application Universal Media Server in your applications folder, select show package contents, open up the contents directory. Inside this there should be the info.plist file. Edit that file by removing the following line if it exists:

Code: Select all

<string>-Djava.net.preferIPv4Stack=true</string>

silveradock wrote:Ive search for the "Info.plist" to remove " -Djava.net.preferIPv4Stack=true " like mp3cm suggested, but couldn't find this file or anything that contain this line in the Windows build. (Except for the .bat file)
I'm unsure of the location of the plist file for Windows, but in the UMS logs the following line is present on startup when my preferIPv4Stack=true line is present

Code: Select all

17:01:29 TRACE has /127.0.0.1, which is skipped, because loopback=true, ipv6=false
and when its removed the following line appears on startup in the UMS logs

Code: Select all

17:03:57 TRACE has /fe80:0:0:0:0:0:0:1%lo0, which is skipped, because loopback=false, ipv6=true

Sasu
Posts: 1
Joined: Tue May 24, 2016 4:10 am

Re: PS4 disconnecting every 20 minutes

Post by Sasu » Tue May 24, 2016 4:15 am

I have the exact same problem. When I stream a video my PS4 just stop playing after around 18 minutes. I tried disabling preferIPv4Stack but that didn't change anything. The day before yesterday I was still using an older version of UMS (a version of mid last year). I never had that problem. But I also updated java yesterday, so I'm not sure if these are related. I'll try using an older version of UMS again.

Is there a solution already? Since I never had that problem before I don't think it's PS4 related. The last update of my PS4 is some time ago.

bazoozoo
Posts: 2
Joined: Mon Jun 20, 2016 12:45 am

Re: PS4 disconnecting every 20 minutes

Post by bazoozoo » Mon Jun 20, 2016 12:51 am

I have the same problem...

Code: Select all

DEBUG 2016-06-19 20:57:01.129 [ffmpeg64-59-2] frame=12845 fps= 45 q=20.0 size=  408276kB time=00:08:56.05 bitrate=6239.3kbits/s speed=1.86x
DEBUG 2016-06-19 20:57:01.713 [ffmpeg64-59-2] frame=12852 fps= 45 q=20.0 size=  408616kB time=00:08:56.21 bitrate=6242.6kbits/s speed=1.86x
DEBUG 2016-06-19 20:57:02.267 [ffmpeg64-59-2] frame=12858 fps= 44 q=20.0 size=  408902kB time=00:08:56.47 bitrate=6244.0kbits/s speed=1.85x
DEBUG 2016-06-19 20:57:02.824 [ffmpeg64-59-2] frame=12863 fps= 44 q=19.0 size=  409155kB time=00:08:56.72 bitrate=6244.9kbits/s speed=1.85x
TRACE 2016-06-19 20:57:03.004 [ffmpeg64-59-Timer] buffered: 207 567 127 bytes / inputs: 1
DEBUG 2016-06-19 20:57:03.400 [ffmpeg64-59-2] frame=12870 fps= 44 q=20.0 size=  409498kB time=00:08:56.91 bitrate=6247.9kbits/s speed=1.85x
DEBUG 2016-06-19 20:57:04.033 [ffmpeg64-59-2] frame=12881 fps= 44 q=20.0 size=  410029kB time=00:08:57.43 bitrate=6250.0kbits/s speed=1.85x
TRACE 2016-06-19 20:57:04.234 [UPNPHelper] Receiving a NOTIFY from [192.168.1.1:55614]
DEBUG 2016-06-19 20:57:04.583 [ffmpeg64-59-2] frame=12886 fps= 44 q=20.0 size=  410286kB time=00:08:57.65 bitrate=6251.3kbits/s speed=1.84x
TRACE 2016-06-19 20:57:05.004 [ffmpeg64-59-Timer] buffered: 207 557 555 bytes / inputs: 1
DEBUG 2016-06-19 20:57:05.221 [ffmpeg64-59-2] frame=12897 fps= 44 q=20.0 size=  410814kB time=00:08:58.16 bitrate=6253.4kbits/s speed=1.84x
DEBUG 2016-06-19 20:57:05.798 [ffmpeg64-59-2] frame=12905 fps= 44 q=20.0 size=  411206kB time=00:08:58.45 bitrate=6256.0kbits/s speed=1.84x
DEBUG 2016-06-19 20:57:05.968 [New I/O worker #4] Connection error: java.io.IOException: Соединение разорвано другой стороной
DEBUG 2016-06-19 20:57:05.969 [New I/O worker #4] Premature end, stopping...
TRACE 2016-06-19 20:57:05.969 [New I/O worker #4] Ready to Stop: true
TRACE 2016-06-19 20:57:07.004 [ffmpeg64-59-Timer] buffered: 421 308 996 bytes / inputs: 0
DEBUG 2016-06-19 20:57:08.471 [ffmpeg64-59-Cleanup] Stopping Unix process 7149: ffmpeg64-59
TRACE 2016-06-19 20:57:08.471 [ffmpeg64-59-Cleanup] Destroying buffer
TRACE 2016-06-19 20:57:08.471 [ffmpeg64-59-Cleanup] Killing the Unix process: 7149
DEBUG 2016-06-19 20:57:08.474 [ffmpeg64-59-Cleanup] Stopping Unix process 7145: mkfifo-60
TRACE 2016-06-19 20:57:08.474 [ffmpeg64-59-Cleanup] Killing the Unix process: 7145
DEBUG 2016-06-19 20:57:09.970 [StopPlaying Event] Matched media renderer "PlayStation 4" based on address /192.168.1.10
INFO  2016-06-19 20:57:09.970 [StopPlaying Event] Stopped playing 01 Братство кольца.mkv on your PlayStation 4
In log i find Connection

Code: Select all

error: java.io.IOException: Соединение разорвано другой стороной
(Connection closed by peer), and thats all...
But i have some suspicious about that:

Code: Select all

TRACE 2016-06-19 20:57:04.234 [UPNPHelper] Receiving a NOTIFY from [192.168.1.1:55614]
192.168.1.1 is IP of my ROUTER....

Post Reply