New renderer Yamaha-RXV500D

Discuss media renderers like Xbox 360, TVs, smartphones, etc.
Post Reply
newbietux
Posts: 16
Joined: Sun Apr 17, 2016 4:57 am

New renderer Yamaha-RXV500D

Post by newbietux » Fri Apr 22, 2016 11:29 pm

I'm created the renderer-file for Yamaha Receiver RX-V500D based on the Yamaha-RXV3900 file.

I could'nt test the aac and wma options.
Yamaha-RXV500D.conf
(1.26 KiB) Downloaded 194 times

radamo
Posts: 30
Joined: Thu Aug 14, 2014 12:12 am

Re: New renderer Yamaha-RXV500D

Post by radamo » Sun May 01, 2016 1:10 am

newbietux wrote:I'm created the renderer-file for Yamaha Receiver RX-V500D based on the Yamaha-RXV3900 file.

I could'nt test the aac and wma options.
Yamaha-RX-A2050.conf
(1.35 KiB) Downloaded 149 times
Thanks, I used this to update my RX-A2050 config. Now seems to work properly. I did not add in the "TranscodeAudio" line in my config. Everything I have in my collection are "Apple Lossless". When using Windows Media Player to stream I see "Apple Lossless" on the Yamaha display. When using UMS I see PCM. Wondering if I can figure out how to stream Apple Lossless direct???

User avatar
SubJunk
Lead Developer
Posts: 3112
Joined: Sun May 27, 2012 4:12 pm

Re: New renderer Yamaha-RXV500D

Post by SubJunk » Fri May 06, 2016 6:21 pm

Thanks for this, it will be in our next release

newbietux
Posts: 16
Joined: Sun Apr 17, 2016 4:57 am

Re: New renderer Yamaha-RXV500D

Post by newbietux » Sun Jun 12, 2016 7:45 pm

I had updated my
Yamaha-RXV500D.conf
Yamaha-RXV500D.conf
(1.26 KiB) Downloaded 162 times
because the first version functions not so good as I want.

Now when I stream FLAC- or WAV-files with the updated renderer file the result is that the Receiver displays "UNKNOWN" and use then the FLAC- or the WAV-Decoder do decode it. That is not the best what I want but I don't find a way to make, that the receiver recognize the FLAC-Format.
If the receiver displayed the PCM then had the UMS transcoded the files to PCM. That is not what I want.

On the base of inspection the receiver functions with the "DeveloperToolsForUPnPTechnologies" I think that the receiver can not recognize the FLAC- or WAV-Format on the basis of construction the DLNA-part.
This is the most important part of the log-files from the tool:

Code: Select all

http-get:*:audio/L16;rate=44100;channels=1:DLNA.ORG_PN=LPCM,
http-get:*:audio/L16;rate=44100;channels=2:DLNA.ORG_PN=LPCM,
http-get:*:audio/L16;rate=48000;channels=1:DLNA.ORG_PN=LPCM,
http-get:*:audio/L16;rate=48000;channels=2:DLNA.ORG_PN=LPCM,
http-get:*:audio/mpeg:DLNA.ORG_PN=MP3,
http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMABASE,
http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAFULL,http-wavetunes:*:audio/x-ms-wma:*
Please inspect or test the updated renderer-file to confirm my results. If your tests arr positiv you use the updated renderer-file.

Post Reply