Google Music plugin

Discuss third party additions, plugins and translations for Universal Media Server
User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Google Music plugin

Post by SharkHunter » Wed Oct 10, 2012 12:40 am

Hi,

I uploaded a new version (0.12) which really didn't change any thing but it works for me at least pls try it...
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Google Music plugin

Post by SharkHunter » Thu Oct 11, 2012 7:30 am

If you got problems with this take a new try at the GrooveShark plugin which is now back on line viewtopic.php?f=6&t=291
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

francadaniel
Posts: 5
Joined: Mon Oct 01, 2012 4:29 am

Re: Google Music plugin

Post by francadaniel » Sun Oct 14, 2012 8:41 am

I've installed the new version, but now it doesn't seem to recognize my profile anymore. There is no error message in the UMS, but my playlist aren't appearing anymore :S

valpis
Posts: 1
Joined: Mon Nov 05, 2012 4:08 am

Re: Google Music plugin

Post by valpis » Mon Nov 05, 2012 4:11 am

Hi

Just installed UMS (linux) but have trouble with GMusic plugin 0.12, complains that it is an invalid plugin and ignores it. Only me or others have problems with it?

spida_singh
Posts: 20
Joined: Sat Jun 09, 2012 4:07 am

Re: Google Music plugin

Post by spida_singh » Thu Nov 08, 2012 3:46 am

Hi

Installed new version, placed .cred file in UMS dir, still get missing credentials message in the traces log.

Windows 8 X64, UMS 2.0.0

When i installed it, it did not automatically create it, i had to manually create it... any ideas?

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Google Music plugin

Post by SharkHunter » Thu Nov 08, 2012 7:52 pm

spida_singh wrote:Hi

Installed new version, placed .cred file in UMS dir, still get missing credentials message in the traces log.
The crde file shouldn't be in the UMS dir but in the same dir as the UMS.conf file (which on windows is plced in User somewhere). Make life easier and go in under the "Plugin Mangement" tab in the UMS GUI. At the the top it should be a button called "Edit Credentials File" click it and a window will pop up wher you can edit the UMS.cred IN THE CORRECT place. Just press "Save" afterwards and the cred file is saved. Maybe a restart is needed to make the plugin pick up the new creds.
valpis wrote:Hi

Just installed UMS (linux) but have trouble with GMusic plugin 0.12, complains that it is an invalid plugin and ignores it. Only me or others have problems with it?
What does the logs say?
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

User avatar
S7eele
Posts: 104
Joined: Thu Jun 07, 2012 8:12 am

Re: Google Music plugin

Post by S7eele » Fri Nov 09, 2012 3:28 pm

Hello all. I just mentioned the problem with the credential editor in UMS 2.0 in another thread and plan to enter a seperate thread if I don't find anything that solves my problems here on the forums first. If any of you have had success using the new .cred edit function in UMS 2.0 please let me know. I am running under Vista 64, ran clean install of 2.0, used the plugin installer in UMS to install channels and could not find a .cred file anywhere. I placed one in the profile directory as has been done in the past and tried putting it in the program directory, the credential editor in UMS 2.0 would not work in either case. I was able to review log files from within UMS 2.0 if that makes any difference whatsoever.

I saw nothing in the basic debug file so I just changed my debug log to trace level and will capture the log files to upload when I create a seperate thread, unless I find the answer elsewhere first.
Peace!

spida_singh
Posts: 20
Joined: Sat Jun 09, 2012 4:07 am

Re: Google Music plugin

Post by spida_singh » Tue Nov 13, 2012 1:08 am

Tried that, installed from fresh, installed the plugin, when i click edit cred file, nothing happens.

I have it installed as a windows service, as it was not starting up via the UMS shortcut in the startup folder. Would this have any bearing on it?

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Google Music plugin

Post by SharkHunter » Tue Nov 13, 2012 1:14 am

Maybe there is a bug in the credfile button. Does the logs say anything?
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

spida_singh
Posts: 20
Joined: Sat Jun 09, 2012 4:07 am

Re: Google Music plugin

Post by spida_singh » Wed Nov 14, 2012 1:11 am

Had a look, nothing appears when i press it, also found that the .conf file is located in

C:\ProgramData\UMS

I placed my .cred file there, restarted UMS, still get the missing credentials warning, even directed the cred path correctly to this folder within UMS.

Post Reply