Grooveshark gs_plugin tiny mode false. HELP?

Discuss third party additions, plugins and translations for Universal Media Server
Post Reply
pulp
Posts: 26
Joined: Wed Dec 03, 2014 5:16 am

Grooveshark gs_plugin tiny mode false. HELP?

Post by pulp » Fri Dec 05, 2014 10:57 am

Hey fellahs,

So I'm using Chrome and running Grooveshark, logged-in of course and Playlist playing. UMS is being served to my TV and PS3, showing the Grooveshark Folders in the XMB but my music isn't in there. What am I forgetting to do? Do I also need a Chrome Plug-in?

Image

Image


12-04 17:00:21 Gs 0.65 using path C:\Users\P\AppData\Local\Temp\universalmediaserver\gs_plugin tiny mode false init delay 3000 zero_fill false


Thanks for any tips! :)

ums_dbg.zip
(15.74 KiB) Downloaded 115 times
Last edited by pulp on Sat Dec 06, 2014 3:18 am, edited 1 time in total.

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Grooveshark gs_plugin tiny mode false. HELP?

Post by SharkHunter » Fri Dec 05, 2014 7:47 pm

As always logs are needed. For gs add the gs_debug=true to your UMS.conf and rerun. Grooveshark might have changed stuff so things doesn't work. I personally don't use playlists so that might be broken.
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

pulp
Posts: 26
Joined: Wed Dec 03, 2014 5:16 am

Re: Grooveshark gs_plugin tiny mode false. HELP?

Post by pulp » Wed Dec 10, 2014 2:42 pm

Where do I "add the gs_debug=true to your UMS.conf" ? There are TWO places showing, with different results and I'm a dumbass:

Here:

Image

or

Here:

Image

Just open in Notepad as shown and copy/paste gs_debug=true anywhere in one of these two places or paste to a specific line, hex editor etc... ?



*****EDIT****

I just found this:

Configuration

The GrooveShark plugin has the following configuration options all should be entered in the PMS.conf file:

gs_plugin.path - The path to were the plugin will store it's internal data. (For example c:\gs_data) This should normally be set to something.

gs_plugin.init_delay - The number of milliseconds the plugin buffers before starting to stream. Defaults to 3000.

gs_plugin.max_display - How many hits that will be showed per folder. The plugin ads a "More" folder after this number of hits. Defaults to 32.

gs_plugin.private_dbg - If set to "true" the plugin will send it's debug to a private file called "gs_debug.txt" placed in the gs_plugin.path. Other wise the debug ends up in the normal PMS debug file.

gs_plugin.cover - If set to "old" the plugin fetches the cover thumbnails from an external website. Otherwise it uses GrooveSharks thumbnail site.

gs_plugin.tiny - If set to "true" the plugin uses GrooveSharks alt. site TinySong to fetch data from. Should be used only if the normal method dont' work.

https://github.com/SharkHunter/GSPMS

Oh boy.... do I really have to input all that? I don't even know the paths and how to space stuff out etc... Can't be as simple as adding the plug-in eh? :shock:


***EDIT2***

I'm using the newer 5.0.0 -b1 and same bad results: GrooveShark shows up on XMB with all the Folders but they are EMPTY, no files.

pulp
Posts: 26
Joined: Wed Dec 03, 2014 5:16 am

Re: Grooveshark gs_plugin tiny mode false. HELP?

Post by pulp » Fri Dec 12, 2014 9:55 am

BUMP?

How do I change it to "gs_debug=true to your UMS.conf" ?


:oops:

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Grooveshark gs_plugin tiny mode false. HELP?

Post by SharkHunter » Fri Dec 12, 2014 7:49 pm

Look under "General Configuration". there you'll find a button "Edit UMS.conf manually" press it and add the line. Press "Save" and then restart UMS to be on the safe side.
If you don't have a "Edit UMS.conf manually" you must first enable the "Advanced mode"
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

pulp
Posts: 26
Joined: Wed Dec 03, 2014 5:16 am

Re: Grooveshark gs_plugin tiny mode false. HELP?

Post by pulp » Sat Dec 13, 2014 2:55 am

Okay, did that but still no luck. I added "gs_debug=true" at bottom, as shown:

Image

After a negative result of gs_plugin tiny mode false, showing up again, I decided to add it in the middle of the UMS.conf file, not at the end, still no luck. So then I also added the number sign like the other inputs have: #gs_debug=true. No luck. Folders are all there in XMB but Empty/No Files.

12-12 10:04:13 Gs 0.65 using path C:\Users\Patrick\AppData\Local\Temp\universalmediaserver\gs_plugin tiny mode false init delay 3000 zero_fill false

Where should it be placed, directly at bottom or it does it even matter where O paste it? Also, should I add the # sign or not?

Using latest UMS 4.3.1 on WIN7:


Here's the zippy:
Attachments
ums_dbg.zip
(17.63 KiB) Downloaded 104 times

Post Reply