FAQ | Forum | Tracker | Code

Channels Plugin

Discuss third party additions, plugins and translations for Universal Media Server

Channels Plugin

Postby gambit » Tue Jun 19, 2012 2:47 pm

I have installed channels on ums but cant get anything to work

I have download psmencoder 1.6.0 and have it and updated ums.conf and help would be appreciated
gambit
 
Posts: 29
Joined: Tue Jun 19, 2012 2:44 pm

Re: Channels Plugin

Postby SharkHunter » Tue Jun 19, 2012 7:00 pm

No it's a bit tricky and until we get the improved plugin installer in place it will stay that way :(. However there isn't anything that can't be workedaround :). Do like this
1) Install the latest PMS-SHB (http://code.google.com/p/sharkhunter-sh ... e&can=2&q=)
2) Install UMS
3) From the PMS-SHB install folder copy the directory called "extra" and place it in the UMS install folder instead.
4) Copy everything from the plugins folder of PMS-SHB to the plugins folder of UMS
5) Edit the UMS.conf to reflect your paths.
At least these line should be added:
Code: Select all
channels.path=extras\\channels
channels.debug = true
pmsencoder.script.directory=extras\\scripts
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.
User avatar
SharkHunter
Developer
 
Posts: 518
Joined: Fri Jun 01, 2012 9:36 pm

Re: Channels Plugin

Postby gambit » Wed Jun 20, 2012 12:48 am

thats actually what i did, just not sure about the last 2 lines in the ums.conf, have to check it out after work. I have another question on the video engine files i have tsmuxer and than mencoder does that impact the functionality of the plugin of them being in that order?
gambit
 
Posts: 29
Joined: Tue Jun 19, 2012 2:44 pm

Re: Channels Plugin

Postby SharkHunter » Wed Jun 20, 2012 12:59 am

gambit wrote:thats actually what i did, just not sure about the last 2 lines in the ums.conf, have to check it out after work. I have another question on the video engine files i have tsmuxer and than mencoder does that impact the functionality of the plugin of them being in that order?


Forgot that you (probably even if channels might fix it for you) add
Code: Select all
engines = pmsencoder,mencoder,avs....

That is make usre that pmsencoder is FIRST in the engines list...

The channels.debug=true line is to enable debug prinouts and improve bug hunting. It will not help in any way to make it work.
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.
User avatar
SharkHunter
Developer
 
Posts: 518
Joined: Fri Jun 01, 2012 9:36 pm

Re: Channels Plugin

Postby gambit » Wed Jun 20, 2012 4:56 am

i still cant get it to work, which files do you me to attach for problem verification?
Attachments
pms_dbg.zip
(7.85 KiB) Downloaded 232 times
gambit
 
Posts: 29
Joined: Tue Jun 19, 2012 2:44 pm

Re: Channels Plugin

Postby SharkHunter » Wed Jun 20, 2012 5:56 am

gambit wrote:i still cant get it to work, which files do you me to attach for problem verification?

Actually it "works" :).
These line from pmsencoder.log informs us that Channels has found the media links. However the streams you are trying to watch comes from unsupported hosts (like gorillavid).
Code: Select all
nvoking matcher for: http://gorillavid.in/39cet7a4konc
2012-06-10 23:23:27 [INFO|PMSEncoder|launchTranscode|New I/O server worker #1-4]: 0 matches for: http://gorillavid.in/39cet7a4konc


Try some that SHOULD work (180upload worked when I tried now, can be found via IceFilms).
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.
User avatar
SharkHunter
Developer
 
Posts: 518
Joined: Fri Jun 01, 2012 9:36 pm

Re: Channels Plugin

Postby gambit » Wed Jun 20, 2012 6:04 am

i shall try than, i know i have been trying to use navi-x and hadnt had much success but thanks for looking at the logs, will report to see if i can get other links to work
gambit
 
Posts: 29
Joined: Tue Jun 19, 2012 2:44 pm

Re: Channels Plugin

Postby gambit » Wed Jun 20, 2012 10:15 am

still not working for me, i have tried icefilms on my android phone and i can get to the file and ums starts saying serving the video then stops.

However when i go through my ps3 i can get to icefilms-> tvshows->f->franklink and bash-> and click on it but says no sources found while android finds them.

Any ideas?
gambit
 
Posts: 29
Joined: Tue Jun 19, 2012 2:44 pm

Re: Channels Plugin

Postby SharkHunter » Wed Jun 20, 2012 8:09 pm

You've hit the folder limit. There is a workaround (within the UMS). Add "folder_limit=true" to your UMS.conf. And you'll see a folder called "Folder Limit" in the root of your tree. Once you hit the folder limit you can continue browsing from there.

I'll write a longer explanation on this later...
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.
User avatar
SharkHunter
Developer
 
Posts: 518
Joined: Fri Jun 01, 2012 9:36 pm

Re: Channels Plugin

Postby gambit » Thu Jun 21, 2012 1:43 pm

i added the line but i dont see the folder limit, everything is just as before, maybe a bug?
gambit
 
Posts: 29
Joined: Tue Jun 19, 2012 2:44 pm

Next

Return to Additions and Plugins

Who is online

Users browsing this forum: No registered users and 1 guest