Plugin: Web Interface for headless UMS

Discuss third party additions, plugins and translations for Universal Media Server
Shway
Posts: 3
Joined: Sat Feb 01, 2014 8:27 am

Re: Plugin: Web Interface for headless UMS

Post by Shway » Sat Feb 01, 2014 6:57 pm

Greetings,

I am having an issue starting up the Web UI. Here are the logs:

======

Code: Select all

02-01 00:44:41  Searching for plugins in C:\Program Files (x86)\Universal Media Server\plugins
02-01 00:44:41  Found plugin: org.qantic.umsplugin.WebInterface
02-01 00:44:41  WebInterface: initializing WebInterface.
02-01 00:44:41  WebInterface: Universal Media Server detected.
02-01 00:44:41  WebInterface: Method mapping file set to (Jar) -> jar:file:/C:/Program%20Files%20(x86)/Universal%20Media%20Server/plugins/ums-webinterface-1.0.0-a1.jar!/WEB/ums_method.map
02-01 00:44:41  WebInterface: Parsing method mapping and loading the configuration object.
02-01 00:44:41  WebInterface: Getter method [getHideVideoSettings] not found. The parameter [hidevideosettings] will not be available.
02-01 00:44:41  WebInterface: Getter method [getFolders] not found. The parameter [folders] will not be available.
02-01 00:44:42  WebInterface: Parsing web feed file C:\ProgramData\UMS/WEB.conf
02-01 00:44:42  jetty-9.0.z-SNAPSHOT
02-01 00:44:42  FAILED ServerConnector@76b98152{HTTP/1.1}{0.0.0.0:8083}: java.net.BindException: Address already in use: bind
java.net.BindException: Address already in use: bind
======

Also as a side note, the STATUS of my console says the default port 5001 is being blocked. I can say for sure it is not as the streaming to devices remains unaffected. I have exceptions placed in and out of the firewall and have process exceptions for all of UMS. The ports on my router are being forwarded and my ACL's are correctly configured and no other application is using this port number.

======

Code: Select all

Using address /192.168.0.254 found on network interface: name:eth3 (Broadcom NetLink (TM) Gigabit Ethernet)
02-01 00:44:42  Created socket: /192.168.0.254:5001
02-01 00:44:42  Another program is using port 5001, which UMS needs.
02-01 00:44:42  You can change the port UMS uses on the General Configuration tab.
======

Thank for the help.
:!: :?: :idea: :arrow:

User avatar
DeFlanko
Moderator
Posts: 724
Joined: Thu Jun 21, 2012 3:43 am
Location: San Pedro, CA
Contact:

Re: Plugin: Web Interface for headless UMS

Post by DeFlanko » Thu Feb 06, 2014 4:30 am

Take the install and plop it into the plugin's folder of UMS.

Shway
Posts: 3
Joined: Sat Feb 01, 2014 8:27 am

Re: Plugin: Web Interface for headless UMS

Post by Shway » Sat Feb 15, 2014 7:09 am

DeFlanko wrote:Take the install and plop it into the plugin's folder of UMS.
Are you saying to put the UMS Installer into the plugins folder as well as the java plugin object? Or is there another installer your referring to?

Jabberwocky
Posts: 2
Joined: Tue Mar 11, 2014 12:16 pm

Re: Plugin: Web Interface for headless UMS

Post by Jabberwocky » Tue Mar 11, 2014 12:23 pm

Shway wrote: ...
Are you saying to put the UMS Installer into the plugins folder as well as the java plugin object? Or is there another installer your referring to?
Juat copy the .jar file into the plugins folder inside ums folder.

This plugin olnly works in 2.6.5 version?????
I was trying in last 3.4.2 version but with no looky.

P.d. sorry for my bad english.

User avatar
DeFlanko
Moderator
Posts: 724
Joined: Thu Jun 21, 2012 3:43 am
Location: San Pedro, CA
Contact:

Re: Plugin: Web Interface for headless UMS

Post by DeFlanko » Wed Mar 12, 2014 3:28 am

I wonder how this plays with the "web" branch over on github.....................

pen
Posts: 60
Joined: Mon Sep 02, 2013 11:47 pm

Re: Plugin: Web Interface for headless UMS

Post by pen » Sat Mar 22, 2014 9:45 pm

Hi, is it a chance to get this working on a Ubuntu Linux server? The plugin starts and the web-interface comes up but it seems that the plugin doesn't respect the location of the UMS.conf file. It probably finds one but that's not the one UMS is currently using. Second, it doesn't show any renderers but that I can live with.

Kindly
Pen

PS: Using UMS 3.3.x
Server Ubuntu 12.04, Renderer Samsung 46D6300

frenchepaul
Posts: 3
Joined: Tue Apr 08, 2014 3:52 am

Re: Plugin: Web Interface for headless UMS

Post by frenchepaul » Thu May 15, 2014 1:18 am

Hello,

I'm using latest UMS version with Java version 1.7.0_51 on OSX. I've added the .Jar file into the Application Contents/Resources/Java/plugins but I get an error at launch.

"Cannot launch java application" (see attachement)

What am I doing wrong ?
Attachments
14-05-2014 9-17-12 AM.png
14-05-2014 9-17-12 AM.png (21.11 KiB) Viewed 9143 times

ntrp
Posts: 7
Joined: Tue Jun 04, 2013 6:09 am

Re: Plugin: Web Interface for headless UMS

Post by ntrp » Mon Dec 15, 2014 11:56 am

frenchepaul wrote:Hello,

I'm using latest UMS version with Java version 1.7.0_51 on OSX. I've added the .Jar file into the Application Contents/Resources/Java/plugins but I get an error at launch.

"Cannot launch java application" (see attachement)

What am I doing wrong ?
the jar should be put into plugins folder inside UMS installation directory

ntrp
Posts: 7
Joined: Tue Jun 04, 2013 6:09 am

Re: Plugin: Web Interface for headless UMS

Post by ntrp » Mon Dec 15, 2014 11:59 am

pen wrote:Hi, is it a chance to get this working on a Ubuntu Linux server? The plugin starts and the web-interface comes up but it seems that the plugin doesn't respect the location of the UMS.conf file. It probably finds one but that's not the one UMS is currently using. Second, it doesn't show any renderers but that I can live with.

Kindly
Pen

PS: Using UMS 3.3.x
The plugin should use the file provided by UMS because it retrieves the path using getProfilePath() on the ums configuration object. Anyway the plugin has been rewritten, maybe try the new version if the problem persists.

ntrp
Posts: 7
Joined: Tue Jun 04, 2013 6:09 am

Re: Plugin: Web Interface for headless UMS

Post by ntrp » Thu Jul 16, 2015 9:04 am

A version has been released with some bug fixes.

Now it is possible to set the interface host name/ip (defaults to 0.0.0.0), the option is available in the UMS.conf file under 'webinterface.host'.

Post Reply