Page 2 of 3

Re: Plugin: Web Interface for headless UMS

Posted: Sat Feb 01, 2014 6:57 pm
by Shway
Greetings,

I am having an issue starting up the Web UI. Here are the logs:

======

Code: Select all

02-01 00:44:41  Searching for plugins in C:\Program Files (x86)\Universal Media Server\plugins
02-01 00:44:41  Found plugin: org.qantic.umsplugin.WebInterface
02-01 00:44:41  WebInterface: initializing WebInterface.
02-01 00:44:41  WebInterface: Universal Media Server detected.
02-01 00:44:41  WebInterface: Method mapping file set to (Jar) -> jar:file:/C:/Program%20Files%20(x86)/Universal%20Media%20Server/plugins/ums-webinterface-1.0.0-a1.jar!/WEB/ums_method.map
02-01 00:44:41  WebInterface: Parsing method mapping and loading the configuration object.
02-01 00:44:41  WebInterface: Getter method [getHideVideoSettings] not found. The parameter [hidevideosettings] will not be available.
02-01 00:44:41  WebInterface: Getter method [getFolders] not found. The parameter [folders] will not be available.
02-01 00:44:42  WebInterface: Parsing web feed file C:\ProgramData\UMS/WEB.conf
02-01 00:44:42  jetty-9.0.z-SNAPSHOT
02-01 00:44:42  FAILED [email protected]{HTTP/1.1}{0.0.0.0:8083}: java.net.BindException: Address already in use: bind
java.net.BindException: Address already in use: bind
======

Also as a side note, the STATUS of my console says the default port 5001 is being blocked. I can say for sure it is not as the streaming to devices remains unaffected. I have exceptions placed in and out of the firewall and have process exceptions for all of UMS. The ports on my router are being forwarded and my ACL's are correctly configured and no other application is using this port number.

======

Code: Select all

Using address /192.168.0.254 found on network interface: name:eth3 (Broadcom NetLink (TM) Gigabit Ethernet)
02-01 00:44:42  Created socket: /192.168.0.254:5001
02-01 00:44:42  Another program is using port 5001, which UMS needs.
02-01 00:44:42  You can change the port UMS uses on the General Configuration tab.
======

Thank for the help.
:!: :?: :idea: :arrow:

Re: Plugin: Web Interface for headless UMS

Posted: Thu Feb 06, 2014 4:30 am
by DeFlanko
Take the install and plop it into the plugin's folder of UMS.

Re: Plugin: Web Interface for headless UMS

Posted: Sat Feb 15, 2014 7:09 am
by Shway
DeFlanko wrote:Take the install and plop it into the plugin's folder of UMS.
Are you saying to put the UMS Installer into the plugins folder as well as the java plugin object? Or is there another installer your referring to?

Re: Plugin: Web Interface for headless UMS

Posted: Tue Mar 11, 2014 12:23 pm
by Jabberwocky
Shway wrote: ...
Are you saying to put the UMS Installer into the plugins folder as well as the java plugin object? Or is there another installer your referring to?
Juat copy the .jar file into the plugins folder inside ums folder.

This plugin olnly works in 2.6.5 version?????
I was trying in last 3.4.2 version but with no looky.

P.d. sorry for my bad english.

Re: Plugin: Web Interface for headless UMS

Posted: Wed Mar 12, 2014 3:28 am
by DeFlanko
I wonder how this plays with the "web" branch over on github.....................

Re: Plugin: Web Interface for headless UMS

Posted: Sat Mar 22, 2014 9:45 pm
by pen
Hi, is it a chance to get this working on a Ubuntu Linux server? The plugin starts and the web-interface comes up but it seems that the plugin doesn't respect the location of the UMS.conf file. It probably finds one but that's not the one UMS is currently using. Second, it doesn't show any renderers but that I can live with.

Kindly
Pen

PS: Using UMS 3.3.x

Re: Plugin: Web Interface for headless UMS

Posted: Thu May 15, 2014 1:18 am
by frenchepaul
Hello,

I'm using latest UMS version with Java version 1.7.0_51 on OSX. I've added the .Jar file into the Application Contents/Resources/Java/plugins but I get an error at launch.

"Cannot launch java application" (see attachement)

What am I doing wrong ?

Re: Plugin: Web Interface for headless UMS

Posted: Mon Dec 15, 2014 11:56 am
by ntrp
frenchepaul wrote:Hello,

I'm using latest UMS version with Java version 1.7.0_51 on OSX. I've added the .Jar file into the Application Contents/Resources/Java/plugins but I get an error at launch.

"Cannot launch java application" (see attachement)

What am I doing wrong ?
the jar should be put into plugins folder inside UMS installation directory

Re: Plugin: Web Interface for headless UMS

Posted: Mon Dec 15, 2014 11:59 am
by ntrp
pen wrote:Hi, is it a chance to get this working on a Ubuntu Linux server? The plugin starts and the web-interface comes up but it seems that the plugin doesn't respect the location of the UMS.conf file. It probably finds one but that's not the one UMS is currently using. Second, it doesn't show any renderers but that I can live with.

Kindly
Pen

PS: Using UMS 3.3.x
The plugin should use the file provided by UMS because it retrieves the path using getProfilePath() on the ums configuration object. Anyway the plugin has been rewritten, maybe try the new version if the problem persists.

Re: Plugin: Web Interface for headless UMS

Posted: Thu Jul 16, 2015 9:04 am
by ntrp
A version has been released with some bug fixes.

Now it is possible to set the interface host name/ip (defaults to 0.0.0.0), the option is available in the UMS.conf file under 'webinterface.host'.