UMS only works with firewall disabled?

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
lowrider007
Posts: 1
Joined: Fri Jun 30, 2017 4:33 am

UMS only works with firewall disabled?

Post by lowrider007 » Fri Jun 30, 2017 4:36 am

Not sure why but for some reason UMS is now only working if I disable my firewall, I'm using windows 7 64bit, streaming audio to my yamaha receiver.

Anyhelp would be greatly appreciated.

Nadahar
Posts: 1421
Joined: Tue Jun 09, 2015 5:57 pm

Re: UMS only works with firewall disabled?

Post by Nadahar » Fri Jun 30, 2017 4:43 am

What do you need help with?

UMS can't work if you use a firewall to block the communication, that applies to any application that use network. You either have to disable the firewall on the computer running UMS or make firewall rules to allow the necessary traffic through.

By default, Java creates a firewall rule that allows any incoming traffic to any Java application. If you haven't disabled or deleted that rule, UMS should work with the Windows firewall in its default state as long as it's running as an application. If you run UMS as a service, you have to manually create a rule that allow all incoming traffic to the service executable (I think it's "wrapper.exe") which you can find when you look up the services (run services.msc).

If you use a different firewall software, you need to make corresponding rules. UMS needs access to incoming and outgoing traffic to and from any renderer (ANY is simplest) for both TCP and UDP.

Pan Borowik
Posts: 8
Joined: Sun May 21, 2017 2:44 am

Re: UMS only works with firewall disabled?

Post by Pan Borowik » Fri Jun 30, 2017 11:13 pm

I had a similar problem, turned out, there were two identical entries for Java in Windows Firewall application list. One was blocked. Enabled it, and it's all working ok.

OzBrickie
Posts: 17
Joined: Sat Nov 19, 2016 4:47 pm

Re: UMS only works with firewall disabled?

Post by OzBrickie » Fri Jul 14, 2017 6:06 am

Turning it off completely is simplest. :twisted:

Post Reply