[Solved] UMS will not open

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
Wiktor222
Posts: 15
Joined: Fri Nov 25, 2016 1:20 pm

[Solved] UMS will not open

Post by Wiktor222 » Sun Aug 13, 2017 7:29 am

UMS will not open but the javaw.exe file is there in Task Manager
I can't get the Create TRACE logs
I uninstalled Java and reinstalled it
I did the same for UMS
My Avast Antivirus does not have real time scanning that I could find
Not sure what other options are there?
I disabled my Firewall opened UMS waited for a few minutes nothing happened but javaw.exe was in Task Manager
Firewall exception is on for all UMS

Nadahar
Posts: 1439
Joined: Tue Jun 09, 2015 5:57 pm

Re: UMS will not open

Post by Nadahar » Sun Aug 13, 2017 7:54 am

Make sure UMS isn't running, kill javaw.exe first if necessary.

Press Win + R and enter:

Code: Select all

%programdata%\UMS
A window should open in your default profile folder, where you can find "UMS.conf" and "debug.log". Open "UMS.conf" in a text editor, and find "log_level =". If you can't find it, type it in on a new line. It should be set to "TRACE" so that the line with "log_level" ends up like this:

Code: Select all

log_level = TRACE
Save the file, start UMS and let it run for some seconds. Then, take "debug.log" from the same folder and attach it here.

Wiktor222
Posts: 15
Joined: Fri Nov 25, 2016 1:20 pm

Re: UMS will not open

Post by Wiktor222 » Sun Aug 13, 2017 8:43 am

What is a "test editor" and how do I get one?
"Open "UMS.conf" in a test editor, and find "log_level =". If you can't find it, type it in on a new line. It should be set to "TRACE" so that the line with "log_level" ends up like this: "

Wiktor222
Posts: 15
Joined: Fri Nov 25, 2016 1:20 pm

Re: UMS will not open

Post by Wiktor222 » Sun Aug 13, 2017 8:58 am

I think I did it here is the log file attached
Attachments
debug.log
(3.25 KiB) Downloaded 63 times

Nadahar
Posts: 1439
Joined: Tue Jun 09, 2015 5:57 pm

Re: UMS will not open

Post by Nadahar » Sun Aug 13, 2017 9:19 am

You didn't manage to set the log level to TRACE, but I got the information I needed without it.

You have installed a newer version of UMS and then reverted back to an older version, using the same profile folder - which is causing problems. In the same folder where you found "UMS.conf" and "debug.log" there's a folder called "database". Delete the folder and anything in it, and start UMS.

Btw, "test editor" was a typo: I meant "text editor".

Wiktor222
Posts: 15
Joined: Fri Nov 25, 2016 1:20 pm

Re: UMS will not open

Post by Wiktor222 » Sun Aug 13, 2017 10:09 am

When I deleted that folder everything is working now.
Thank You very much for your fast reply and follow up.

Post Reply