PS4 transcoding problems

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
erick diangilis
Posts: 105
Joined: Sun May 22, 2016 8:25 am

Re: PS4 transcoding problems

Post by erick diangilis » Tue Oct 03, 2017 8:46 am

hi sami i've tried these new builds from 6.7.4 snapshot none of them after the one from 3th of september the one i got from this post is Reading vídeos with higher resolutions than 1080p. i got all of them from diffrent posts and dates and tested all are having the same issues any 1440p or 2160p on the ps4 media player is not Reading. it only Works on the build from the 3th september. i though you should know to help since think this new version is going to be the new one in the future i thought this report could help to make it better. my friend of advice is to look on this particular older build from 3th september and compare with newer ones to understand why is not working the way is supose too. and i i've been noticing the other posts are from people having the same issue with their particular tv brands in 4k. i hope this help in any way.


have a good day and good luck in your work god bless. ;)

User avatar
Sami32
Posts: 792
Joined: Mon Apr 11, 2016 5:09 am

Re: PS4 transcoding problems

Post by Sami32 » Tue Oct 03, 2017 9:09 am

Hi erick diangilis,

Thanks, but as you already know, i need log, so until i finally get what really happen that will stay as it is now, as i've too many change that i couldn't even remember with my memory bird ;)

Why are you saying "Reading" ? do you meaning that they all transcoded correctly ?

Have a nice day as well, but please, leave God where he is, on the dollar banknotes ;)

BTW, this issue is not related to PS4 pro, so 4K videos is out of topic here.
Last edited by Sami32 on Tue Oct 03, 2017 11:43 am, edited 2 times in total.

User avatar
Sami32
Posts: 792
Joined: Mon Apr 11, 2016 5:09 am

Re: PS4 transcoding problems

Post by Sami32 » Tue Oct 03, 2017 9:50 am

@mik_s You could also try any of these changes:

1)

Code: Select all

CustomFFmpegOptions = -f mp4 -movflags frag_keyframe+default_base_moof -seekable 1
2)

Code: Select all

CustomFFmpegOptions = -level 42 -f mp4 -movflags frag_keyframe+default_base_moof -seekable 1
Oooh, i see that i've removed that line:

Code: Select all

TranscodedVideoFileSize = -1
So, you should try to add it back with all these and the 5 others modifications posted/asked before, and see what will happen.

mik_s
Posts: 27
Joined: Wed Aug 23, 2017 11:03 pm

Re: PS4 transcoding problems

Post by mik_s » Wed Oct 04, 2017 3:19 am

OK done the first 5 tests and here are my results -

Test 1 - PS4 waits 40 secs then says "cannot play media"
Test 2 - plays after 6 secs but only plays first 4 secs on PS4 - ums still streaming (or doing something) and doesn't stop till i stop on PS4.
Test 3 - PS4 waits 20 secs then says "cannot play media"
Test 4 - PS4 waits 20 secs then says "cannot play media"
Test 5 - PS4 waits 20 secs then says "cannot play media"

messing around with customFFmpegOptions i found the only thing that changed anything was the frag_keyframe option.

I did notice the message "DEBUG Connection error: java.io.IOException: An established connection was aborted by the software in your host machine" a lot in the logs. i have no idea why the PS4 would be aborting the connection as it is still trying to play the file and why only does this with transcoded files.

Made logs of playing the same file on PS3 and on TV, both played fine and was stopped manually after 20 secs.

PS3 didn't recognise the files until i removed "TranscodeVideo = MP4-H264-AAC" from the config file that wasn't there in previous version.
Made config file for my Samsung UE46F6400 TV based on Samsung-NotCD.conf and information in the e-manual of supported formats.
not sure if it is 100% correct though, plays file fine but unable to seek - max time is at 1 sec.

I will give the new tests a try and redo the 1st 5 with the TranscodedVideoFileSize option.
Attachments
ums_test 3.zip
(44.98 KiB) Downloaded 5 times
ums_test 2.zip
(54.99 KiB) Downloaded 9 times
ums_test 1.zip
(48.48 KiB) Downloaded 5 times

mik_s
Posts: 27
Joined: Wed Aug 23, 2017 11:03 pm

Re: PS4 transcoding problems

Post by mik_s » Wed Oct 04, 2017 3:20 am

here are the other logs due to limit of 3 attachments.
Attachments
ums_ps3 and tv working.zip
(73.15 KiB) Downloaded 5 times
ums_test 5.zip
(44.67 KiB) Downloaded 4 times
ums_test 4.zip
(51.13 KiB) Downloaded 5 times

User avatar
Sami32
Posts: 792
Joined: Mon Apr 11, 2016 5:09 am

Re: PS4 transcoding problems

Post by Sami32 » Wed Oct 04, 2017 4:18 am

@mik_s Thank you very much for your tests and logs :D +1
I don't need anymore logs for now, it will take me some time to analyse them ;)

For the next try, remove these line and compare their result with your first try:

Code: Select all

TranscodeFastStart = true
See if it make things faster or not, and if the transcoding is possible; test with the n°2 and the 2 latest.

Code: Select all

TranscodedVideoFileSize = -1
I suspect that it is no more necessary for PS4; test with the n°2 and the 2 latest.

Yes, don't forget that it's a testing build, some stuff is added, some other is disabled, and i use it for many other users issues, so PS3 have been modified for a user wishing play H.264 quality, but he get bored on the testing way and it has been leaved as it for later work ;)

mik_s
Posts: 27
Joined: Wed Aug 23, 2017 11:03 pm

Re: PS4 transcoding problems

Post by mik_s » Sat Oct 07, 2017 3:16 am

OK i have tried those new tests with and without the transcodefaststart and transcodedvideofilesize options on both the snapshot build and the final release and with the same results as before. not sure what you mean by "test with the n°2 and the 2 latest" though.

to eliminate java as a problem i upgraded that to the latest version and as much offline windows updates as i could find but made no difference to UMS.

User avatar
Sami32
Posts: 792
Joined: Mon Apr 11, 2016 5:09 am

Re: PS4 transcoding problems

Post by Sami32 » Sat Oct 07, 2017 10:41 am

@mik_s Thanks. It was worst a try, as fixing it correctly, i should say implement DLNA, as it as never really be implemented in PMS/UMS, would ask a full refactoring so...

Instead you can try that build, as a work around:
https://we.tl/IollsfdFO7

In case it doesn't work, try to uncomment this line inside the PS4 renderer's configuration file:

Code: Select all

#TranscodedVideoFileSize = -1
Cross your fingers ;)

mik_s
Posts: 27
Joined: Wed Aug 23, 2017 11:03 pm

Re: PS4 transcoding problems

Post by mik_s » Wed Oct 11, 2017 12:35 am

thanks and i have all my fingers crossed ;)

User avatar
Sami32
Posts: 792
Joined: Mon Apr 11, 2016 5:09 am

Re: PS4 transcoding problems

Post by Sami32 » Wed Oct 11, 2017 1:23 am

Don't worry, i'm on the way to make a new build for a Samsung user, that will have more chance to also work around your issue ;)

Post Reply