UMS Not opening

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
Wiktor222
Posts: 15
Joined: Fri Nov 25, 2016 1:20 pm

UMS Not opening

Post by Wiktor222 » Sat Sep 23, 2017 1:11 pm

I couldn't open program so I uninstalled and reinstalled but the program is still not opening.
Since it can't open I don't know how to upload a bug log.
Please help me figure out what happened and how to fix it for future reference.
Java 64 bit up to date
Windows up to date
No program changes were made not sure what the problem is.

Nadahar
Posts: 1441
Joined: Tue Jun 09, 2015 5:57 pm

Re: UMS Not opening

Post by Nadahar » Sat Sep 23, 2017 3:57 pm

If you have installed UMS as a service, you must stop the service before starting the GUI. Run "services.msc", look for UMS and if you find it, stop it.

Wiktor222
Posts: 15
Joined: Fri Nov 25, 2016 1:20 pm

Re: UMS Not opening

Post by Wiktor222 » Sun Sep 24, 2017 2:21 am

I did not find UMS in services.msc
Last time someone had me delete a file in Universal Media Server folder.
Not sure which one to delete or if that would help this time.
Last edited by Wiktor222 on Sun Sep 24, 2017 2:26 am, edited 1 time in total.

Nadahar
Posts: 1441
Joined: Tue Jun 09, 2015 5:57 pm

Re: UMS Not opening

Post by Nadahar » Sun Sep 24, 2017 2:23 am

Ok, go to "C:\ProgramData\UMS". Inside that folder, you should find a file "debug.log". Please attach it here.

Wiktor222
Posts: 15
Joined: Fri Nov 25, 2016 1:20 pm

Re: UMS Not opening

Post by Wiktor222 » Sun Sep 24, 2017 2:35 am

I did not find a debug.log
Last edited by Wiktor222 on Sun Sep 24, 2017 2:47 am, edited 1 time in total.

Nadahar
Posts: 1441
Joined: Tue Jun 09, 2015 5:57 pm

Re: UMS Not opening

Post by Nadahar » Sun Sep 24, 2017 2:46 am

Hmm, then something very basic is going wrong.

To get the error then, you need to start UMS from the command line. Open a command line by running "cmd" with Win + R.

Assuming that "java.exe" is on your PATH (if not, you need to specify the full path to java.exe), run:

Code: Select all

java -jar <full path to ums.jar> trace
The full path to ums.jar is by default "C:\Program Files (x86)\Universal Media Server\ums.jar", so normally the command would be:

Code: Select all

java -jar "C:\Program Files (x86)\Universal Media Server\ums.jar" trace
You will then get the log output to the console. Paste the output here. You have to right-click the command window and select "Select" to be able to copy and past. Select all the output and click Enter copy. Then simply paste it here.

Wiktor222
Posts: 15
Joined: Fri Nov 25, 2016 1:20 pm

Re: UMS Not opening

Post by Wiktor222 » Sun Sep 24, 2017 3:03 am

I found the ums.jar but not the other
tried to open ums.jar nothing happened
Every time I try to open UMS I look in task manager and see no UMS or javaw.exe
Last edited by Wiktor222 on Sun Sep 24, 2017 3:13 am, edited 1 time in total.

Nadahar
Posts: 1441
Joined: Tue Jun 09, 2015 5:57 pm

Re: UMS Not opening

Post by Nadahar » Sun Sep 24, 2017 3:11 am

You were never supposed to paste the first line as it was - you have to replace what's inside <> with the actual path.

The output from the second command line indicates something very wrong with your Java installation. Reinstall Java and try again.

What do you mean "the other"?

Wiktor222
Posts: 15
Joined: Fri Nov 25, 2016 1:20 pm

Re: UMS Not opening

Post by Wiktor222 » Sun Sep 24, 2017 3:34 am

After reinstalling Java everything seems to be working.
By other I meant ums.jar trace.

Thank You

Nadahar
Posts: 1441
Joined: Tue Jun 09, 2015 5:57 pm

Re: UMS Not opening

Post by Nadahar » Sun Sep 24, 2017 3:40 am

Ok, good.

Post Reply