Transcode files size

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
mogthemoogle
Posts: 4
Joined: Sun Oct 22, 2017 5:43 am

Transcode files size

Post by mogthemoogle » Sun Oct 22, 2017 5:48 am

So I'm trying to watch video files without subtitles. Before I was able to go into transcode folder and select a specific title that would have the subtitles disabled. Now when I go into the transcode folder to select a specific file, all the files are the same size (something like 976 kb) except for the file itself with no transcoding options. So when I select a file that would have the subtitles disabled it will play with them disabled but only for about 30 seconds. Any fix or advice? I haven't messed around with the settings themselves too much because I don't know where to begin. I've tried to force disable and a couple other things. Thanks for the help

User avatar
Nadahar
Developer
Posts: 868
Joined: Tue Jun 09, 2015 5:57 pm

Re: Transcode files size

Post by Nadahar » Sun Oct 22, 2017 7:44 am

What has changed between "before" and "now"? The incorrect size is caused by UMS returning a fixed size value for files that are to be transcoded, as the actual size in unknown. Transcoding happens in real time, so the "file" doesn't exist and thus is has no finite size. The only way to "find" the size would be to first transcode the whole file, which would take a long time and isn't a viable option. Some renderers refuse to play if the size is "0", which is why a fixed size value is used.

What's interesting is therefore what has changed since it used to work.

mogthemoogle
Posts: 4
Joined: Sun Oct 22, 2017 5:43 am

Re: Transcode files size

Post by mogthemoogle » Sun Oct 22, 2017 11:23 am

I wish I knew about before and after. What happens when I play through transcode is after 30 seconds it says file type not supported or something like that. It's frustrating because I hate watching with subtitles unless it's of course something in a foreign language

Post Reply