Samsung KU6000 Series 6 4k Playback issue

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Nadahar
Posts: 1232
Joined: Tue Jun 09, 2015 5:57 pm

Re: Samsung KU6000 Series 6 4k Playback issue

Post by Nadahar » Sat Feb 24, 2018 3:37 am

rowdyruffbrick wrote:
Sat Feb 24, 2018 2:29 am
Is this file affecting the playback of the 4k files?
That's quite likely, as the audio codec used has very little support. It might be that FFmpeg and other transcoding engines can't handle it properly.

rowdyruffbrick
Posts: 8
Joined: Sat Feb 17, 2018 7:05 pm

Re: Samsung KU6000 Series 6 4k Playback issue

Post by rowdyruffbrick » Sat Feb 24, 2018 2:45 pm

Nadahar wrote:
Sat Feb 24, 2018 3:37 am
rowdyruffbrick wrote:
Sat Feb 24, 2018 2:29 am
Is this file affecting the playback of the 4k files?
That's quite likely, as the audio codec used has very little support. It might be that FFmpeg and other transcoding engines can't handle it properly.
I've deleted the file since I dont actually watch it anymore, but the problem still persists. Could it be my computer is incapable of handling the streaming process?

User avatar
valib
Developer
Posts: 594
Joined: Fri Feb 08, 2013 3:11 am

Re: Samsung KU6000 Series 6 4k Playback issue

Post by valib » Sat Feb 24, 2018 10:13 pm

When UMS is going to transcode 4K video is impossible to do it on the fly with processor Core i5-760. Only when streaming video as it is it could work.

rowdyruffbrick
Posts: 8
Joined: Sat Feb 17, 2018 7:05 pm

Re: Samsung KU6000 Series 6 4k Playback issue

Post by rowdyruffbrick » Sun Feb 25, 2018 1:23 am

valib wrote:
Sat Feb 24, 2018 10:13 pm
When UMS is going to transcode 4K video is impossible to do it on the fly with processor Core i5-760. Only when streaming video as it is it could work.
Okay so lets say all I want to do is stream the video without any transcoding, how do I get about this? Just to test it out of course. Again my apologies for my lack of knowledge in this field.

Nadahar
Posts: 1232
Joined: Tue Jun 09, 2015 5:57 pm

Re: Samsung KU6000 Series 6 4k Playback issue

Post by Nadahar » Sun Feb 25, 2018 1:31 am

You can only stream the movie if your renderer supports receiving the file via UPnP AV/DLNA. If your renderer configuration is correct, UMS will always stream the file if possible. Transcoding is done when the file can't be streamed.

That means that the only things you can do to avoid transcoding is either to update your renderer configuration so that UMS knows what format/codecs your renderer can play, or that you convert the file (using Handbrake for example) into a format that your renderer does support.

rowdyruffbrick
Posts: 8
Joined: Sat Feb 17, 2018 7:05 pm

Re: Samsung KU6000 Series 6 4k Playback issue

Post by rowdyruffbrick » Sun Feb 25, 2018 2:39 am

Nadahar wrote:
Sun Feb 25, 2018 1:31 am
You can only stream the movie if your renderer supports receiving the file via UPnP AV/DLNA. If your renderer configuration is correct, UMS will always stream the file if possible. Transcoding is done when the file can't be streamed.

That means that the only things you can do to avoid transcoding is either to update your renderer configuration so that UMS knows what format/codecs your renderer can play, or that you convert the file (using Handbrake for example) into a format that your renderer does support.
I see. Okay so how would i know if a video is being transcoded or streamed directly?

Nadahar
Posts: 1232
Joined: Tue Jun 09, 2015 5:57 pm

Re: Samsung KU6000 Series 6 4k Playback issue

Post by Nadahar » Sun Feb 25, 2018 2:52 am

If you turn on "Show Engine name" on the Navigation/Share tab (and restart UMN), you will see "[FFmpeg]", "[MEncoder]" etc added the video names if they are being transcoded. Videos without any such tag are streamed.

Post Reply