Page 1 of 1

Samsung KU6000 TV + MPEG transcoding issue

Posted: Wed Aug 22, 2018 8:30 am
by tomaz
I am using UMS version 7.3.0.

I have created the attached profile file for the Samsung KU6000 TVs, based on this TV's documentation from Samsung.

I can successfully:
- view any video & audio that does not have to be transcoded (perfectly, even for very high bit rate files); and,
- view any video that is transcoded, so long as I use TranscodeVideo = WMV, however, the quality is terrible, the audio is unusable and the video stutters, even for moderate bit rate files.

I cannot:
- view any video that is transcoded, if I try any of the TranscodeVideo = MPEG.* options; the TV reports "an error has occurred" or "check your network connection" after a delay.

I attach the debug.log file (with log_level = TRACE) which I have sanitized in the following ways:
- I have deleted the lines referring to media (e.g. in the Recently Played list) other than the file I have played to create this debug log; and,
- I have anonymized all the uuids.
It is otherwise unchanged.

Do you have any idea why the MPEG.* options are not working, and what else I could try?

Also, I have files where both the video and the audio track formats are supported by the TV but the subtitle track formats are not, but where I have no interest in using the subtitles. I have set the following options in UMS.conf:

ffmpeg_mux_tsmuxer_compatible = true
mencoder_mux_compatible = true
audio_languages = eng
audio_subtitles_languages = eng,off;*,eng;*,und

These files are in containers where I have both files of that container type which need transcoding, and other files which do not need transcoding; I therefore cannot use the StreamExtensions setting. UMS appears to transcode these files by default (because of the incompatible subtitles). Thus, with the MPEG.* transcoding setting, I cannot play them, and with WMV transcoding, the viewing stutters so much it is unusable. If I manually navigate to the #--TRANSCODE--# folder and manually select the untranscoded file to play, it plays perfectly (both video and audio) but the subtitles do not show (which is exactly what I want). Is there a way to set UMS up so that by default it will not attempt to transcode such files, or will at least only remux them, which I assume should be fast enough for the video not to stutter?

Thank you.

Re: Samsung KU6000 TV + MPEG transcoding issue

Posted: Sat Sep 01, 2018 10:33 am
by tomaz
Any idea why TranscodeVideo = WMV works, but TranscodeVideo = MPEG.* all fail?

Re: Samsung KU6000 TV + MPEG transcoding issue

Posted: Sat Sep 08, 2018 3:41 pm
by SubJunk
Hi tomaz, it looks like that renderer config has a strange MIME type set for MKV files. Maybe try the attached file and let me know if that works?
Samsung-KU6000.conf
(10.15 KiB) Downloaded 60 times

Re: Samsung KU6000 TV + MPEG transcoding issue

Posted: Mon Sep 10, 2018 6:55 am
by tomaz
Thank you very much for your kind reply and suggested config. I much appreciate it. Unfortunately, I get the exact same problem as before.

Re: Samsung KU6000 TV + MPEG transcoding issue

Posted: Mon Sep 10, 2018 9:32 am
by SubJunk
Could you please attach logs after using the new config?