UMS and Special Characters in Subtitles

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
Madoka
Posts: 328
Joined: Fri Jun 01, 2012 12:51 pm

UMS and Special Characters in Subtitles

Post by Madoka » Thu Aug 23, 2018 2:56 pm

This is not a bug per se, more like UMS chooses poorly(?)

I have in the past left the non-unicode subtitles encoding detection to Auto-detect. However, I don't know what encoding it's using, but the auto detection will not display curly quotes, N or M dashes, or ellipses correctly. For example, it’s is rendered as it’s. However, manually setting the code to Windows 1252 will solve these problems. Not sure if UMS needs to improve the detection or not. Just reporting what I have noticed.

Nadahar
Posts: 1439
Joined: Tue Jun 09, 2015 5:57 pm

Re: UMS and Special Characters in Subtitles

Post by Nadahar » Fri Aug 24, 2018 6:37 am

Character set detection is very tricky, especially for short texts. UMS uses ICU4J for this. I don't think we would be able to "improve" the detection, some of the character sets are very similar and some texts simply don't use words that reveal the difference.

What you should do instead is use UTF-8. Converting them to UTF-8 can be done easily for example by using Notepad++

Madoka
Posts: 328
Joined: Fri Jun 01, 2012 12:51 pm

Re: UMS and Special Characters in Subtitles

Post by Madoka » Fri Aug 24, 2018 8:44 am

Thank you for your explanation! Much appreciated.

Post Reply