Playback pauses streaming to PS3

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
User avatar
SubJunk
Lead Developer
Posts: 3107
Joined: Sun May 27, 2012 4:12 pm

Re: Playback pauses streaming to PS3

Post by SubJunk » Fri Sep 21, 2012 10:05 pm

It will run faster on CPUs made in the last few years and the same speed on old ones, not slower :)

Daywatch
Posts: 6
Joined: Fri Jul 27, 2012 12:55 am

Re: Playback pauses streaming to PS3

Post by Daywatch » Sat Sep 22, 2012 1:03 pm

I have upgraded to the latest version of UMS again, and this time I set the max. bandwidth to 200. So far I have had no issues at all. I didn't think it would have bogged down my processor that much by using a lower value (I have a core-i7 950 in my PC with 12 GB of RAM). In either case, it seems to be working great again. Love the program - keep up the good work! :)
The problem with troubleshooting is that trouble shoots back...

User avatar
SubJunk
Lead Developer
Posts: 3107
Joined: Sun May 27, 2012 4:12 pm

Re: Playback pauses streaming to PS3

Post by SubJunk » Sat Sep 22, 2012 6:14 pm

Great :)

Daywatch
Posts: 6
Joined: Fri Jul 27, 2012 12:55 am

Re: Playback pauses streaming to PS3

Post by Daywatch » Sat Dec 29, 2012 4:41 pm

I recently upgraded to version 2.2.1, and the 'pausing' issue seems to have returned. :( At first I left the 'Maximum Bandwidth' setting at 110 as it was by default, but after having it pause on me a few times I started testing other values again. 300 seems to have resolved the issue for now, I think. I will have to try with a couple of other shows I am trying to watch and see what happens though.

I am not sure if this helps, but here is a section of the debug.log file where the issue occurred:

DEBUG 2012-12-28 22:27:04.706 [Thread-899] Disconnected pipe: \\.\pipe\1356749723493videoout
DEBUG 2012-12-28 22:27:04.707 [Thread-913] Bitstream exception Unknown exception. It does not have to be! Plase contact the application support team for more information.
DEBUG 2012-12-28 22:27:04.708 [Thread-903] Disconnected pipe: \\.\pipe\1356749723493audioout
DEBUG 2012-12-28 22:27:05.704 [Thread-897] Error : Pipe closed
DEBUG 2012-12-28 22:27:05.708 [Thread-901] Error : Pipe closed
INFO 2012-12-28 22:27:05.710 [tsMuxeR.exe-140] Process C:\Program Files (x86)\Universal Media Server\win32\tsMuxeR.exe has a return code of -3! Maybe an error occurred... check the log file
DEBUG 2012-12-28 22:27:05.710 [tsMuxeR.exe-140] Stopping process: mencoder.exe-138
DEBUG 2012-12-28 22:27:05.710 [Thread-898] Error: null
DEBUG 2012-12-28 22:27:05.711 [tsMuxeR.exe-140] Stopping process: mencoder.exe-139
DEBUG 2012-12-28 22:27:05.711 [Thread-902] Error: null
DEBUG 2012-12-28 22:27:16.074 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2012-12-28 22:29:08.608 [Buffered IO End Checker] Stopping process: tsMuxeR.exe-140

As before, I will keep testing different values to see if I find one that fixes the issue for good, but if you have any ideas please let me know.

Thanks!
The problem with troubleshooting is that trouble shoots back...

SuperDre
Posts: 61
Joined: Mon Jun 11, 2012 8:24 am

Re: Playback pauses streaming to PS3

Post by SuperDre » Sun Dec 30, 2012 3:44 am

I still can't say, haven't used UMS too much, with 2.2.1 because of the dual subtitle problem (showing embeded and external subtitles at the same time), still using latest SB PMS version, but I know I did watch a few movies with UMS (2.2.0) which didn't give me any problems.. Hope the subtitle problem is solved with the next release so I can try use it again all the time..

laferrierejc
Posts: 2
Joined: Fri Apr 12, 2013 1:46 pm

Re: Playback pauses streaming to PS3

Post by laferrierejc » Fri Apr 12, 2013 1:48 pm

I don't know why either. I was using 2.5 (after some firewall magic) it was working.

But with v2.6 , even after disabling the firewall... crying kids...

not sure why it's pausing fast forwarding on many segments of many videos...

so frustrating.

I can verify that with 2.5 it works as it should. (with firewall settings setup for javaw)

you guys broke something...

User avatar
SubJunk
Lead Developer
Posts: 3107
Joined: Sun May 27, 2012 4:12 pm

Re: Playback pauses streaming to PS3

Post by SubJunk » Fri Apr 12, 2013 4:32 pm

I suspect it's torrent programs or something clogging up the networks. People have complained about this happening since PMS was released years ago. Plus uTorrent is always updating and screwing itself up, I've noticed it with uTorrent 3.3.

frenchepaul
Posts: 3
Joined: Tue Apr 08, 2014 3:52 am

Re: Playback pauses streaming to PS3

Post by frenchepaul » Tue Apr 08, 2014 3:59 am

Hello guys,

I kind of have the same issue when streaming 720p and 1080p from my computer to my Sony BDVE-980W (surround system + bluray).
My CPU is an i5-3570k OC to 4.42Ghz, I have 16GB of RAM. My computer is connected via Cat6 (1Gb/s) to an Asus RT-N66U using Merlin's Firmware and my receiver is hooked via Cat5e to the router (100Mb/s). I'm currently using the latest version of UMS but I had this issue with previous builds (was using wifi at the time so I thought it was the issue).

Last night I played a movie and the playback stopped like 6 times while watching the movie. I had to press pause everytime, wait a few seconds then press play again and the playback would start again. I checked the Debug.log and this is what happened :
INFO 2014-04-06 18:03:39.370 [StartPlaying Event] Started playing eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv on your Sony Home Theatre System
DEBUG 2014-04-06 18:03:39.371 [StartPlaying Event] The full filename of which is: /Volumes/HD 2/Movies/Movies/eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv and the address of the renderer is: 192.168.1.11
INFO 2014-04-06 18:03:39.370 [StopPlaying Event] Stopped playing eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv on your Sony Home Theatre System
DEBUG 2014-04-06 18:03:39.371 [StopPlaying Event] The full filename of which is: /Volumes/HD 2/Movies/Movies/eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv and the address of the renderer is: 192.168.1.11
INFO 2014-04-06 18:03:44.279 [StopPlaying Event] Stopped playing eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv on your Sony Home Theatre System
DEBUG 2014-04-06 18:03:44.280 [StopPlaying Event] The full filename of which is: /Volumes/HD 2/Movies/Movies/eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv and the address of the renderer is: 192.168.1.11
INFO 2014-04-06 18:03:45.301 [StartPlaying Event] Started playing eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv on your Sony Home Theatre System
DEBUG 2014-04-06 18:03:45.301 [StartPlaying Event] The full filename of which is: /Volumes/HD 2/Movies/Movies/eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv and the address of the renderer is: 192.168.1.11
DEBUG 2014-04-06 18:05:51.297 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 18:08:51.302 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 18:12:03.379 [UPNP-AliveMessageSender] Sending ALIVE...
INFO 2014-04-06 18:12:03.380 [StopPlaying Event] Stopped playing eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv on your Sony Home Theatre System
DEBUG 2014-04-06 18:12:03.381 [StopPlaying Event] The full filename of which is: /Volumes/HD 2/Movies/Movies/eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv and the address of the renderer is: 192.168.1.11
DEBUG 2014-04-06 18:12:03.381 [StopPlaying Event] Resume stop. This segment 498080 new time 667165
INFO 2014-04-06 18:12:19.452 [StartPlaying Event] Started playing eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv on your Sony Home Theatre System
DEBUG 2014-04-06 18:12:19.452 [StartPlaying Event] The full filename of which is: /Volumes/HD 2/Movies/Movies/eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv and the address of the renderer is: 192.168.1.11
DEBUG 2014-04-06 18:15:03.384 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 18:18:03.389 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 18:21:03.394 [UPNP-AliveMessageSender] Sending ALIVE...
INFO 2014-04-06 18:23:58.406 [StopPlaying Event] Stopped playing eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv on your Sony Home Theatre System
DEBUG 2014-04-06 18:23:58.407 [StopPlaying Event] The full filename of which is: /Volumes/HD 2/Movies/Movies/eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv and the address of the renderer is: 192.168.1.11
DEBUG 2014-04-06 18:23:58.407 [StopPlaying Event] Resume stop. This segment 698955 new time 1349120
DEBUG 2014-04-06 18:24:03.398 [UPNP-AliveMessageSender] Sending ALIVE...
INFO 2014-04-06 18:24:43.915 [StartPlaying Event] Started playing eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv on your Sony Home Theatre System
DEBUG 2014-04-06 18:24:43.916 [StartPlaying Event] The full filename of which is: /Volumes/HD 2/Movies/Movies/eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv and the address of the renderer is: 192.168.1.11
DEBUG 2014-04-06 18:27:03.404 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 18:30:03.409 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 18:33:03.422 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 18:36:03.427 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 18:39:03.432 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 18:42:17.899 [UPNP-AliveMessageSender] Sending ALIVE...
INFO 2014-04-06 18:42:59.904 [StopPlaying Event] Stopped playing eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv on your Sony Home Theatre System
DEBUG 2014-04-06 18:42:59.904 [StopPlaying Event] The full filename of which is: /Volumes/HD 2/Movies/Movies/eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv and the address of the renderer is: 192.168.1.11
DEBUG 2014-04-06 18:42:59.904 [StopPlaying Event] Resume stop. This segment 1095988 new time 2428108
INFO 2014-04-06 18:42:59.904 [StartPlaying Event] Started playing eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv on your Sony Home Theatre System
DEBUG 2014-04-06 18:42:59.904 [StartPlaying Event] The full filename of which is: /Volumes/HD 2/Movies/Movies/eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv and the address of the renderer is: 192.168.1.11
DEBUG 2014-04-06 18:45:17.904 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 18:48:17.909 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 18:51:17.914 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 18:54:17.918 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 18:57:17.924 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 19:00:17.928 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 19:03:17.933 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 19:06:17.938 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 19:09:17.943 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-04-06 19:12:17.948 [UPNP-AliveMessageSender] Sending ALIVE...
INFO 2014-04-06 19:15:07.175 [StopPlaying Event] Stopped playing eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv on your Sony Home Theatre System
DEBUG 2014-04-06 19:15:07.175 [StopPlaying Event] The full filename of which is: /Volumes/HD 2/Movies/Movies/eyjafjallajokull.2013.french.720p.bluray.x264-monday27th.mkv and the address of the renderer is: 192.168.1.11
DEBUG 2014-04-06 19:15:07.175 [StopPlaying Event] Resume stop. This segment 1927271 new time 4338379
Is it normal that the server is sending keep alive signal while streaming ?
I've tried with Plex Media Server and had no issues.

Funny thing is that I cabled my computer with Cat6 because I had the same issue with Wifi and now Im pretty sure it's not network speed related or computer spec related.
I had the same issue with MEnconder, FFMpeg and TSMuxer.

Thanks for your help

Edit : I had uTorrent opened but It wasn't downloading anything and I'm limited to 30Kbp/s uploads. I also always make sure that nothing hogs my bandwidth when I'm streaming to my receiver.

Post Reply