Playback pauses streaming to PS3

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
SuperDre
Posts: 61
Joined: Mon Jun 11, 2012 8:24 am

Re: Playback pauses streaming to PS3

Post by SuperDre » Sun Aug 12, 2012 3:41 am

SharkHunter wrote:
SuperDre wrote:I don't know if I have the same problem, but for me some streaming also goes haywire.. after a few minutes the video just stops (pressing pause and wait a while will play the file for a few minutes and then the same happens).
I start the program with a bat -Xmx1536M (as the first time I installed it with a higher default heap, but that crashed the application, don't know if it's fixed with later builds)..

But i also had some problems with playing iso dvd's (which seemed to have the same problem).. But with a lot of other 720p movies I really don't have any problems, with or without subtitles..

I included the debuglogs for the one that just keeps choking.. it's the first episode of 'Episodes - season 1'.. I hope the debuglogs help.. Oh, I'm also wired gigabit and on a PS3 with rebug 3.55 CFW..
What videoformat is 'Episodes - season 1'? mpeg4 gives me some problems. And sometimes also aac audio (BRAVIA forces transcoding of everything). I think mencoder is the culprit. But we'll need to dig deeper.
according to VLC:
Episodes.S01E01.720p.HDTV.x264.mkv
Video:
Codec: H264 - MPEG-4 AVC (part 10) (avc1)
Frame rate: 23.976215
Decoded format: Planar 4:2:0 YUV
Audio:
Codec: A52 Audio (aka AC3) (a52 )
Channels: 3F2R/LFE
Sample rate: 48000 Hz
Bitrate: 384 kb/s

Daywatch
Posts: 6
Joined: Fri Jul 27, 2012 12:55 am

Re: Playback pauses streaming to PS3

Post by Daywatch » Sun Aug 26, 2012 8:12 am

SharkHunter wrote:I bashed my head bloody for quite sometime with this. Can't say waht the problem is but I have some ideas that needs some input from you here.
1) What type of video are you trying to stream? Not the contianer but the video format. I think there is an issue with mpeg4.
2) On my BRAVIA I get a complete stop after say 1 hour and then I can squeeze an extra 30 mins out of the video.
3) Are you using java 6 or 7?
I've looked over the buffering code and it has no real substansial changes lately so my hunch is that it is something outside....

1) One video that stopped on me was and MKV - the video stream was AVC and the audio stream was AC-3
2) When it stops on me, my only option is to stop playback, restart the file and the fast-forward to where it paused. After that it plays fine.
3) Using the latest Java - version 7 update 6

Hope the info is useful.
The problem with troubleshooting is that trouble shoots back...

RavenFire
Posts: 12
Joined: Fri Aug 24, 2012 4:05 pm

Re: Playback pauses streaming to PS3

Post by RavenFire » Wed Aug 29, 2012 5:55 pm

Mine seems to do this frequently as well on tv shows, but never on movies.
When the tv show pauses, i'll have to stop it and start again. Sometimes I get the 'corrupted' message, and just start and stop again. It'll then play through and I usually don't have problems the rest of the night..
I had sort of wondered if it was my router blocking packets..

My movies are always(usually) 1080p + DTS - never a problem
TV Shows are usually 720P + AC3 5.1 or 2. - very frequently happens (4/5 times on a 42 minute long show at around the 30 minute mark)

Universal media server is installed with the defaults and running java 6.

Next time it happens, I'll make a note of the show and codec being used..

User avatar
SubJunk
Lead Developer
Posts: 3012
Joined: Sun May 27, 2012 4:12 pm

Re: Playback pauses streaming to PS3

Post by SubJunk » Fri Aug 31, 2012 3:11 pm

It would be good to get one of you guys who have this bug to try installing old versions to see when it started happening :)

User avatar
SubJunk
Lead Developer
Posts: 3012
Joined: Sun May 27, 2012 4:12 pm

Re: Playback pauses streaming to PS3

Post by SubJunk » Mon Sep 03, 2012 9:48 pm

It happened to me just now so I am gonna see if I can reproduce it then hopefully fix it.

Edit: Well I played the same video through to the part where it happened and it didn't happen again, so this bug is going to be harder to reproduce

SuperDre
Posts: 61
Joined: Mon Jun 11, 2012 8:24 am

Re: Playback pauses streaming to PS3

Post by SuperDre » Fri Sep 07, 2012 1:24 pm

Had it happen again, or maybe it's something else, but I've attached the debug logs, and I see an out of memory error, so I guess it was at that point..

I'm still starting UMS with the following line: start javaw -Xmx1536M -Djava.net.preferIPv4Stack=true -Dfile.encoding=UTF-8 -classpath update.jar;ums.jar net.pms.PMS
Machine: 4GB, Windows 7 ultimate x64 , P4 3.6
Attachments
ums_dbg(201209070317).zip
(11.98 KiB) Downloaded 132 times

Daywatch
Posts: 6
Joined: Fri Jul 27, 2012 12:55 am

Re: Playback pauses streaming to PS3

Post by Daywatch » Sun Sep 16, 2012 12:19 pm

I changed the 'Maximum bandwidth' to '400' in advanced network settings (I had originally set it to zero for no limit and that was when I started having problems). Since I changed it to 400 I have only had one TV show pause on me.

I have since upgraded to the latest version of UMS and latest Java. So far I have the same results - with the setting at 400 I have had fewer pauses. I am going to try different settings for this and see what happens. If I find a setting that works I will post my findings in case anyone else wants to try them.
The problem with troubleshooting is that trouble shoots back...

User avatar
SubJunk
Lead Developer
Posts: 3012
Joined: Sun May 27, 2012 4:12 pm

Re: Playback pauses streaming to PS3

Post by SubJunk » Mon Sep 17, 2012 4:09 pm

Daywatch, that probably means your pauses were caused by a CPU-bottleneck, since the lower the value of "maximum bandwidth" is, the more intensive it will be on CPU

User avatar
SubJunk
Lead Developer
Posts: 3012
Joined: Sun May 27, 2012 4:12 pm

Re: Playback pauses streaming to PS3

Post by SubJunk » Fri Sep 21, 2012 7:59 am

This issue has hopefully been fixed in version 1.5.1.
Note that there can be many causes of pausing streaming, like a CPU that is too slow for the content, and a wireless network, or misconfigured or slow router, or a renderer that limits connection speed (like OPPO devices) but this bug was happening when all those things were accounted for.

SuperDre
Posts: 61
Joined: Mon Jun 11, 2012 8:24 am

Re: Playback pauses streaming to PS3

Post by SuperDre » Fri Sep 21, 2012 5:20 pm

SubJunk wrote:This issue has hopefully been fixed in version 1.5.1.
Note that there can be many causes of pausing streaming, like a CPU that is too slow for the content, and a wireless network, or misconfigured or slow router, or a renderer that limits connection speed (like OPPO devices) but this bug was happening when all those things were accounted for.
will try it later, had been using the latest SB-build of PS3MS instead of UMS, I had too many movies/series pause on me (ofcourse that could also be a different problem).

hmm, I see you did some CPU optimizations so it will run faster, could that maybe also have an negative effect on a P4 3.6 (x64) with hyperthreading which is seen as 2 cores..

Post Reply