PS4 now support DLNA!

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
TheRiddler303
Posts: 5
Joined: Sat Jun 20, 2015 8:09 pm

Re: PS4 now support DLNA!

Post by TheRiddler303 » Fri Jul 10, 2015 7:09 am

since installing UMS 5.2.0 my PMS isnt running anymore using mencoder.
it was my default setting over years and worked steady.

UMS is still buggy for me on ps4. picture stutters heavy. Even on the low wifi setting, its wired though!
same on ps3 with UMS. CPU Load is only 5% so guess thats not the problem here. its something about the ffmpeg trancoding imo as i never had this before.

Now if i go back to PMS on PS3 with mencoder enables as prior, it says file cannot playbacked (likewise translated to english) and also displays an PS3 errorcode. somehow it sounds a bit like the error we had on ps4 in the last weeks with DTS files?
if i switch to ffmpeg on PMS, every 5 minutes the picture stucks and i have to restart the video to get a/v synced again. also here after a certain time, it starts to stutter like UMS.

i uninstalled both programs, incl. config files and reinstalled PMS, but still not working anymore. What file was overwritten with the UMS 5.2 installation? as it was working perfect since yesterday :?
Would appreciate any help, as a fresh install of my whole PC would be a mess and timekiller just to watch a video again

User avatar
valib
Developer
Posts: 653
Joined: Fri Feb 08, 2013 3:11 am

Re: PS4 now support DLNA!

Post by valib » Fri Jul 10, 2015 7:49 am

TheRiddler303 wrote:What file was overwritten with the UMS 5.2 installation? as it was working perfect since yesterday :?
UMS instalation doesn't override anything in the PMS or in the OS. All UMS and PMS files are simply extracted to separate folders. There are no changes in the OS enviroment. So the problem you described seems to be related to your OS or other programs running.

MXDTV
Posts: 3
Joined: Fri Jul 10, 2015 3:33 am

Re: PS4 now support DLNA!

Post by MXDTV » Fri Jul 10, 2015 8:02 am

Anybody able to transcode FLAC to MP3 or AAC?

During Playback UMS says: "No encoding" :?: :?:
Attachments
ums_dbg.zip
(152.2 KiB) Downloaded 93 times

TheRiddler303
Posts: 5
Joined: Sat Jun 20, 2015 8:09 pm

Re: PS4 now support DLNA!

Post by TheRiddler303 » Sat Jul 11, 2015 4:56 am

valib wrote:
TheRiddler303 wrote:What file was overwritten with the UMS 5.2 installation? as it was working perfect since yesterday :?
UMS instalation doesn't override anything in the PMS or in the OS. All UMS and PMS files are simply extracted to separate folders. There are no changes in the OS enviroment. So the problem you described seems to be related to your OS or other programs running.
understand. so as mencoder isnt working anymore with PMS, can i guess there is some newer mencoder programm in the background running that PMS is anymore capable off to work with?
wouldnt make any sense that straight after installing UMS 5.2, the PMS isnt running anymore. It worked before with the UMS test versions though!
and no i didnt installed anything else. Im not a coder crackhead, but know as much from my OS that i didnt do any changes on here last night (saying just in case to leave that out :lol: )

it has to be something with mencoder directly, as ffmpeg is -not good- but working someway and never had the error message before on my ps3.

jMollys
Posts: 4
Joined: Wed Jun 17, 2015 8:25 am

Re: PS4 now support DLNA!

Post by jMollys » Sat Jul 11, 2015 9:13 am

MXDTV wrote:Anybody able to transcode FLAC to MP3 or AAC?

During Playback UMS says: "No encoding" :?: :?:
I do not know if it is related but I'm now unable to stream web audio via MP3 since updating to 5.2.0.

I had to add "Transcodeaudio = MP3" to the PS4 render profile on 5.1.3 to work sometimes. With the 5.1.3 version it would end the stream within 10 minutes or less. Now it does not work period.

Oh well.. I know Subjunk and the developers are hard at work. I'm keeping an eye on them over on Github. :)

PS3 still rocking it like a champ thankfully!

User avatar
SubJunk
Lead Developer
Posts: 2936
Joined: Sun May 27, 2012 4:12 pm

Re: PS4 now support DLNA!

Post by SubJunk » Sat Jul 11, 2015 3:20 pm

I just saw a post on the forum that someone was able to rewind and fast-forward on PS4 with version 5.1.4. I assume it was being detected as PS3 then. Can anyone confirm?

Whogie
Posts: 49
Joined: Thu Aug 02, 2012 7:59 pm

Re: PS4 now support DLNA!

Post by Whogie » Sat Jul 11, 2015 6:58 pm

5.1.4 shows as an Unknown Renderer. Transcodes fail.
I tried a file with DTS and it played without audio, but let me scrub.

5.2.1 detects PS4 properly, and lets me scrub on a supported m4v file.
When playing the DTS file, it seems to encode, but does not allow scrubbing.

Logs attached.

Edit: For what it's worth, deleting and editing SeekByTime to true and false did nothing for 5.2.1's ability to fast forward encoded video.
Attachments
ps4 5.2.1.zip
(69.2 KiB) Downloaded 100 times
ps4 5.1.4.zip
(87.36 KiB) Downloaded 94 times

AlGrenadine
Posts: 51
Joined: Wed Jun 24, 2015 7:21 pm

Re: PS4 now support DLNA!

Post by AlGrenadine » Sat Jul 11, 2015 9:49 pm

SubJunk wrote:I just saw a post on the forum that someone was able to rewind and fast-forward on PS4 with version 5.1.4. I assume it was being detected as PS3 then. Can anyone confirm?
Yes ff/rw worked in 5.1.4

jMollys
Posts: 4
Joined: Wed Jun 17, 2015 8:25 am

Re: PS4 now support DLNA!

Post by jMollys » Sun Jul 12, 2015 12:49 am

SubJunk wrote:I just saw a post on the forum that someone was able to rewind and fast-forward on PS4 with version 5.1.4. I assume it was being detected as PS3 then. Can anyone confirm?
Interesting stuff with 5.2.1 running on PS4. I'm only able to discuss my findings on audio only (MP3) files. MP3 files on my computer now work again including the ability to FF/RR.

Although on several files I get the following:
"07-11 08:49:50 The file C:\Users\Jeffrey\Desktop\M.I.K.E\M.I.K.E._-_Club_Elite_Sessions_406_-_24-04-2015.mp3 could not be parsed. It will be hidden"

When attempting to stream web audio I noticed the following:
The folders now display on my screen WITHOUT "transcode audio = mp3" verbiage placed in the PS4 renderer profile. The audio still will not play and I just get a lighting bolt symbol. I do not get the "no encoding" any longer.
Attachments
ums_dbg.zip
(61.21 KiB) Downloaded 88 times

AlGrenadine
Posts: 51
Joined: Wed Jun 24, 2015 7:21 pm

Re: PS4 now support DLNA!

Post by AlGrenadine » Sun Jul 12, 2015 7:16 am

I tried 5.2.1 tonight and it's catastrophic : videos not transcoded sto pplaying after few seconds and the PS4 says "unreadable media".
Transcoded videos have very long a/v sync issues (many seconds)...

Back to pre-5.2.0 alpha version...

Post Reply