PS4 now support DLNA!

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
ExSport
Posts: 596
Joined: Wed Oct 10, 2012 1:57 am

Re: PS4 now support DLNA!

Post by ExSport » Wed Jul 15, 2015 1:42 am

@nk69it:
You started it at 21:15:34 and it ended at 21:31:44 prematurely (Duration: 00:40:41)?

Code: Select all

DEBUG 21:31:37.130 [ffmpeg.exe-13-2] frame=43173 fps= 38 q=20.0 size=  735898kB time=00:28:47.56 bitrate=3489.6kbits/s dup=3 drop=0    
DEBUG 21:31:38.131 [ffmpeg.exe-13-2] frame=43191 fps= 38 q=20.0 size=  736378kB time=00:28:48.01 bitrate=3490.9kbits/s dup=3 drop=0    
TRACE 21:31:38.943 [ffmpeg.exe-13-Timer] buffered: 208.047.595 bytes / inputs: 1
DEBUG 21:31:39.146 [ffmpeg.exe-13-2] frame=43209 fps= 38 q=20.0 size=  736878kB time=00:28:48.97 bitrate=3491.4kbits/s dup=3 drop=0    
DEBUG 21:31:39.271 [UPNP-AliveMessageSender] Sending ALIVE...
TRACE 21:31:39.271 [UPNPHelper] Receiving a NOTIFY from [192.168.0.2:54181]
TRACE 21:31:39.271 [nioEventLoopGroup-3-5] Ignoring self-originating request from /192.168.0.2:64179
DEBUG 21:31:40.147 [ffmpeg.exe-13-2] frame=43230 fps= 38 q=18.0 size=  737325kB time=00:28:49.48 bitrate=3492.5kbits/s dup=3 drop=0    
TRACE 21:31:40.662 [nioEventLoopGroup-3-13] Ready to Stop: true
TRACE 21:31:40.944 [ffmpeg.exe-13-Timer] buffered: 754.003.724 bytes / inputs: 0
DEBUG 21:31:43.163 [ffmpeg.exe-13-Cleanup] Stopping process: ffmpeg.exe-13
TRACE 21:31:43.163 [ffmpeg.exe-13-Cleanup] Destroying buffer
DEBUG 21:31:43.163 [Thread-54] Error: null
TRACE 21:31:44.179 [ffmpeg.exe-13] EOF
Please try to transcode file outside PS4, to local system and when finished, check if final file is with duration of 40:41 or it ended prematurely as when streamed to PS4.
It will help to troubleshoot if problem is file itself, FFmpeg or that problem was on network side. Use this command line in CMD:

Code: Select all

"D:\DVD\Programs\Universal Media Server\win32\ffmpeg.exe" -y -loglevel info -i "V:\SerieTV\The Flash\The.Flash.2014.1x18.Bug-Eyed.Bandit.ITA.WEB-DLMux.x264-iGM.mp4" -filter_complex "subtitles=V\\:/SerieTV/The Flash/The.Flash.2014.1x18.Bug-Eyed.Bandit.ITA.WEB-DLMux.x264-iGM.srt:720x404:ISO-8859-1" -bufsize 31250000 -maxrate 31250000 -crf 19 -ab 448k -c:a ac3 -c:v libx264 -tune zerolatency -preset ultrafast -level 31 -pix_fmt yuv420p -f mpegts D:\output.ts
[/size]
It should create output.ts file on D:\ so check it and post results or attach error message if manual run will fail to start.

gbulfon
Posts: 1
Joined: Fri Jul 17, 2015 4:37 am

Re: PS4 now support DLNA!

Post by gbulfon » Fri Jul 17, 2015 4:43 am

Hi.

I just ported UMS into our XStreamOS / illumos distro (opensolaris).
It works great!

Mainly I tried it on PS4, and yes I can help development of this jewel.

How can I help?
I experience all of the troubles stated in this thread, on PS4.
At first I thought I had problems with my distro ffmpeg etc all built from sources by myself.
Now I see the binary tools works great, tried them manually reproducing the commands stated in the logs.
Le me know how I can help enhance this great software to play on PS4 perfectly.

;)

radamo
Posts: 30
Joined: Thu Aug 14, 2014 12:12 am

Re: PS4 now support DLNA!

Post by radamo » Fri Jul 17, 2015 10:28 am

WOW!!!!
A few days away from this and you guys are really making progress.

Just tried two random MKV's of mine with only DTS audio tracks. Used the "transcode" FMPEG version and both worked great!!! As you know, no FF or RW yet but great progress.
Thanks so much.

radamanthyspl
Posts: 6
Joined: Mon May 27, 2013 12:07 am

Re: PS4 now support DLNA!

Post by radamanthyspl » Mon Jul 20, 2015 3:52 am

Hey, it finally works, one question though - anybody else cannot rewind or forward the video clips on PS4? there's no times/duration on those clips either.

emoolaf
Posts: 17
Joined: Tue Jun 30, 2015 5:00 am

Re: PS4 now support DLNA!

Post by emoolaf » Mon Jul 20, 2015 4:15 am

where can I download the latest version?

do mkv files with dts sound work now?

AlGrenadine
Posts: 51
Joined: Wed Jun 24, 2015 7:21 pm

Re: PS4 now support DLNA!

Post by AlGrenadine » Mon Jul 20, 2015 5:31 am

radamanthyspl wrote:Hey, it finally works, one question though - anybody else cannot rewind or forward the video clips on PS4? there's no times/duration on those clips either.
No we can't

Jbsnake
Posts: 5
Joined: Tue Jul 14, 2015 2:02 am

Re: PS4 now support DLNA!

Post by Jbsnake » Mon Jul 20, 2015 9:43 pm

Lasher wrote:
Since I went back to 5.1.4 i havent had any more problems of UMS crashing ... that being said Ive also stopped running anything else with it like download clients etc ... so far so good.
I have set a static ip in the UMS options field for the server (computer) too ... Im runing 32bit windows 7 pro.

as far as i know PS4 media app doesnt support DTS in any way or form so even streaming it wont work ... i could be wrong on this though.
Setting a static IP for the ps4 solved the disconnection issue for me! Filtrering away everything else seems to cause less conflicts somehow.. :D works on 5.2.1 for me.

Lasher
Posts: 15
Joined: Mon Jul 13, 2015 9:44 pm

Re: PS4 now support DLNA!

Post by Lasher » Tue Jul 21, 2015 5:01 am

Jbsnake wrote:
Setting a static IP for the ps4 solved the disconnection issue for me! Filtrering away everything else seems to cause less conflicts somehow.. :D works on 5.2.1 for me.
I'll give that a go tomorrow ...cheers jb :)

*EDIT*
Ok I updated back to 5.2.1(clean install) and set a static ip on the PS4 ... so far no crashing but the strange this is ..I still have FF/RW ... I wonder how that happened when everyone else says its not working ? ... although i should add that im not transcoding anything ...im playing the file as it is ....is the problem only with transcoding ?

Jbsnake
Posts: 5
Joined: Tue Jul 14, 2015 2:02 am

Re: PS4 now support DLNA!

Post by Jbsnake » Wed Jul 22, 2015 8:47 am

It's only with transcoding FF / RW is an issue. Cheers for getting it to work though ;)

Lasher
Posts: 15
Joined: Mon Jul 13, 2015 9:44 pm

Re: PS4 now support DLNA!

Post by Lasher » Fri Jul 24, 2015 3:47 am

Jbsnake wrote:It's only with transcoding FF / RW is an issue. Cheers for getting it to work though ;)
Hahaha ...after i wrote that i went to my PS4 and tried it while transcoding ...it didnt work :D

Hopefully the next update will fix it although to be honest it doesnt really bother Me.

its great setting a static ip fixes the crashes though ;)

Post Reply