Mkv playback stuttering/freezing after fast forward / rewind

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Freich
Posts: 8
Joined: Sun Feb 17, 2013 4:16 am

Mkv playback stuttering/freezing after fast forward / rewind

Post by Freich » Sun Feb 17, 2013 4:33 am

I love this program and find it the best DLNA server I could find.
Only problem I now have is with playing .mvk files. Works fine with Mencoder and subtitles. But when I need to fastforward for example, the fun is over.
The .mkv won't play normally anymore, even when I try pausing and unpausing. Also a lot of the times it's completely frozen and I need to exit to the home menu of my player.

Any ideas suggestions? This is really a dealbreaker for me personally.

Keep up the good work!

Regards,
Freich

User avatar
Optimus_prime
Posts: 690
Joined: Fri Jun 01, 2012 6:39 pm
Location: Sydney, Australia

Re: Mkv playback stuttering/freezing after fast forward / re

Post by Optimus_prime » Sun Feb 17, 2013 9:37 am

check this out
viewtopic.php?f=9&t=556

include a debug log so we can help you better
How Ask For Support
Remember, Debug Log's Can/Will Help and Explain your issues, we're not mind reader's but here to help
OS's I Use And Can Assist With: Windows 7/8, Mac OS-X 10.8 & 10.9
Mac OS-X Java 7 Builds Mac OS-X Java 7 Forum

User avatar
SubJunk
Lead Developer
Posts: 2934
Joined: Sun May 27, 2012 4:12 pm

Re: Mkv playback stuttering/freezing after fast forward / re

Post by SubJunk » Sun Feb 17, 2013 9:46 am

It's not a bug, this is just how it is. Rewinding and fast-forwarding is possible with files that are not being transcoded, but with files that your device does not support we need to transcode them which means your computer is encoding them while you watch. When you fast-forward it means your computer has to encode much faster to keep up so it becomes a race between the fast-forward and your CPU. When the CPU is fast enough for the race, everything is OK, but when it isn't the buffer runs out and it stutters.
If you are using a PS3 it's a lot more convenient to use the "go to" function anyway when you get used to it since it is faster than fast-forward or rewind.

Freich
Posts: 8
Joined: Sun Feb 17, 2013 4:16 am

Re: Mkv playback stuttering/freezing after fast forward / re

Post by Freich » Sun Feb 17, 2013 12:02 pm

Thanks for the reply.
I found a sort of fix for my problem. I'm now using the transcode folder chapter support option. So now I can select mkv time chapters instead of forwarding.

An go to option isn't available for me on my device sadly.

User avatar
squadjot
Moderator
Posts: 651
Joined: Fri Jun 01, 2012 4:24 am

Re: Mkv playback stuttering/freezing after fast forward / re

Post by squadjot » Sun Feb 17, 2013 12:06 pm

Whaty device are you using?

And..you say that you have forward/backward option. As SubJunk points out, while it works quite slow, and in chunks.. it should still work. If it doesent (movie stops playback..or blacks out)..then i'd say you should post debug log of it =)

User avatar
kuroukage
Posts: 304
Joined: Wed Dec 12, 2012 3:56 pm

Re: Mkv playback stuttering/freezing after fast forward / re

Post by kuroukage » Sun Feb 17, 2013 12:25 pm

Under the Transcoding Settings Tab > Common Transcode Settings > General Settings

Make sure #--TRANSCODE--# folder chapter support: (interval in minutes) is checked and I set mine to 1

This way it makes it easier to skip forward without having to hold down the FF button.
黒影
_______________________________________________|_._._._._._._._._._
\______________________________________________|_#_#_#_#_#_#_|
------------------------------------------------------------------|---------------------

Freich
Posts: 8
Joined: Sun Feb 17, 2013 4:16 am

Re: Mkv playback stuttering/freezing after fast forward / re

Post by Freich » Mon Feb 18, 2013 10:42 pm

squadjot wrote:Whaty device are you using?

And..you say that you have forward/backward option. As SubJunk points out, while it works quite slow, and in chunks.. it should still work. If it doesent (movie stops playback..or blacks out)..then i'd say you should post debug log of it =)
I will post a debug log later on! :)
kuroukage wrote:Under the Transcoding Settings Tab > Common Transcode Settings > General Settings

Make sure #--TRANSCODE--# folder chapter support: (interval in minutes) is checked and I set mine to 1

This way it makes it easier to skip forward without having to hold down the FF button.
Yes I have that enabled as i said in my previous post ;)

Freich
Posts: 8
Joined: Sun Feb 17, 2013 4:16 am

Re: Mkv playback stuttering/freezing after fast forward / re

Post by Freich » Mon Feb 18, 2013 10:46 pm


Freich
Posts: 8
Joined: Sun Feb 17, 2013 4:16 am

Re: Mkv playback stuttering/freezing after fast forward / re

Post by Freich » Tue Feb 19, 2013 12:40 am

Did some more testing with different render profiles etc.
I underestimated the importance/relevance of those. Since I noticed very different behavior and compatibility with different profiles. (Doh!).

Used to use PS3 profile for my BDV-E190. Worked ok except forwarding etc. When I used Unknow renderer it presented me with some pure MKV movies straight away.
Those played perfectly, and I could fast forward and play without any troubles. Sounds logical because no transcoding is running on my pc.
Except now the dvd iso's aren't supported for playback.

I guess my sollution will be, creating an personal conf file for my renderer. That supports pure mkv and dvd iso playback.
No idea how yet ;)

ExSport
Posts: 596
Joined: Wed Oct 10, 2012 1:57 am

Re: Mkv playback stuttering/freezing after fast forward / re

Post by ExSport » Tue Feb 19, 2013 2:06 am

I have quadcore quite old CPU with 1Gbit network. I have 2 PS3 and 2 Panasonic TV renderers.
PanTV is 100Mbit only and quite poor 100Mbit (or limited video bandwidth) so in reality it can achieve about 60-80Mbit max.
Also with this configuration I have no problems to use FF/RW on PS3 nor PanTV.
The main rule is to not "over-request" UMS in this case. So if you started to FFWD, give time to UMS so don't send another "different" requests like another FFWD, RWD because it seems it doesn't react.
It reacts but sometimes with some delay (eg. on WIFI it is much longer) so be patient.
My TV has 4 steps for FF/RW, activated by pressing, not by holding. So if I set 3rd step of FF (almost fastest), it is good to wait a while and see the progress before chaotically clicking another buttons on remote 8-)
Then I have no problems with FF/RW. I click on FF 3x, wait 2-3secs and then TV starts to FF so I can see every 1 sec change of position about e.g. 10min (depending on used step of FF/RW). Very reliable :mrgreen:
I am sure the latency on WIFI or weaker CPU will be greater but it should somehow work :)

Post Reply