Can't play video files only

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
ken.yong
Posts: 2
Joined: Sun Feb 17, 2013 12:47 pm

Can't play video files only

Post by ken.yong » Sun Feb 17, 2013 12:52 pm

I have configured UMS to play music files and photos OK on my Samsung TV. However, I am unable to play ANY video files (tried different file extensions still unsuccessful). I can browse and see the thumbnails, just can't play them. [Plex and Serviio play videos well on TV if it is relevant]

Since I can play music files and photos OK, it leads me to believe UMS can communicate with my TV well. I am just not sure why I can't play videos.

Any help is appreciated!

User avatar
kuroukage
Posts: 304
Joined: Wed Dec 12, 2012 3:56 pm

Re: Can't play video files only

Post by kuroukage » Sun Feb 17, 2013 1:32 pm

What model is your TV and which renderer is UMS using for it?
黒影
_______________________________________________|_._._._._._._._._._
\______________________________________________|_#_#_#_#_#_#_|
------------------------------------------------------------------|---------------------

ken.yong
Posts: 2
Joined: Sun Feb 17, 2013 12:47 pm

Re: Can't play video files only

Post by ken.yong » Sun Feb 17, 2013 5:27 pm

It's Samsung UN55EH6070.

Renderer is XBMC on desktop and Samsung AllShare on TV.

I did see the followings in my log:
"Process C:\Program Files\Universal Media Server\win32\ffmpeg.exe has a return code of 1! Maybe an error occurred... check the log file"

and

Buffer read ArrayIndexOutOfBoundsException error:
02-16 19:25:46 readCount: "99999750000"
02-16 19:25:46 maxMemorySize: "209715200"

jackychen159
Posts: 1
Joined: Mon Feb 18, 2013 10:36 pm

Re: Can't play video files only

Post by jackychen159 » Mon Feb 18, 2013 10:58 pm

I have same problem.

My samsung TV can't play any transcoded video.

I add two line in the bottom of SamsungAllShare.conf to disable transcode

Code: Select all

MediaInfo = true                     
Supported = f:.+  
or just add video's extension after

Code: Select all

StreamExtensions=mkv,mp3,mp4,avi,mov
now, my TV can play FLV MPE and RMVB, but still can't play MPEG-1 or WMV

btw, ps3mediaserver have similar problem and i didn't find solution in their forum.

User avatar
valib
Developer
Posts: 651
Joined: Fri Feb 08, 2013 3:11 am

Re: Can't play video files only

Post by valib » Tue Feb 19, 2013 1:22 am

Can you provide debug.log see topic "How to ask for support" to help us identify your problem?

tubby
Posts: 9
Joined: Wed Feb 27, 2013 7:06 pm

Re: Can't play video files only

Post by tubby » Sat Mar 09, 2013 3:02 am

I am experiencing the same issues as ken.yong with my Samsung AllShare. ArrayIndexOutOfBounds excpetion. I also get this on my Android Device.

I am trying different transcoding engines and the problem differs between them. I'll try to collect a recent debug log when using my Samsung renderer .

User avatar
kuroukage
Posts: 304
Joined: Wed Dec 12, 2012 3:56 pm

Re: Can't play video files only

Post by kuroukage » Sat Mar 09, 2013 3:36 am

Please see this topic as Valib suggests and post your debug.log files.
黒影
_______________________________________________|_._._._._._._._._._
\______________________________________________|_#_#_#_#_#_#_|
------------------------------------------------------------------|---------------------

tubby
Posts: 9
Joined: Wed Feb 27, 2013 7:06 pm

Re: Can't play video files only

Post by tubby » Wed Mar 13, 2013 7:59 am

kuroukage wrote:Please see this topic as Valib suggests and post your debug.log files.
Will do :-), I attached a debug package covering (trace enabled) when I am trying to transcode a DVD ISO. I'm getting ArrayIndexOutOfBoundsException. I assume it is part of the buffering process, when looking at the code.

When running the mencoder command directly on the computer running UMS on the command line and then reading it via mplayer or vlc it works, so something is not working as expected.

Avi files are working however but any transcoding seems to fail. I am running kubuntu 12.04 LTS and I have tried both IcedTea and Oracle java 7 versions.
Attachments
ums_dbg_samsung.zip
(44.91 KiB) Downloaded 132 times

tubby
Posts: 9
Joined: Wed Feb 27, 2013 7:06 pm

Re: Can't play video files only

Post by tubby » Sat Mar 16, 2013 8:46 pm

I finally got transcoding of DVD:s to work on my Samsung TV. I tried different settings on Mencoder and I tried debugging the code of UMS but no light was shed on my problem.

The thing that was missing was in the SamsungAllShare.conf and the following line.

Code: Select all

ChunkedTransfer=true

Post Reply