Youtube feeds no longer working.

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
inkrypted
Posts: 4
Joined: Mon Feb 18, 2013 8:59 am

Youtube feeds no longer working.

Post by inkrypted » Mon Feb 18, 2013 9:23 am

I have a feed for Equals Three set up in my WEB.conf that I used to use with PS3 Media Server. and after switching to Universal Media Server that feed no longer works. I was using the pmsencoder plugin from Chocolateboy (Latest version) so I just moved the plugin into the UMS directory . As mentioned in another post i have installed youtube-dl When I attempt to play the stream I get and error that the content cannot be played back and the following errors in the log.

Code: Select all

02-17 15:16:44  PMSEncoder: match error
org.codehaus.groovy.runtime.InvokerInvocationException: Assertion failed: 

assert t != null
       | |
       | false
       null

	at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:97) ~[na:na]
	at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:233) ~[na:na]
	at org.codehaus.groovy.runtime.metaclass.ClosureMetaClass.invokeMethod(ClosureMetaClass.java:273) ~[na:na]
	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:886) ~[na:na]
	at groovy.lang.Closure.call(Closure.java:282) ~[na:na]
	at groovy.lang.Closure.call(Closure.java:277) ~[na:na]
	at com.chocolatey.pmsencoder.Profile.runActionBlock(Profile.groovy:70) ~[na:na]
	at com.chocolatey.pmsencoder.Profile.match(Profile.groovy:114) ~[na:na]
	at com.chocolatey.pmsencoder.Matcher$match$3$1.doCall(Matcher.groovy:47) ~[na:na]
	at com.chocolatey.pmsencoder.Matcher$match$3$1.call(Matcher.groovy) ~[na:na]
	at com.chocolatey.pmsencoder.Matcher$match$3$1.call(Matcher.groovy) ~[na:na]
	at groovypp.util.Iterations.each(Iterations.groovy:98) ~[na:na]
	at groovypp.util.Iterations.each(Iterations.groovy:154) ~[na:na]
	at com.chocolatey.pmsencoder.Matcher$match$3.doCall(Matcher.groovy:46) ~[na:na]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.7.0_09]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) ~[na:1.7.0_09]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.7.0_09]
	at java.lang.reflect.Method.invoke(Method.java:601) ~[na:1.7.0_09]
	at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:90) ~[na:na]
	at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:233) ~[na:na]
	at org.codehaus.groovy.runtime.metaclass.ClosureMetaClass.invokeMethod(ClosureMetaClass.java:273) ~[na:na]
	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:886) ~[na:na]
	at groovy.lang.Closure.call(Closure.java:282) ~[na:na]
	at groovy.lang.Closure.call(Closure.java:295) ~[na:na]
	at org.codehaus.groovy.runtime.DefaultGroovyMethods.each(DefaultGroovyMethods.java:1220) ~[na:na]
	at org.codehaus.groovy.runtime.DefaultGroovyMethods.each(DefaultGroovyMethods.java:1196) ~[na:na]
	at groovypp.util.Iterations.each(Iterations.groovy:280) ~[na:na]
	at com.chocolatey.pmsencoder.Matcher.match(Matcher.groovy:45) ~[na:na]
	at com.chocolatey.pmsencoder.Matcher.match(Matcher.groovy) ~[na:na]
	at com.chocolatey.pmsencoder.Plugin.match(Plugin.groovy:254) ~[na:na]
	at com.chocolatey.pmsencoder.PMSEncoder.launchTranscode(PMSEncoder.groovy:104) ~[na:na]
	at net.pms.dlna.DLNAResource.getInputStream(DLNAResource.java:1746) [ums.jar:2.4.2]
	at net.pms.network.Request.answer(Request.java:245) [ums.jar:2.4.2]
	at net.pms.network.RequestHandler.run(RequestHandler.java:246) [ums.jar:2.4.2]
	at java.lang.Thread.run(Thread.java:722) [na:1.7.0_09]
Caused by: org.mbte.groovypp.runtime.powerassert.PowerAssertionError: assert t != null
       | |
       | false
       null
	at com.chocolatey.pmsencoder.Action.youtube(Action.groovy:321) ~[na:na]
	at com.chocolatey.pmsencoder.Action.youtube(Action.groovy) ~[na:na]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.7.0_09]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) ~[na:1.7.0_09]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.7.0_09]
	at java.lang.reflect.Method.invoke(Method.java:601) ~[na:1.7.0_09]
	at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:90) ~[na:na]
	at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:233) ~[na:na]
	at org.codehaus.groovy.runtime.metaclass.ClosureMetaClass.invokeMethod(ClosureMetaClass.java:362) ~[na:na]
	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:886) ~[na:na]
	at org.codehaus.groovy.runtime.callsite.PogoMetaClassSite.callCurrent(PogoMetaClassSite.java:66) ~[na:na]
	at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCallCurrent(CallSiteArray.java:44) ~[na:na]
	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:141) ~[na:na]
	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:145) ~[na:na]
	at youtube$_run_closure1_closure5_closure16.doCall(youtube.groovy:112) ~[na:na]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.7.0_09]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) ~[na:1.7.0_09]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.7.0_09]
	at java.lang.reflect.Method.invoke(Method.java:601) ~[na:1.7.0_09]
	at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:90) ~[na:na]
	at groovy.lang.MetaMethod.doMethodInvoke(MetaMethod.java:233) ~[na:na]
	at org.codehaus.groovy.runtime.metaclass.ClosureMetaClass.invokeMethod(ClosureMetaClass.java:273) ~[na:na]
	at groovy.lang.MetaClassImpl.invokeMethod(MetaClassImpl.java:886) ~[na:na]
	at org.codehaus.groovy.runtime.callsite.PogoMetaClassSite.callCurrent(PogoMetaClassSite.java:66) ~[na:na]
	at org.codehaus.groovy.runtime.callsite.CallSiteArray.defaultCallCurrent(CallSiteArray.java:44) ~[na:na]
	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:141) ~[na:na]
	at org.codehaus.groovy.runtime.callsite.AbstractCallSite.callCurrent(AbstractCallSite.java:149) ~[na:na]
	at youtube$_run_closure1_closure5_closure16.doCall(youtube.groovy) ~[na:na]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.7.0_09]
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) ~[na:1.7.0_09]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.7.0_09]
	at java.lang.reflect.Method.invoke(Method.java:601) ~[na:1.7.0_09]
	at org.codehaus.groovy.reflection.CachedMethod.invoke(CachedMethod.java:90) ~[na:na]
	... 34 common frames omitted
02-17 15:16:55  There is no inputstream to return for HARLEM SHAKE VIDEOS
Also if I check use Mplayer for Thumbnails I get no thumbnails at all. I also noticed that UMS reports my Java version as Java: 1.7.0_09-Oracle Corporation In reality i am using.
java version "1.7.0_13"
Java(TM) SE Runtime Environment (build 1.7.0_13-b20)
Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)

As indicated by running java -version. I am using openSUSE 64 bit. Any help would be appreciated Thanks.
Attachments
ums_dbg.zip
(4.01 KiB) Downloaded 105 times

R9deLima
Posts: 41
Joined: Tue Jan 08, 2013 9:33 am

Re: Youtube feeds no longer working.

Post by R9deLima » Thu Feb 28, 2013 6:58 am

I have Youtube feeds in my web.conf for the latest UMS and PMS and all have stopped working. I'm not sure when they stopped working, but I just noticed yesterday. Youtube must have changed something.

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Youtube feeds no longer working.

Post by SharkHunter » Thu Feb 28, 2013 7:03 am

YouTube works via Channels. Try installing it and use youtube from there
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

R9deLima
Posts: 41
Joined: Tue Jan 08, 2013 9:33 am

Re: Youtube feeds no longer working.

Post by R9deLima » Thu Feb 28, 2013 3:05 pm

Thanks SharkHunter! I've been using the youtube jumpy plugin and that works perfectly fine. I rarely use feeds in web.conf anymore. I was just curious as to why they stopped working. Jumpy and the channel plugin work well. Cheers!

User avatar
kuroukage
Posts: 304
Joined: Wed Dec 12, 2012 3:56 pm

Re: Youtube feeds no longer working.

Post by kuroukage » Thu Feb 28, 2013 3:13 pm

@r9

Are you using the latest version of youtube-dl? They've been updating it a lot lately. All my feeds in web.conf for Youtube still work just fine. As well as in Jumpy and Channels.
黒影
_______________________________________________|_._._._._._._._._._
\______________________________________________|_#_#_#_#_#_#_|
------------------------------------------------------------------|---------------------

R9deLima
Posts: 41
Joined: Tue Jan 08, 2013 9:33 am

Re: Youtube feeds no longer working.

Post by R9deLima » Fri Mar 01, 2013 4:14 am

Hi kuroukage,

The version of youtube-dl I have must be dated because I've never had to update it manually before. I thought it was pre-installed in UMS? Does it have to be downloaded to a specific location and do I need to add any command lines to UMS.conf? Thanks for your time.

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Youtube feeds no longer working.

Post by SharkHunter » Fri Mar 01, 2013 9:02 am

I haven't updated my youtube-dl for a while and since it works for me it should mast likely work for the rest....
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

User avatar
kuroukage
Posts: 304
Joined: Wed Dec 12, 2012 3:56 pm

Re: Youtube feeds no longer working.

Post by kuroukage » Fri Mar 01, 2013 2:05 pm

SharkHunter wrote:I haven't updated my youtube-dl for a while and since it works for me it should mast likely work for the rest....
I've run into problems before where Youtube links stopped working and I had to download the latest youtube-dl so it would work properly again. Now I just figure might as well keep it up to date, so I don't have to worry about that again.
R9deLima wrote:Hi kuroukage,

The version of youtube-dl I have must be dated because I've never had to update it manually before. I thought it was pre-installed in UMS? Does it have to be downloaded to a specific location and do I need to add any command lines to UMS.conf? Thanks for your time.
You can put it anywhere as long as you have this line (or whatever directory you'd like at the bottom of your UMS.conf file):

Code: Select all

youtube-dl.path = D:\\System\\bin\\youtube-dl.py
or

Code: Select all

youtube-dl.path = D:\\System\\bin\\youtube-dl.exe
I'd recommend just grabbing the .exe version if you didn't install Python yourself.

If you're familiar with DOS you can just type youtube-dl --version to see which version you have. Then type youtube-dl --update to update it to the latest version. Or you can just manually download it from the link above.
黒影
_______________________________________________|_._._._._._._._._._
\______________________________________________|_#_#_#_#_#_#_|
------------------------------------------------------------------|---------------------

R9deLima
Posts: 41
Joined: Tue Jan 08, 2013 9:33 am

Re: Youtube feeds no longer working.

Post by R9deLima » Fri Mar 01, 2013 6:47 pm

SharkHunter and Koroukage, thanks again! My youtube web streams are rolling again. You guys are awesome. Keep up the great work!

User avatar
kuroukage
Posts: 304
Joined: Wed Dec 12, 2012 3:56 pm

Re: Youtube feeds no longer working.

Post by kuroukage » Fri Mar 01, 2013 9:59 pm

@R9deLima

NP. Glad everything is working for you again. :)
黒影
_______________________________________________|_._._._._._._._._._
\______________________________________________|_#_#_#_#_#_#_|
------------------------------------------------------------------|---------------------

Post Reply