PlayStation Vita 'Network Media Player' App Support

Discuss media renderers like Xbox 360, TVs, smartphones, etc.
User avatar
SubJunk
Lead Developer
Posts: 3112
Joined: Sun May 27, 2012 4:12 pm

Re: PlayStation Vita 'Network Media Player' App Support

Post by SubJunk » Tue Nov 04, 2014 2:06 pm

Hmm that's strange since I would think a Microsoft server would be transcoding to WMV.
Most renderers are able to display information about the video they're playing, either by pushing an information button while on the menu, or displaying information during playback. I wonder if the Vita is the same.

Verequies
Posts: 11
Joined: Thu Oct 30, 2014 9:11 pm

Re: PlayStation Vita 'Network Media Player' App Support

Post by Verequies » Tue Nov 04, 2014 3:20 pm

Yeah, the Vita's normal video player app does show some info on it (like the PS3), however the Network Media Player shows nothing.

Verequies
Posts: 11
Joined: Thu Oct 30, 2014 9:11 pm

Re: PlayStation Vita 'Network Media Player' App Support

Post by Verequies » Tue Nov 04, 2014 4:03 pm

I've been doing some more reading on the trace logs, could it be that the audio is not playing instead of the video? I'm pretty sure that the Windows Media Streaming as well as the Vita's Content Manager Assistant both stream the file without any modification.

Code: Select all

TRACE 2014-11-04 13:58:43.865 [New I/O worker #43] Sent to socket: Content-Type: text/xml; charset="utf-8"
TRACE 2014-11-04 13:58:43.865 [New I/O worker #43] Sent to socket: Server: Windows_8.1-amd64-6.3, UPnP/1.0, UMS/4.2.2
TRACE 2014-11-04 13:58:43.865 [New I/O worker #43] Sent to socket: Content-Length: 9517
TRACE 2014-11-04 13:58:44.537 [New I/O server boss #51] Creating new pipeline
TRACE 2014-11-04 13:58:44.542 [New I/O worker #44] Opened request handler on socket /192.168.1.10:65283
TRACE 2014-11-04 13:58:44.542 [New I/O worker #44] Request: HTTP/1.1 : GET : get/0$4$6$1$1$6/Arrow.S03E04.HDTV.x264-LOL.mp4
TRACE 2014-11-04 13:58:44.542 [New I/O worker #44] Matched media renderer "PlayStation Vita" based on address /192.168.1.10
TRACE 2014-11-04 13:58:44.542 [New I/O worker #44] Received on socket: Range: bytes=0-0
TRACE 2014-11-04 13:58:44.542 [New I/O worker #44] Received on socket: Host: 192.168.1.18:5001
TRACE 2014-11-04 13:58:44.542 [New I/O worker #44] Received on socket: User-Agent: libhttp/3.35 (PS Vita)
TRACE 2014-11-04 13:58:44.543 [New I/O worker #44] Received on socket: Connection: Keep-Alive
DEBUG 2014-11-04 13:58:44.543 [New I/O worker #44] HTTP User-Agent: libhttp/3.35 (PS Vita)
TRACE 2014-11-04 13:58:44.543 [New I/O worker #44] Recognized media renderer: PlayStation Vita
TRACE 2014-11-04 13:58:44.543 [New I/O worker #44] HTTP: get/0$4$6$1$1$6/Arrow.S03E04.HDTV.x264-LOL.mp4 / 0-0
TRACE 2014-11-04 13:58:44.543 [New I/O worker #44] discover 0 refresh forced: false
TRACE 2014-11-04 13:58:44.543 [New I/O worker #44] discover 0$4 refresh forced: false
TRACE 2014-11-04 13:58:44.543 [New I/O worker #44] discover 0$4$6 refresh forced: false
TRACE 2014-11-04 13:58:44.543 [New I/O worker #44] discover 0$4$6$1 refresh forced: false
TRACE 2014-11-04 13:58:44.543 [New I/O worker #44] discover 0$4$6$1$1 refresh forced: false
TRACE 2014-11-04 13:58:44.543 [New I/O worker #44] Asked stream chunk : TimeRange [start=null, end=null] of Arrow.S03E04.HDTV.x264-LOL.mp4 and player MEncoder
DEBUG 2014-11-04 13:58:44.543 [New I/O worker #44] Starting transcode/remux of Arrow.S03E04.HDTV.x264-LOL.mp4 with media info: container: mov, bitrate: 777216, size: 239172180, video codec: h264 (High) (avc1 / 0x31637661), duration: 00:41:59.55, width: 720, height: 404, frame rate: 23.98, thumb size : 4705, muxing mode: null, mime type: video/mp4
	Audio track id: 0, lang: und, flavor: null, audio codec: aac (mp4a / 0x6134706D), sample frequency:48000, number of channels: 2, bits per sample: 16, artist: , album: , song name: , year: 0, track: 0
TRACE 2014-11-04 13:58:44.544 [New I/O worker #44] Looking for an audio track with lang: eng
TRACE 2014-11-04 13:58:44.544 [New I/O worker #44] Looking for an audio track with lang: fre
TRACE 2014-11-04 13:58:44.544 [New I/O worker #44] Looking for an audio track with lang: jpn
TRACE 2014-11-04 13:58:44.544 [New I/O worker #44] Looking for an audio track with lang: ger
TRACE 2014-11-04 13:58:44.544 [New I/O worker #44] Looking for an audio track with lang: und
TRACE 2014-11-04 13:58:44.544 [New I/O worker #44] Matched audio track: id: 0, lang: und, flavor: null, audio codec: aac (mp4a / 0x6134706D), sample frequency:48000, number of channels: 2, bits per sample: 16, artist: , album: , song name: , year: 0, track: 0
TRACE 2014-11-04 13:58:44.544 [New I/O worker #44] Searching for a match for: und with eng and off
TRACE 2014-11-04 13:58:44.545 [New I/O worker #44] Searching for a match for: und with * and eng
TRACE 2014-11-04 13:58:44.545 [New I/O worker #44] Searching for a match for: und with * and und
TRACE 2014-11-04 13:58:44.545 [New I/O worker #44] Looking for a subtitle track with lang: eng
TRACE 2014-11-04 13:58:44.545 [New I/O worker #44] Looking for a subtitle track with lang: fre
TRACE 2014-11-04 13:58:44.545 [New I/O worker #44] Looking for a subtitle track with lang: jpn
TRACE 2014-11-04 13:58:44.545 [New I/O worker #44] Looking for a subtitle track with lang: ger
TRACE 2014-11-04 13:58:44.545 [New I/O worker #44] Looking for a subtitle track with lang: und
DEBUG 2014-11-04 13:58:44.545 [New I/O worker #44] Reading mencoder_mux_compatible: default: true, previous: false, current: true
TRACE 2014-11-04 13:58:44.552 [New I/O worker #44] Searching for a match for: und with eng and off
TRACE 2014-11-04 13:58:44.552 [New I/O worker #44] Searching for a match for: und with * and eng
TRACE 2014-11-04 13:58:44.552 [New I/O worker #44] Searching for a match for: und with * and und
TRACE 2014-11-04 13:58:44.553 [New I/O worker #44] Looking for a subtitle track with lang: eng
TRACE 2014-11-04 13:58:44.553 [New I/O worker #44] Looking for a subtitle track with lang: fre
TRACE 2014-11-04 13:58:44.553 [New I/O worker #44] Looking for a subtitle track with lang: jpn
TRACE 2014-11-04 13:58:44.553 [New I/O worker #44] Looking for a subtitle track with lang: ger
TRACE 2014-11-04 13:58:44.553 [New I/O worker #44] Looking for a subtitle track with lang: und
DEBUG 2014-11-04 13:58:44.556 [New I/O worker #44] Creating pipe \\.\pipe\1415073524556ffmpegvideo
DEBUG 2014-11-04 13:58:44.557 [New I/O worker #44] Creating pipe \\.\pipe\1415073524556videoout
DEBUG 2014-11-04 13:58:44.557 [Thread-19] Waiting for pipe connection \\.\pipe\1415073524556ffmpegvideo
DEBUG 2014-11-04 13:58:44.558 [Thread-20] Waiting for pipe connection \\.\pipe\1415073524556videoout
DEBUG 2014-11-04 13:58:44.559 [New I/O worker #44] Starting C:\Program Files (x86)\Universal Media Server\win32\ffmpeg.exe -i C:\Users\Hamish\Videos\TV Shows\Arrow\Season 3\Arrow.S03E04.HDTV.x264-LOL.mp4 -vframes 1 -c:v copy -f h264 -bsf h264_mp4toannexb -an -y pipe:
TRACE 2014-11-04 13:58:44.564 [New I/O worker #44] Successfully initialized buffer to 1,048,576 bytes.
DEBUG 2014-11-04 13:58:44.564 [New I/O worker #44] Attaching thread: ffmpeg.exe-2
DEBUG 2014-11-04 13:58:44.611 [ffmpeg.exe-2-2] ffmpeg version N-66860-g5552594 Copyright (c) 2000-2014 the FFmpeg developers
DEBUG 2014-11-04 13:58:44.611 [ffmpeg.exe-2-2]   built on Oct 15 2014 00:05:18 with gcc 4.9.1 (GCC)
DEBUG 2014-11-04 13:58:44.611 [ffmpeg.exe-2-2]   configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libfreetype --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-zlib
DEBUG 2014-11-04 13:58:44.611 [ffmpeg.exe-2-2]   libavutil      54. 10.100 / 54. 10.100
DEBUG 2014-11-04 13:58:44.611 [ffmpeg.exe-2-2]   libavcodec     56.  5.100 / 56.  5.100
DEBUG 2014-11-04 13:58:44.611 [ffmpeg.exe-2-2]   libavformat    56.  9.100 / 56.  9.100
DEBUG 2014-11-04 13:58:44.611 [ffmpeg.exe-2-2]   libavdevice    56.  1.100 / 56.  1.100
DEBUG 2014-11-04 13:58:44.611 [ffmpeg.exe-2-2]   libavfilter     5.  1.106 /  5.  1.106
DEBUG 2014-11-04 13:58:44.611 [ffmpeg.exe-2-2]   libswscale      3.  1.101 /  3.  1.101
DEBUG 2014-11-04 13:58:44.611 [ffmpeg.exe-2-2]   libswresample   1.  1.100 /  1.  1.100
DEBUG 2014-11-04 13:58:44.611 [ffmpeg.exe-2-2]   libpostproc    53.  3.100 / 53.  3.100
DEBUG 2014-11-04 13:58:44.627 [ffmpeg.exe-2-2] Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'C:\Users\Hamish\Videos\TV Shows\Arrow\Season 3\Arrow.S03E04.HDTV.x264-LOL.mp4':
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]   Metadata:
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]     major_brand     : isom
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]     minor_version   : 1
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]     compatible_brands: isom
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]     creation_time   : 2014-10-29 18:07:27
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]   Duration: 00:41:59.55, start: 0.000000, bitrate: 759 kb/s
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]     Stream #0:0(und): Video: h264 (High) (avc1 / 0x31637661), yuv420p(tv, bt709/unknown/unknown), 720x404, 632 kb/s, 23.98 fps, 23.98 tbr, 24k tbn, 47.95 tbc (default)
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]     Metadata:
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]       creation_time   : 2014-10-29 18:07:27
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]       handler_name    : L-SMASH Video Media Handler
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]       encoder         : AVC Coding
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]     Stream #0:1(und): Audio: aac (mp4a / 0x6134706D), 48000 Hz, stereo, fltp, 122 kb/s (default)
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]     Metadata:
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]       creation_time   : 2014-10-29 18:07:27
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]       handler_name    : GPAC ISO Audio Handler
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2] Output #0, h264, to 'pipe:':
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]   Metadata:
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]     major_brand     : isom
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]     minor_version   : 1
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]     compatible_brands: isom
DEBUG 2014-11-04 13:58:44.628 [ffmpeg.exe-2-2]     encoder         : Lavf56.9.100
DEBUG 2014-11-04 13:58:44.629 [ffmpeg.exe-2-2]     Stream #0:0(und): Video: h264 (avc1 / 0x31637661), yuv420p, 720x404, q=2-31, 632 kb/s, 23.98 fps, 23.98 tbn, 23.98 tbc (default)
DEBUG 2014-11-04 13:58:44.629 [ffmpeg.exe-2-2]     Metadata:
DEBUG 2014-11-04 13:58:44.629 [ffmpeg.exe-2-2]       creation_time   : 2014-10-29 18:07:27
DEBUG 2014-11-04 13:58:44.629 [ffmpeg.exe-2-2]       handler_name    : L-SMASH Video Media Handler
DEBUG 2014-11-04 13:58:44.629 [ffmpeg.exe-2-2]       encoder         : AVC Coding
DEBUG 2014-11-04 13:58:44.629 [ffmpeg.exe-2-2] Stream mapping:
DEBUG 2014-11-04 13:58:44.629 [ffmpeg.exe-2-2]   Stream #0:0 -> #0:0 (copy)
DEBUG 2014-11-04 13:58:44.629 [ffmpeg.exe-2-2] Press [q] to stop, [?] for help
DEBUG 2014-11-04 13:58:44.629 [ffmpeg.exe-2-2] frame=    1 fps=0.0 q=-1.0 Lsize=       1kB time=00:00:00.-4 bitrate=N/A    
DEBUG 2014-11-04 13:58:44.629 [ffmpeg.exe-2-2] 
DEBUG 2014-11-04 13:58:44.629 [ffmpeg.exe-2-2] video:1kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 0.000000%
TRACE 2014-11-04 13:58:44.633 [New I/O worker #44] EOF
TRACE 2014-11-04 13:58:44.634 [New I/O worker #44] Ready to Stop: true
DEBUG 2014-11-04 13:58:44.635 [New I/O worker #44] Creating pipe \\.\pipe\1415073524635ffmpegaudio01
DEBUG 2014-11-04 13:58:44.635 [New I/O worker #44] Creating pipe \\.\pipe\1415073524635audioout
DEBUG 2014-11-04 13:58:44.636 [Thread-26] Waiting for pipe connection \\.\pipe\1415073524635ffmpegaudio01
DEBUG 2014-11-04 13:58:44.636 [Thread-27] Waiting for pipe connection \\.\pipe\1415073524635audioout
DEBUG 2014-11-04 13:58:44.639 [New I/O worker #44] Creating pipe \\.\pipe\1415073524639tsmuxerout.ts
DEBUG 2014-11-04 13:58:44.640 [Thread-29] Waiting for pipe connection \\.\pipe\1415073524639tsmuxerout.ts
DEBUG 2014-11-04 13:58:44.740 [mencoder.exe-3] Starting C:\Program Files (x86)\Universal Media Server\win32\mencoder.exe -ss 0 C:\Users\Hamish\Videos\TV Shows\Arrow\Season 3\Arrow.S03E04.HDTV.x264-LOL.mp4 -quiet -quiet -really-quiet -msglevel statusline=2 -ovc copy -nosound -mc 0 -noskip -of rawvideo -o \\.\pipe\1415073524556ffmpegvideo
TRACE 2014-11-04 13:58:44.745 [mencoder.exe-3] Successfully initialized buffer to 1,048,576 bytes.
DEBUG 2014-11-04 13:58:44.745 [mencoder.exe-3] Attaching thread: mencoder.exe-3
DEBUG 2014-11-04 13:58:44.792 [Thread-19] Result of \\.\pipe\1415073524556ffmpegvideo : true
DEBUG 2014-11-04 13:58:44.840 [mencoder.exe-4] Starting C:\Program Files (x86)\Universal Media Server\win32\mencoder.exe -ss 0 C:\Users\Hamish\Videos\TV Shows\Arrow\Season 3\Arrow.S03E04.HDTV.x264-LOL.mp4 -quiet -quiet -really-quiet -msglevel statusline=2 -channels 6 -ovc copy -of rawaudio -mc 0 -noskip -oac lavc -quiet -quiet -lavcopts acodec=ac3:abitrate=448 -af lavcresample=48000 -srate 48000 -quiet -quiet -o \\.\pipe\1415073524635ffmpegaudio01
TRACE 2014-11-04 13:58:44.845 [mencoder.exe-4] Successfully initialized buffer to 1,048,576 bytes.
DEBUG 2014-11-04 13:58:44.845 [mencoder.exe-4] Attaching thread: mencoder.exe-4
DEBUG 2014-11-04 13:58:44.899 [Thread-26] Result of \\.\pipe\1415073524635ffmpegaudio01 : true
DEBUG 2014-11-04 13:58:44.940 [New I/O worker #44] External input stream instance is null... sounds not good, waiting 500ms
DEBUG 2014-11-04 13:58:44.940 [tsMuxeR-new.exe-5] Starting C:\Program Files (x86)\Universal Media Server\win32\tsMuxeR-new.exe C:\Users\Hamish\AppData\Local\Temp\universalmediaserver\pms-tsmuxer.meta \\.\pipe\1415073524639tsmuxerout.ts
DEBUG 2014-11-04 13:58:44.945 [tsMuxeR-new.exe-5] Reading pipe: \\.\pipe\1415073524639tsmuxerout.ts
TRACE 2014-11-04 13:58:44.953 [tsMuxeR-new.exe-5] Successfully initialized buffer to 52,428,800 bytes.
DEBUG 2014-11-04 13:58:44.953 [tsMuxeR-new.exe-5] Attaching thread: tsMuxeR-new.exe-5
TRACE 2014-11-04 13:58:44.955 [tsMuxeR-new.exe-5-Timer] buffered: 0 bytes / inputs: 0
DEBUG 2014-11-04 13:58:45.009 [Thread-38] Network Optix tsMuxeR.  Version 2.2.3(b). www.networkoptix.com
DEBUG 2014-11-04 13:58:45.212 [Thread-27] Forced reconnection of \\.\pipe\1415073524635audioout with result : true
DEBUG 2014-11-04 13:58:45.212 [Thread-20] Forced reconnection of \\.\pipe\1415073524556videoout with result : true
DEBUG 2014-11-04 13:58:45.212 [Thread-27] Result of \\.\pipe\1415073524635audioout : true
DEBUG 2014-11-04 13:58:45.212 [Thread-20] Result of \\.\pipe\1415073524556videoout : true
DEBUG 2014-11-04 13:58:45.213 [Thread-38] Decoding H264 stream (track 1): Profile: [email protected]  Resolution: 720:404p  Frame rate: 23.976
DEBUG 2014-11-04 13:58:45.213 [Thread-38] Change H264 level from 3.1 to 4.1
DEBUG 2014-11-04 13:58:45.217 [Thread-29] Result of \\.\pipe\1415073524639tsmuxerout.ts : true
DEBUG 2014-11-04 13:58:45.217 [Thread-38] 100.0% complete
DEBUG 2014-11-04 13:58:45.217 [Thread-38] H264 bitstream changed: insert nal unit delimiters
DEBUG 2014-11-04 13:58:45.217 [Thread-38] H264 bitstream changed: insert pict timing and buffering period SEI units
DEBUG 2014-11-04 13:58:45.217 [Thread-38] Decoding AC3 stream (track 2): Bitrate: 448Kbps Sample Rate: 48KHz Channels: 2
DEBUG 2014-11-04 13:58:45.217 [Thread-38] B-pyramid level 1 detected. Shift DTS to 2 frames
TRACE 2014-11-04 13:58:45.440 [New I/O worker #44] Did not send subtitle headers because mediaRenderer.getSubtitleHttpHeader returned either null or blank
TRACE 2014-11-04 13:58:45.440 [StartPlaying Event] Matched media renderer "PlayStation Vita" based on address /192.168.1.10
INFO  2014-11-04 13:58:45.440 [StartPlaying Event] Started playing Arrow.S03E04.HDTV.x264-LOL.mp4 on your PlayStation Vita
DEBUG 2014-11-04 13:58:45.441 [StartPlaying Event] The full filename of which is: C:\Users\Hamish\Videos\TV Shows\Arrow\Season 3\Arrow.S03E04.HDTV.x264-LOL.mp4 and the address of the renderer is: 192.168.1.10
TRACE 2014-11-04 13:58:45.441 [New I/O worker #44] Sent to socket: Content-Type: video/mp4
TRACE 2014-11-04 13:58:45.441 [New I/O worker #44] Sent to socket: Accept-Ranges: bytes
TRACE 2014-11-04 13:58:45.441 [New I/O worker #44] Sent to socket: Connection: keep-alive
TRACE 2014-11-04 13:58:45.441 [New I/O worker #44] Sent to socket: Server: Windows_8.1-amd64-6.3, UPnP/1.0, UMS/4.2.2
TRACE 2014-11-04 13:58:45.481 [New I/O worker #44] Ready to Stop: true
DEBUG 2014-11-04 13:58:45.510 [Thread-38] 100.0% complete
DEBUG 2014-11-04 13:58:45.805 [Thread-38] 100.0% complete
DEBUG 2014-11-04 13:58:46.100 [Thread-38] 100.0% complete
DEBUG 2014-11-04 13:58:46.352 [Thread-38] 100.0% complete
DEBUG 2014-11-04 13:58:46.604 [Thread-38] 100.0% complete
DEBUG 2014-11-04 13:58:46.890 [Thread-38] 100.0% complete
TRACE 2014-11-04 13:58:46.955 [tsMuxeR-new.exe-5-Timer] buffered: 41,500,000 bytes / inputs: 0
DEBUG 2014-11-04 13:58:47.135 [ffmpeg.exe-2-Cleanup] Stopping process: ffmpeg.exe-2
TRACE 2014-11-04 13:58:47.135 [ffmpeg.exe-2-Cleanup] Destroying buffer
DEBUG 2014-11-04 13:58:47.169 [Thread-38] 100.0% complete

SpitFire92
Posts: 5
Joined: Thu Oct 30, 2014 5:55 am

Re: PlayStation Vita 'Network Media Player' App Support

Post by SpitFire92 » Fri Nov 07, 2014 5:53 am

Is there a new thread for the vita support? Or is it useless to try to support vita?

Balmung
Posts: 12
Joined: Thu Oct 09, 2014 8:14 am

Re: PlayStation Vita 'Network Media Player' App Support

Post by Balmung » Fri Nov 07, 2014 6:22 am

No other Thread and no, its not useless, it takes time to find out the Problem. You can't fix things when you don't know exactly what the Problem is and the Vita App made it not easy to find it with no Stream Infos in the App itself.

SpitFire92
Posts: 5
Joined: Thu Oct 30, 2014 5:55 am

Re: PlayStation Vita 'Network Media Player' App Support

Post by SpitFire92 » Sat Nov 08, 2014 5:52 am

Balmung wrote:No other Thread and no, its not useless, it takes time to find out the Problem. You can't fix things when you don't know exactly what the Problem is and the Vita App made it not easy to find it with no Stream Infos in the App itself.

Okay, thank you. I have some free time right now., is there something i couldread about formats and renderers? so i could try to hep?

User avatar
SubJunk
Lead Developer
Posts: 3112
Joined: Sun May 27, 2012 4:12 pm

Re: PlayStation Vita 'Network Media Player' App Support

Post by SubJunk » Fri Nov 14, 2014 3:42 pm

You can try custom FFmpeg options by using the "CustomFFmpegOptions" setting in the renderer file. For example, for Samsung Galaxy phones, we use this:

Code: Select all

CustomFFmpegOptions = -async 1 -fflags +genpts -c:a libmp3lame -ac 2 -b:v 35000k -bufsize 35000k -f matroska
and it lets it work.

Balmung
Posts: 12
Joined: Thu Oct 09, 2014 8:14 am

Re: PlayStation Vita 'Network Media Player' App Support

Post by Balmung » Sat Nov 15, 2014 1:58 am

Btw. This "Network Media Player" App is also available for PlayStation TV (released today in Europe), so it needs a Renderer too (but with the same Settings).

Something new about the Renderer?

User avatar
SubJunk
Lead Developer
Posts: 3112
Joined: Sun May 27, 2012 4:12 pm

Re: PlayStation Vita 'Network Media Player' App Support

Post by SubJunk » Sat Nov 15, 2014 11:11 pm

Balmung wrote:Btw. This "Network Media Player" App is also available for PlayStation TV (released today in Europe), so it needs a Renderer too (but with the same Settings).

Something new about the Renderer?
It would be great if someone can send us logs from the PlayStation TV one so we can grab the identifying stuff from it :)

jujitsuka
Posts: 3
Joined: Mon Nov 17, 2014 8:18 am

Re: PlayStation Vita 'Network Media Player' App Support

Post by jujitsuka » Tue Nov 18, 2014 8:42 am

I can send you a trace log from me trying the Network Media Player app on a PS Vita - what's the best way of getting it to you?

I've also just got the PS TV, so I can send you logs for that too.

I can't message you as I've just registered.

Post Reply