Jumpy Plugin (26 October 2016)

Discuss third party additions, plugins and translations for Universal Media Server
Post Reply
infidel
Developer
Posts: 571
Joined: Thu Jul 12, 2012 5:37 am

Re: Jumpy Plugin (19 Nov 2012)

Post by infidel » Sun Dec 23, 2012 5:01 pm

slipwind wrote:but nothing with regards to xbmc shows up even though I have it properly installed. I found the following error message...
Jumpy can't locate your xbmc program folder because the Windows system variables %ProgramFiles% and/or %ProgramFiles(x86)% don't seem to be set, so the questions are what version of Windows are you running and what's the path to your xbmc program folder? It would be very helpful if you attach (in one zip file):
  • full debug logs
  • your jumpy install log which is at plugins\jumpy\win32-setup\setup.log
  • the output from running the following command (if you're familiar with using the cmd console)

    Code: Select all

    set
EDIT: if you're running XP, try changing ProgramFiles to uppercase in plugins/jumpy/xbmc/xbmcinit.py, line 24:
(os.getenv('PROGRAMFILES') if platform.release() == 'XP' \

slipwind
Posts: 3
Joined: Sun Dec 23, 2012 10:56 am

Re: Jumpy Plugin (19 Nov 2012)

Post by slipwind » Mon Dec 24, 2012 6:02 am

Thank you for your help infidel. Here is the information you requested in the form of a zip.

Additional info: I am running Windows 7 currently, and the path to my XBMC is C:\Program Files\XBMC
Attachments
pms_dbg_slipwind.zip
(127.28 KiB) Downloaded 131 times

infidel
Developer
Posts: 571
Joined: Thu Jul 12, 2012 5:37 am

Re: Jumpy Plugin (19 Nov 2012)

Post by infidel » Mon Dec 24, 2012 6:52 am

slipwind wrote:Here is the information you requested
Thanks for the very thorough submission :). It's not immediately clear why you're getting this error in Win7, but you should be able to work around it by adding the following lines to your PMS.conf:

Code: Select all

xbmc.main.path =  C:\\Program Files\\XBMC
xbmc.path =  C:\\Users\\<your user name here>\\AppData\\Roaming\\XBMC
EDIT: you've got 32bit win7 and Jumpy's looking up the wrong variable. Try replacing plugins/jumpy/xbmc/xbmcinit.py with this one (without the workaround above):

[attachment removed] - superceded by jumpy-0.2.5
Last edited by infidel on Fri Jan 18, 2013 3:08 am, edited 1 time in total.

slipwind
Posts: 3
Joined: Sun Dec 23, 2012 10:56 am

Re: Jumpy Plugin (19 Nov 2012)

Post by slipwind » Mon Dec 24, 2012 8:05 am

Perfect. That solved everything. Thank you for the help!

User avatar
kuroukage
Posts: 304
Joined: Wed Dec 12, 2012 3:56 pm

Re: Jumpy Plugin (19 Nov 2012)

Post by kuroukage » Fri Jan 04, 2013 11:28 pm

Hello,

I'm using latest build of UMS, Jumpy, XBMC, etc. Running Windows 7 x64 and getting this error for both Vimeo and Youtube plugins.

Code: Select all

YouTube-4.4.1
CommonFunctions-2.5.1
Traceback (most recent call last):
  File "C:\Users\kuroukage\AppData\Roaming\XBMC\addons\plugin.video.youtube\default.py", line 106, in <module>
    params = common.getParameters(sys.argv[2])
  File "C:\Users\kuroukage\AppData\Roaming\XBMC\addons\script.module.parsedom\lib\CommonFunctions.py", line 111, in getParameters
    if getXBMCVersion() >= 12.0:
  File "C:\Users\kuroukage\AppData\Roaming\XBMC\addons\script.module.parsedom\lib\CommonFunctions.py", line 103, in getXBMCVersion
    version = float(version)
ValueError: could not convert string to float:

Code: Select all

Vimeo-3.5.1
CommonFunctions-2.5.1
Traceback (most recent call last):
  File "C:\Users\kuroukage\AppData\Roaming\XBMC\addons\plugin.video.vimeo\default.py", line 96, in <module>
    params = common.getParameters(sys.argv[2])
  File "C:\Users\kuroukage\AppData\Roaming\XBMC\addons\script.module.parsedom\lib\CommonFunctions.py", line 111, in getParameters
    if getXBMCVersion() >= 12.0:
  File "C:\Users\kuroukage\AppData\Roaming\XBMC\addons\script.module.parsedom\lib\CommonFunctions.py", line 103, in getXBMCVersion
    version = float(version)
ValueError: could not convert string to float:
Any idea on how to fix this? Help would be much appreciated. :)

Thanks,
kurou
黒影
_______________________________________________|_._._._._._._._._._
\______________________________________________|_#_#_#_#_#_#_|
------------------------------------------------------------------|---------------------

infidel
Developer
Posts: 571
Joined: Thu Jul 12, 2012 5:37 am

Re: Jumpy Plugin (19 Nov 2012)

Post by infidel » Sat Jan 05, 2013 4:07 am

kuroukage wrote:Any idea on how to fix this?
Congratulations on hitting two bugs with one stone here, in jumpy and in the addon too :). Things should go back to normal if you replace the files in plugins/jumpy/xbmc/ with these:

[attachment removed] - superceded by jumpy-0.2.5

All other fixes since the last release are included, I should be releasing a new version fairly soon.
Last edited by infidel on Fri Jan 18, 2013 3:09 am, edited 1 time in total.

Penda
Posts: 9
Joined: Wed Dec 12, 2012 3:32 pm

Re: Jumpy Plugin (19 Nov 2012)

Post by Penda » Sat Jan 05, 2013 5:34 pm

one of the urlresolver plugins (vidxden.py) got updated and messed up jumpy.

Code: Select all

 class InputWindow(xbmcgui.WindowDialog):# Cheers to Bastardsmkr code already done in Putlocker PRO resolver.
AttributeError: 'module' object has no attribute 'WindowDialog'
I had to comment out that whole class so that one of my plugins would load. It runs fine on xbmc. Maybe jumpy's xbmcgui is not updated?


Also wondering if anyone knows why a lot (all?) of my rtmp streams keeps getting this error.
"D:\Universal Media Server\win32\mencoder.exe has a return code of 1!"
Edit: Switching back to version 2.2.0 fixed it for me.

infidel
Developer
Posts: 571
Joined: Thu Jul 12, 2012 5:37 am

Re: Jumpy Plugin (19 Nov 2012)

Post by infidel » Sat Jan 05, 2013 8:35 pm

Penda wrote:one of the urlresolver plugins (vidxden.py) got updated and messed up jumpy.... Maybe jumpy's xbmcgui is not updated?
Here's an updated xbmcgui.py that gets me past your error, but all the working vidxden links I tried failed due to captcha. Try it and report back (with complete logs if you still get errors so I'll have some links to work from).

[attachment removed] - superceded by jumpy-0.2.5
Last edited by infidel on Fri Jan 18, 2013 3:10 am, edited 1 time in total.

User avatar
kuroukage
Posts: 304
Joined: Wed Dec 12, 2012 3:56 pm

Re: Jumpy Plugin (19 Nov 2012)

Post by kuroukage » Sat Jan 05, 2013 11:50 pm

Hey, thanks for the quick fix/reply. I'm finding I'm running into another problem as well (due to being logged into Youtube):

Code: Select all

YouTube-4.4.1
CommonFunctions-2.5.1
Traceback (most recent call last):
  File "C:\Users\kuroukage\AppData\Roaming\XBMC\addons\plugin.video.youtube\default.py", line 109, in <module>
    navigation.executeAction(params)
  File "C:\Users\kuroukage\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeNavigation.py", line 144, in executeAction
    self.player.playVideo(params)
  File "C:\Users\kuroukage\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubePlayer.py", line 81, in playVideo
    (video, status) = self.buildVideoObject(params)
  File "C:\Users\kuroukage\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubePlayer.py", line 284, in buildVideoObject
    (links, video) = self.extractVideoLinksFromYoutube(video, params)
  File "C:\Users\kuroukage\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubePlayer.py", line 377, in extractVideoLinksFromYoutube
    result = self.getVideoPageFromYoutube(get)
  File "C:\Users\kuroukage\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubePlayer.py", line 361, in getVideoPageFromYoutube
    page = self.core._fetchPage({u"link": self.urls[u"video_stream"] % get(u"videoid"), "login": login})
  File "C:\Users\kuroukage\AppData\Roaming\XBMC\addons\plugin.video.youtube\YouTubeCore.py", line 451, in _fetchPage
    tcookies = eval(self.settings.getSetting("login_cookies"))
  File "<string>", line 1
If I use the fix without my account it will work, but when I use a l/p this will happen with both Youtube and Vimeo. Looking forward to a new release of Jumpy. :)

Thanks,
kurou
黒影
_______________________________________________|_._._._._._._._._._
\______________________________________________|_#_#_#_#_#_#_|
------------------------------------------------------------------|---------------------

infidel
Developer
Posts: 571
Joined: Thu Jul 12, 2012 5:37 am

Re: Jumpy Plugin (19 Nov 2012)

Post by infidel » Sun Jan 06, 2013 3:40 am

kuroukage wrote:If I use the fix without my account it will work, but when I use a l/p this will happen with both Youtube and Vimeo.
kurou, would you please attach a zip with your complete jumpy.log? The problem with posting snippets is that there's not necessarily enough context to reproduce the error.

Note that the updated version above attempts to hide any setting that looks like a login/pw as '####' in jumpy.log, but double check by searching for your actual l/p and overwrite if necessary.

Post Reply