Profile for renderer Samsung 4K (UHD SUHD)

Discuss media renderers like Xbox 360, TVs, smartphones, etc.

callahan
Posts: 4
Joined: Thu Feb 23, 2017 11:14 pm

Re: Profile for renderer Samsung 4K (UHD SUHD)

Post by callahan » Sun Feb 26, 2017 11:42 pm

Sami32 wrote:Hi callahan,

just follow these steps:
viewtopic.php?f=9&t=556
Hi Sami32,
sorry, of course . . .
Logs are attached now. I also found out, that some other 4k-files doesn´t work at all.
Attachments
ums_dbg.zip
(74.45 KiB) Downloaded 105 times

User avatar
Sami32
Posts: 852
Joined: Mon Apr 11, 2016 5:09 am

Re: Profile for renderer Samsung 4K (UHD SUHD)

Post by Sami32 » Mon Feb 27, 2017 12:54 pm

Hi Callahan,

Make FFmpeg video engine as your first choice engine. Using MEncoder, old and poorly maintened, will only give you problem.

From the "Transcoding settings" tab select "FFmpeg" and deselect "Defer to MEncoder when transcoding problematic issue".
You can set "MEncoder" as your third choice video files engines or disabled it if you prefer.

If you still get issue, don't forget to join your new trace log.

callahan
Posts: 4
Joined: Thu Feb 23, 2017 11:14 pm

Re: Profile for renderer Samsung 4K (UHD SUHD)

Post by callahan » Tue Feb 28, 2017 1:12 am

Hi Sami32,

I did the changes you recommend but I didn´t change the behaviour.
I found one sample-movie which is working but ´some other are stuttering and the most are not working at all.
Log is attached.
Attachments
ums_dbg.zip
(78.56 KiB) Downloaded 105 times

User avatar
Sami32
Posts: 852
Joined: Mon Apr 11, 2016 5:09 am

Re: Profile for renderer Samsung 4K (UHD SUHD)

Post by Sami32 » Thu Mar 02, 2017 5:35 am

Hi callahan,

That's normal, as you use a not appropriate renderer, though i think that something else occur.

Try this renderer, as it will give you less transcoding issues: (delete the .txt extension)
Samsung-UHD.conf.txt
(4.26 KiB) Downloaded 270 times
To avoid the stuttering with the transcoded files, you can add some parameters, or to avoid videos having unsupported audio TrueHD/DTS-HD (MA or 8 channels) or subtitles (PGS...though you can disable them or use external supported ones instead).
Try to add these parameters in the Mencoder video files engines custom option found into "Transcoding settings" tab:

Code: Select all

-vf scale=1920:1080
And select "Remux videos with tsMuxeR when possible instead of transcoding".

That way, you'll see correctly the supported videos with FFmpeg by default, and the one stuttering should be tried with MEncoder engine, and hopefully give you some playing improvements.

Please, take time to return feedback ;)
Don't forget to join a new log if you report some issues.

P.S. As a side note, you can delete this line

Code: Select all

fix_25fps_av_mismatch=true
from your UMS.conf file, except if you really need it of course.

EDIT: You can try to delete the MEncoder custom parameters already set, and select the "Skip loop filter deblocking for H.264" option.

callahan
Posts: 4
Joined: Thu Feb 23, 2017 11:14 pm

Re: Profile for renderer Samsung 4K (UHD SUHD)

Post by callahan » Fri Mar 03, 2017 10:20 am

Hi Sami
Sami32 wrote: That's normal, as you use a not appropriate renderer, though i think that something else occur.

Try this renderer, as it will give you less transcoding issues: (delete the .txt extension)
ums_dbg.zip
(97.7 KiB) Downloaded 119 times
done
To avoid the stuttering with the transcoded files, you can add some parameters, or to avoid videos having unsupported audio TrueHD/DTS-HD (MA or 8 channels) or subtitles (PGS...though you can disable them or use external supported ones instead).
Try to add these parameters in the Mencoder video files engines custom option found into "Transcoding settings" tab:

Code: Select all

-vf scale=1920:1080
And select "Remux videos with tsMuxeR when possible instead of transcoding".
done

But all the settings hasn´t changed anything :-(
Same behaviour as before. Maybe I am too stupid . . . .
Don't forget to join a new log if you report some issues.
done :-)
P.S. As a side note, you can delete this line

Code: Select all

fix_25fps_av_mismatch=true
from your UMS.conf file, except if you really need it of course.
I cannot find this line in UMS.conf file . . . (?)
EDIT: You can try to delete the MEncoder custom parameters already set, and select the "Skip loop filter deblocking for H.264" option.
done, but seemes to be without effect . . .

User avatar
Sami32
Posts: 852
Joined: Mon Apr 11, 2016 5:09 am

Re: Profile for renderer Samsung 4K (UHD SUHD)

Post by Sami32 » Fri Mar 03, 2017 2:28 pm

Hello callahan,

Code: Select all

fix_25fps_av_mismatch=true
is in your UMS.conf, not the one inside your UniversalMediaServer program folder but inside the one in the Documents and Settings\All Users\UMS folder.
You can also edit it from UMS GUI, in the "General Configuration" tab select "Edit UMS configuration file manually" and go to the end of the file.

I updated the renderer:
Samsung-UHD.conf
(4.26 KiB) Downloaded 235 times
Though your issue seem to be a bandwidth or/and CPU issue.
Could you confirm that [2160p] 4K-HD.Club-2013-Taipei 101 Fireworks Trailer (4ksamples.com).mp4 is stuttering while streamed from UMS ?
And that your movies are playing fine from a USB or HDD ?

For testing purpose only, set the maximum bandwidth in the "General Configuration" tab to 30 MB/s, and if any improvements occur try to increase this value until you get stuttering. The stuttering increase or decrease should fix us.

If it's a CPU power resource issue, as i suspect, i'm afraid that your choice will resume to decrease the video dimensions or the video quality. You already know how to change the 2 dimensions value in your renderer configuration, so if you absolutely want see your movies in UHD with this computer the FFmpeg customs parameters should be set accordingly.

alesk76
Posts: 8
Joined: Fri Oct 21, 2016 8:46 am

Re: Profile for renderer Samsung 4K (UHD SUHD)

Post by alesk76 » Sat Mar 25, 2017 7:23 am

Hi,

I have now new TV Samsung UE65KS9002T and I still have problems with playing x265 mkv files..:(
for test I have try: (I also have original Blu Ray)
The Revenant (2015) 4K UltraHD BluRay HEVC x265 DTS-HD 7.1 [Zeus-n-Duke].mkv
but I have get error and offer me to skip this file...

please for helping me out and tell me which config do I have to use that I could see that kind of files...

best regards to all

User avatar
Sami32
Posts: 852
Joined: Mon Apr 11, 2016 5:09 am

Re: Profile for renderer Samsung 4K (UHD SUHD)

Post by Sami32 » Sat Mar 25, 2017 9:01 am

Hi alesk76,

you should try that renderer.

Edit the file and uncomment these lines:

Code: Select all

#MaxVideoWidth = 3840
#MaxVideoHeight = 2160
And modify this line as following:

Code: Select all

H264Level41Limited = false
If you still get issue, just click on the red link in my signature and read the 3 first comments.

alesk76
Posts: 8
Joined: Fri Oct 21, 2016 8:46 am

Re: Profile for renderer Samsung 4K (UHD SUHD)

Post by alesk76 » Sat Mar 25, 2017 10:41 pm

@ Sami32

thx for helping me out.. all the moveies now Works fine...

but there are two problems:
1. I have a movie /*mkv file and subttiles file / *sub
and now when I run the film I have three sbutitle /english-i think is inside the mkv file / slovenianin one font and another slovenian in different font

2. also I can not do fast forward it goes by scale but when for example then I press play at 34min throw me back to begining of the movie

best rgards

I ihave i5/ 16GB /SSD/ 100/1000 network connection drives and Windows 10 pro

thx again for helping me

Post Reply