UMS freezes while 'cleaning up database'

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
eniomarques
Posts: 10
Joined: Mon Feb 06, 2017 1:19 pm

UMS freezes while 'cleaning up database'

Post by eniomarques » Mon Dec 10, 2018 1:28 pm

Hello, I'm recently having some problems with v7.6.2, where it freezes while 'cleaning up databases' with 100%.

It already happened 3 times, and only resolves when restarting the computer, and killing the javaw.exe process doesn't help.

When I open UMS, I can normally navigate the media server on my TV for a short period of time, but then it suddenly stops, and then the UMS is always showing the message below.

Image

Logs/conf attached
Attachments
ums_dbg.zip
(1.11 MiB) Downloaded 39 times

User avatar
SubJunk
Lead Developer
Posts: 2943
Joined: Sun May 27, 2012 4:12 pm

Re: UMS freezes while 'cleaning up database'

Post by SubJunk » Tue Dec 11, 2018 8:10 am

Thanks for this, it looks like we need to add some more logging to that cleanup feature, if I add some can I get you to re-test and post logs from the test version?

LouRawls
Posts: 1
Joined: Sun Dec 16, 2018 12:36 pm

Re: UMS freezes while 'cleaning up database'

Post by LouRawls » Sun Dec 16, 2018 12:58 pm

I'm seeing this too. The program does not hang but the status bar loops through "cleaning up database" over and over. I let it go for over and hour. The Memory Usage (MB) bar jumps around all over the place. Always before it was quite stable. Within a few minutes, the task manage reports java at 1.5 g which it think is the maximum.
------------------------
In share settings, I turned off "scan shared folders at startup" and I "think" it stopped.

User avatar
SubJunk
Lead Developer
Posts: 2943
Joined: Sun May 27, 2012 4:12 pm

Re: UMS freezes while 'cleaning up database'

Post by SubJunk » Mon Dec 17, 2018 1:40 pm

Did it start in 7.6 or 7.5?

eniomarques
Posts: 10
Joined: Mon Feb 06, 2017 1:19 pm

Re: UMS freezes while 'cleaning up database'

Post by eniomarques » Thu Dec 20, 2018 1:49 pm

SubJunk wrote:
Tue Dec 11, 2018 8:10 am
Thanks for this, it looks like we need to add some more logging to that cleanup feature, if I add some can I get you to re-test and post logs from the test version?
sure! I believe it started in 7.6, not sure.
In share settings, I turned off "scan shared folders at startup" and I "think" it stopped.
yeah, it seems to work, and the program starts way faster, thanks

Post Reply