Version 9.0.0-b1 released

Announcements about Universal Media Server
Post Reply
User avatar
SubJunk
Lead Developer
Posts: 2933
Joined: Sun May 27, 2012 4:12 pm

Version 9.0.0-b1 released

Post by SubJunk » Sun Jul 28, 2019 7:32 pm

General:

In this release, we no longer require Java to be installed, at any time.
We are particularly interested in Linux users because we have done the least testing of this change on there

Other notable changes are improvements to Chromecast and Cover Art Archive support, bugfixes, and other minor improvements.


Download:

Windows
macOS
Linux

Changes since 8.2.0:
  • General:
    • We no longer require Java installation on any operating system
    • Added new renderer setting vbd (video bit depth) to allow filetype-specific bit-depth support configuration
    • Fixed filename prettifying not displaying episode names and other related problems
    • Fixed the PrependTrackNumbers renderer setting (thanks, tcely!)
  • Languages:
    • Fixed broken "hide engines" string
    • Updated translations via Crowdin:
      • Chinese Simplified updated
      • French translation updated
      • German translation updated
      • Hungarian translation updated
      • Italian translation updated
      • Japanese translation updated
      • Norwegian translation updated
      • Polish translation updated
      • Portuguese (Brazilian) translation updated
      • Romanian translation updated
      • Russian translation updated
      • Spanish translation updated
      • Swedish translation updated
  • Dependencies:
    • Updated Chromecast api-v2 to 0.11.0
    • Updated fm.last coverartarchive-api to 2.1.1
    • Updated icu4j to 64.2
    • Updated JNA to 5.3.1
    • Updated Oshi to 3.13.3
    • Updated Surefire to 2.22.2

Compatibility notes:

The Windows releases work on Windows Vista onwards.
The macOS versions require 64-bit macOS/OS X.

User avatar
pipin
Posts: 91
Joined: Fri Dec 28, 2012 12:17 am

Re: Version 9.0.0-b1 released

Post by pipin » Sun Jul 28, 2019 10:01 pm

Hi,

thanks for the release, but why going to 9.0.0?

Could have been 8.5.0 too. Or is it due to the java thingie?

I hope you won't inflate release numbers like Mozilla did with firefox.

From 5.0 to 7.0 it took 3 years,

From 7.0 to 9.0. about one and a half.
Regards,
Jens
-----------
Devices used with UMS : - Windows 10 PC, Samsung UE32 F4580SS, Samsung UE48H6600

erick diangilis
Posts: 161
Joined: Sun May 22, 2016 8:25 am

Re: Version 9.0.0-b1 released

Post by erick diangilis » Mon Jul 29, 2019 2:57 am

hi subjunk thanks for the new release also for those who helped building it. i've downloaded the the ums 9b1 for windows a couple of times and tried a lots of options but i couldn't make the software run after instalation i don't know what's going on so i went back to 8.2.0 and its working fine the download process is ok and also could install it but after finishing instalation the software is not running is just closes and the others screens like to choose language and other options is not showing up as is suppose to do it.

do you have any suggestions or it's a software problem and there is nothing a i can do to fix it?

User avatar
SubJunk
Lead Developer
Posts: 2933
Joined: Sun May 27, 2012 4:12 pm

Re: Version 9.0.0-b1 released

Post by SubJunk » Mon Jul 29, 2019 8:41 pm

pipin wrote:
Sun Jul 28, 2019 10:01 pm
Hi,

thanks for the release, but why going to 9.0.0?

Could have been 8.5.0 too. Or is it due to the java thingie?

I hope you won't inflate release numbers like Mozilla did with firefox.

From 5.0 to 7.0 it took 3 years,

From 7.0 to 9.0. about one and a half.
:lol: yes it's because of Java, it is a major thing from our perspective and the major version bump makes that known. We mostly use Semver https://semver.org/
erick diangilis wrote:
Mon Jul 29, 2019 2:57 am
hi subjunk thanks for the new release also for those who helped building it. i've downloaded the the ums 9b1 for windows a couple of times and tried a lots of options but i couldn't make the software run after instalation i don't know what's going on so i went back to 8.2.0 and its working fine the download process is ok and also could install it but after finishing instalation the software is not running is just closes and the others screens like to choose language and other options is not showing up as is suppose to do it.

do you have any suggestions or it's a software problem and there is nothing a i can do to fix it?
You're right, the Windows beta is totally broken. I'm working on a fix now and will post here when it's ready


janvs
Posts: 1
Joined: Mon Jul 29, 2019 9:54 pm

Re: Version 9.0.0-b1 released

Post by janvs » Mon Jul 29, 2019 10:07 pm

Thanks SubJunk,

Testing this on linux it still seems to prefer the user installed jre, the bundled jre doesn't get called because UMS.sh tests for the included jre-x{86|64}/bin/java to be a directory (which it isn't).
Also the supplied 64bit jre isn't set as executable in the supplied tarball. Any reason why the preferred method is now to include java?

//edit: Changing these bits in UMS.sh makes it use the bundled jre for me:

Code: Select all

# Use our JVM if it exists
if [ "$(uname -m | grep '64')" != "" ]; then
    if [ -x linux/jre-x64/bin/java ]; then 
        JAVA="linux/jre-x64/bin/java"
    fi
else
    if [ -x linux/jre-x86/bin/java ]; then 
        JAVA="linux/jre-x86/bin/java"
    fi
fi

erick diangilis
Posts: 161
Joined: Sun May 22, 2016 8:25 am

Re: Version 9.0.0-b1 released

Post by erick diangilis » Tue Jul 30, 2019 7:06 am

hi subjunk thanks for fix to the Windows version. i've downloaded and installled successfully and took sometime testing as well on the ps4 pro media player for a beta it's working pretty fine and very stable the slow downs that what i was having before on some vídeos almost vanished wich i appreciate it. i'm using wired on a gigabit network with cat 7 cables, the playback quality is very nice and clean the sound encoding to dts wich i usually prefer on settings is also nice. the playback in diffrent resolutions and fps worked very smoothly with a little hiccups here and there but since its an incomplete version i can comprehend. the other stuff as series, movies music and photos are also working ok. the 3d playback is also good and clean. i'll continuing testing for more days if i notice something i'll let you know but for now i'm very pleased with the unfinished software. before i forget i'm using the latest java 8 update 221 that came out recently.


thanks again and keep up with the good work have a nice week. :D

User avatar
SubJunk
Lead Developer
Posts: 2933
Joined: Sun May 27, 2012 4:12 pm

Re: Version 9.0.0-b1 released

Post by SubJunk » Tue Jul 30, 2019 7:58 am

janvs wrote:
Mon Jul 29, 2019 10:07 pm
Thanks SubJunk,

Testing this on linux it still seems to prefer the user installed jre, the bundled jre doesn't get called because UMS.sh tests for the included jre-x{86|64}/bin/java to be a directory (which it isn't).
Also the supplied 64bit jre isn't set as executable in the supplied tarball. Any reason why the preferred method is now to include java?

//edit: Changing these bits in UMS.sh makes it use the bundled jre for me:

Code: Select all

# Use our JVM if it exists
if [ "$(uname -m | grep '64')" != "" ]; then
    if [ -x linux/jre-x64/bin/java ]; then 
        JAVA="linux/jre-x64/bin/java"
    fi
else
    if [ -x linux/jre-x86/bin/java ]; then 
        JAVA="linux/jre-x86/bin/java"
    fi
fi
Thanks for reporting this janvs, that fix is in the b2 release now.
We have been seeing an increase in errors caused by newer Java versions because they keep changing how it works, so this is the best way we can maintain stability instead of having to keep reacting to broken things.
erick diangilis wrote:
Tue Jul 30, 2019 7:06 am
hi subjunk thanks for fix to the Windows version. i've downloaded and installled successfully and took sometime testing as well on the ps4 pro media player for a beta it's working pretty fine and very stable the slow downs that what i was having before on some vídeos almost vanished wich i appreciate it. i'm using wired on a gigabit network with cat 7 cables, the playback quality is very nice and clean the sound encoding to dts wich i usually prefer on settings is also nice. the playback in diffrent resolutions and fps worked very smoothly with a little hiccups here and there but since its an incomplete version i can comprehend. the other stuff as series, movies music and photos are also working ok. the 3d playback is also good and clean. i'll continuing testing for more days if i notice something i'll let you know but for now i'm very pleased with the unfinished software. before i forget i'm using the latest java 8 update 221 that came out recently.


thanks again and keep up with the good work have a nice week. :D
Thanks for confirming the fix erick. You can uninstall Java now if you want to, if it is not used by any other programs :)

User avatar
pipin
Posts: 91
Joined: Fri Dec 28, 2012 12:17 am

Re: Version 9.0.0-b1 released

Post by pipin » Tue Jul 30, 2019 9:08 am

SubJunk wrote:
Mon Jul 29, 2019 8:41 pm
:lol: yes it's because of Java, it is a major thing from our perspective and the major version bump makes that known. We mostly use Semver https://semver.org/
Ok, thanks for the info. :)
Regards,
Jens
-----------
Devices used with UMS : - Windows 10 PC, Samsung UE32 F4580SS, Samsung UE48H6600

Post Reply